
      

Online Help  
 

 

 

RT-Eye® Serial Compliance and Analysis 
Application 
  

077-0021-00 
Adapted from the RT-Eye Online Help, Version 3.0.0  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
www.tektronix.com





      

 

Copyright © Tektronix. All rights reserved. Licensed software products are owned by Tektronix or its suppliers 
and are protected by United States copyright laws and international treaty provisions. 

Tektronix products are covered by U.S. and foreign patents, issued and pending. Information in this publication 
supercedes that in all previously published material. Specifications and price change privileges reserved. 

TEKTRONIX and TEK are registered trademarks of Tektronix, Inc. 

RT-Eye Serial Data Compliance and Analysis Online Help, 076-0059-00, Version 3.0.0 

 

Contacting Tektronix 

Tektronix, Inc. 

14200 SW Karl Braun Drive or P.O. Box 500 

Beaverton, OR 97077 USA 

 

For product information, sales, service, and technical support: 

• In North America, call 1-800-833-9200. 

• Worldwide, visit www.tektronix.com to find contacts in your area. 





 

RT-Eye ® Serial Compliance and Analysis Application 
      

i

General Safety Summary ...............................................................................xv 

Welcome to the RT-Eye
®

 Serial Compliance                    ...............      
and Analysis Application .............................................................. xvii 

Five-Time Free Trial.................................................................................. xviii 
Related Documentation.............................................................................. xviii 
GPIB Information .........................................................................................xix 
Relevant Web Sites.......................................................................................xix 
Application CD Contents...............................................................................xx 
Access to PDF Files......................................................................................xxi 
Conventions ................................................................................................ xxii 
Types of Online Help Information............................................................. xxiii 
Using Online Help ......................................................................................xxiv 
Online Help for the Report Generator .........................................................xxv 
Online Help for Compliance Modules.........................................................xxv 
Find Tab and Searches ................................................................................xxvi 
Feedback .....................................................................................................xxvi 

General Information .............................................................................xxvi 
Application-Specific Information....................................................... xxvii 

Getting Started................................................................................ 1 

Product Description .........................................................................................1 
Analysis and Compliance Modules .................................................................2 
Compatibility ...................................................................................................2 
Requirements and Restrictions ........................................................................3 
Minimum Required System Configuration......................................................4 
Accessories ......................................................................................................4 
Installation .......................................................................................................4 
Connecting to a Device Under Test (DUT) .....................................................5 
Probe Information ............................................................................................5 
Power Spectrum of a 2.5 Gb/sec Signal Example ...........................................6 
Two TCA-to-SMA Adaptors, Diagram A .......................................................6 
One P73XX SMA Differential Probe, Diagram B...........................................7 
Two P72XX Single-Ended or P73XX Differential Probes, Diagram C ..........7 
One P73XX Differential Probe, Diagram D ....................................................8 



Table of Contents 

 

ii                RT-Eye ®Serial Compliance and Analysis Application 

Deskewing Probes and Channels .....................................................................8 

Operating Basics............................................................................. 9 

About Basic Operations ...................................................................................9 
Starting the Application .................................................................................10 
Oscilloscope Menu Bar and Selected Application.........................................11 
Application Interface .....................................................................................11 
User Interface Definitions..............................................................................12 
Menu With Application User Interface Items................................................13 
Application Menu Bar and Drop-Down Lists................................................14 

Using Basic Oscilloscope Functions .......................................................14 
Returning to the Application ...................................................................15 
Hiding the Application ............................................................................15 
Minimizing and Maximizing the Application .........................................15 
Exiting the Application ...........................................................................15 
Docking the Application .........................................................................16 
Undocking the Application .....................................................................16 
Application Directories ...........................................................................17 
Directory Structure for the Serial Analysis Application .........................18 
File Name Extensions..............................................................................19 
How to Enter Alphanumerical Values.....................................................20 
Virtual Keypad ........................................................................................21 
Virtual Keyboard.....................................................................................22 

Using MyTest ................................................................................................22 
About My Test.........................................................................................22 
Saving MyTest ........................................................................................23 
Running MyTest......................................................................................23 

Using Serial Data Wizard ..............................................................................24 
About the Serial Data Wizard .................................................................24 
Probe type................................................................................................25 
Measurement Sources .............................................................................26 
Standards Selection .................................................................................27 
Measurement Categories .........................................................................28 
Autoset Source Levels.............................................................................29 
Autoset Source Reference Levels............................................................30 



Table of Contents 

RT-Eye ® Serial Compliance and Analysis Application  iii

Plots.........................................................................................................30 
File Menus .....................................................................................................33 

File Menu Definitions .............................................................................33 
About the File menus ..............................................................................34 
Saving a Setup File..................................................................................34 
File: Save Browser ..................................................................................35 
Recalling a Saved Setup File...................................................................36 
File: Recall Browser................................................................................37 
Recalling the Default Setup.....................................................................38 
Recalling a Recently Saved or Accessed Setup File ...............................38 
Recall Recent Drop-Down List Example................................................39 
Defining Preferences ...............................................................................39 
File Preferences Options .........................................................................40 
File: Preferences Menu............................................................................40 

Setting up the Application .............................................................................41 
About Setting up the Application for Analysis .......................................41 
General Steps to Set Up the Application.................................................42 
Selecting an Analysis or Compliance Module ........................................43 
Selecting the Analysis Module................................................................43 
Selecting a Compliance Module..............................................................44 
Choosing the Probe Configuration ..........................................................44 
Probe Type Definitions ...........................................................................45 
Selecting a Measurement ........................................................................45 
Measurement Definitions ........................................................................46 
Measurements: Select Menu for Differential Probes ..............................47 
Measurements: Select Menu for Single-Ended Probes ...........................47 
Autoset Button in the Measurements Select Menu .................................48 
Autoset Summary Menu Options ............................................................48 
Autoset Summary Menu Example ..........................................................49 

Configuring a Measurement ..........................................................................50 
About Configuring a Measurement .........................................................50 
Configure Menu Definitions ...................................................................51 

Sources...........................................................................................................52 
About Configuring the Sources...............................................................52 
Configure Source Menu Options for a Differential Probe ......................53 



Table of Contents 

 

iv                RT-Eye ®Serial Compliance and Analysis Application 

Configure Source Menu for Differential Probes .....................................54 
Configure Source from a File for Differential Probes.............................54 
Configure Source Menu Options for Single-Ended Probes ....................55 
Configure Source Menu for Single-Ended Probes ..................................56 
Configure Source from Ref Waveform for Single-Ended Probes...........56 
Configure Source from File for Single-Ended Probes ............................57 
Autosetting Sources for Live (Channel) Waveforms ..............................58 

Reference Voltage Levels ..............................................................................59 
About Reference Voltage Levels ............................................................59 
High, Mid, and Low Reference Voltage Levels......................................59 
Reference Voltage Levels Diagram ........................................................59 
Rising Versus Falling Thresholds ...........................................................60 
Using the Hysteresis Option....................................................................60 
Example of Hysteresis on a Noisy Waveform ........................................60 
Cursor Gating and Reference Voltage Levels Autoset............................61 
Configuring Reference Voltage Level Autoset .......................................61 
Configuring Reference Voltage Autoset Percentages .............................62 
Steps to Set the Reference Voltage Levels..............................................63 
Reference Level Autoset Setup Menu Options .......................................64 
Ref Level Autoset Setup Menu ...............................................................64 
Manually Adjusting the Reference Voltage Levels.................................64 
Configure Ref Levels Menu Options ......................................................65 
Configure Ref Levels Menu....................................................................66 

Gating Measurements ....................................................................................66 
About Gated Measurements ....................................................................66 
Configure Smart Gating Menu Options ..................................................67 
Configure Smart Gating Menu with Gating Off .....................................67 
Configure Smart Gating Menu with Cursors Gating...............................68 
Configure Smart Gating Menu Options for Smart Gating ......................69 
Using Smart Gating.................................................................................70 
Configure Smart Gating Menu with Clock Recovery Window ..............70 
Configure Smart Gating Menu with Analysis Window ..........................71 
Smart Gating Diagram ............................................................................72 

Clock Recovery Measurements .....................................................................72 
Clock Recovery Methods ........................................................................72 



Table of Contents 

RT-Eye ® Serial Compliance and Analysis Application  v

About Constant (Straight-Line) Clock Recovery ....................................73 
About PLL-based Clock Recovery..........................................................74 
PLL-based Clock Recovery Setup ..........................................................74 
Clock Recovery Menu Options ...............................................................75 
Configure Clock Recovery Menu............................................................76 

Jitter Measurements .......................................................................................76 
Jitter Measurement Methods ...................................................................76 
Rj/Dj Analysis of Repeating Patterns Using a Spectral Approach..........77 
RjDj Analysis of Arbitrary Pattern..........................................................77 
Configure Jitter Menu Options................................................................78 
Configure Jitter menu for Repeating patterns .........................................79 
Configure Jitter menu for Arbitrary patterns...........................................79 
Bathtub Curve: BER versus Decision Time............................................80 

Population for Measurements ........................................................................80 
Setting the Population for the Measurements..........................................80 
Configure Population Menu Options ......................................................81 
Configure Population Menu ....................................................................81 

General Config...............................................................................................82 
Measurement Limits ......................................................................................83 

About Using Measurements Limits File .................................................83 
Creating a Measurements Limits File .....................................................83 
Editing a Measurements Limits File .......................................................84 
Measurements Limits Menu Options ......................................................84 
Measurements Limits Menu....................................................................85 
Measurements Limits Editor Toolbar Functions.....................................85 
Measurements Limits Editor Menu Options ...........................................85 
Measurements Limits Editor Menu.........................................................86 
Measurements Limits File Summary ......................................................87 

User Masks ....................................................................................................88 
About Using Standard Masks..................................................................88 
Using the User Mask File Editor.............................................................89 
Import of User Mask ...............................................................................91 
Manually Editing a Mask File .................................................................92 
User Mask File Opened in a Text Editor.................................................93 
Creating a New User Mask File ..............................................................94 



Table of Contents 

 

vi                RT-Eye ®Serial Compliance and Analysis Application 

Mask File Edited Using a Text Editor Example......................................94 
Recalling a User Mask in the Plots Configure Menu ..............................94 

Taking Measurements....................................................................................95 
About Taking Measurements ..................................................................95 
Localizing Measurements .......................................................................95 
About Sequencing ...................................................................................95 
Acquiring Data ........................................................................................96 
Control Panel Functions ..........................................................................97 
Sequence Mode Option Definitions ........................................................97 
Single shot, Scan mode off......................................................................98 
Single shot, Scan mode on ......................................................................99 
Free run, Scan mode off ..........................................................................99 
Free run, Scan mode on...........................................................................99 
Control Panel.........................................................................................100 
About the Results ..................................................................................100 

Statistical Results.........................................................................................101 
About Viewing Statistics.......................................................................101 
Viewing Statistics..................................................................................101 
Results Summary Menu Options...........................................................102 
Results Summary Menu ........................................................................102 
Results Details Menu Options...............................................................103 
Results Details Menu ............................................................................103 
Saving Statistics to a .CSV File.............................................................104 

Plotting the Results ......................................................................................105 
About Plotting .......................................................................................105 
Plot Type Definitions ............................................................................106 
Measurements and Available Plots .......................................................106 
Plot Window Layouts............................................................................107 
Eye Diagram Plot Usage .......................................................................107 
RT-Eye (Real Time) Rendering ............................................................108 
ET-Eye (Equivalent Time) Rendering ..................................................109 
Usage of Waveform with Bit Error Locator..........................................110 
Histogram Plot Usage............................................................................111 
Spectrum Plot Usage .............................................................................111 
Bathtub Plot Usage................................................................................112 



Table of Contents 

RT-Eye ® Serial Compliance and Analysis Application  vii

Selecting and Configuring Plots ..................................................................112 
Selecting Plots for Configuration ..........................................................112 
Plots Select Menu Options ....................................................................113 
Plots: Select Menu.................................................................................113 
Configuring Plots ..................................................................................114 
Plots Configure Menu Options for an Eye Diagram .............................115 
Plots Configure Menu for an Eye Diagram...........................................115 
Plots Configure Menu Options for a Histogram ...................................116 
Plots Configure Menu for a Histogram .................................................116 
Plots Configure Menu Options for a Spectrum .....................................117 
Plots Configure Menu for a Spectrum...................................................117 
Plots Configure Menu Option for a Bathtub .........................................118 
Plots Configure Menu for a Bathtub .....................................................118 

Viewing Plots...............................................................................................119 
About Viewing Plots .............................................................................119 
Using a Separate Monitor to View Plots ...............................................120 
Toolbar Functions in Plot Windows......................................................120 
Plot Summary Window Example ..........................................................121 
Plot Details Window Example ..............................................................122 
Plot Summary and Details Window Example .......................................123 
Viewing a Plot in the Whole Display or in Half the Display ................124 
Returning to the Plot Summary Window ..............................................124 
Using Zoom and Cursors in a Plot ........................................................125 

Removing Plots............................................................................................126 
Using Zoom in a Plot ...................................................................................126 

About Using Zoom in a Plot .................................................................126 
Plot Zoom Definitions...........................................................................126 
Changing the Scale of Data in a Plot (Zoom) .......................................127 

Using Cursors in a Plot ................................................................................128 
About Using Cursors in a Plot...............................................................128 
Plot Cursors Definitions ........................................................................128 
Using Cursors in a Plot..........................................................................128 
Using Grid Points in a Plot....................................................................129 
Horizontal and Vertical Cursors in a Plot Example ..............................129 

Saving Plots to Files ....................................................................................130 



Table of Contents 

 

viii                RT-Eye ®Serial Compliance and Analysis Application 

About Saving Plot Files.........................................................................130 
Save Plot Files Definitions ....................................................................130 
Saving Plot Files....................................................................................130 

Printing Plots ...............................................................................................131 
About Printing Plots ..............................................................................131 
Plot Print Preview Window...................................................................132 
Plot Page Setup Window.......................................................................133 

Logging Worst Case Waveforms.................................................................133 
Saving Worst Case Waveforms from a Live Source.............................133 
Log Worst Case Configure Options ......................................................134 
Log: Worst Case Configure Menu ........................................................135 
File Names of Worst Case Waveforms .................................................135 
Log: Worst Case File Names Menu ......................................................135 

Generating a Report .....................................................................................136 
About Generating a Report ...................................................................136 
Report Generator File Directories .........................................................136 
Directory Structure for the Report Generator Utility ............................137 
Starting the Report Generator and Accessing the Online Help .............138 
Setting Up a Test Template and Layout for a Report............................139 
Generating and Printing a Report..........................................................139 
Creating a PDF File of the Compliance Report.....................................140 
Test Template Menu..............................................................................141 
Report Layout Menu .............................................................................142 
Report Generate Menu Options.............................................................142 
Report Generate Menu ..........................................................................143 
Report Generator Fields ........................................................................143 
Application Fields General Information List ........................................144 
Application Fields Configuration List and Ref Levels Example ..........145 
Application Fields Results List and Specific Measurements Example .146 
Oscilloscope Fields and Native Fields Lists..........................................147 

Tutorial ................................................................................ 149 

Introduction to the Tutorial..........................................................................149 
Setting Up the Oscilloscope.........................................................................149 
Starting the Application ...............................................................................149 



Table of Contents 

RT-Eye ® Serial Compliance and Analysis Application  ix

Waveform Files ...........................................................................................149 
Recalling a Waveform File ..........................................................................150 
Oscilloscope Reference Memory Setup Menu ............................................151 
Taking an Eye Width Measurement ............................................................152 

Setting Up an Eye Width Measurement ................................................152 
Ref1 Selected as the Source.........................................................................153 
Using Autoset for Reference Voltage Levels ..............................................153 
Taking a Measurement and Viewing as an Eye Diagram............................154 
Results Summary and Plots Summary Window Example ...........................155 
Results Details and Plot Details Window Example .....................................156 
Ending a Tutorial Lesson.............................................................................156 

Stopping the Tutorial.............................................................................157 
Returning to the Tutorial .......................................................................157 

Quick Method Concept................................................................................157 
Quick Method to Take Measurements ..................................................158 

Taking a TIE Jitter Measurement ................................................................159 
Clearing Results ....................................................................................159 
Setting Up a TIE Jitter Measurement and Plots ....................................160 
TIE Jitter Results with Histogram Example..........................................161 
TIE Jitter Histogram and Spectrum Plot Example ................................162 
Examples of Plot Details .......................................................................163 
Saving Statistical Results to a .CSV File ..............................................164 
.CSV File Viewed with Wordpad Example ..........................................165 
.CSV File Viewed in a Spreadsheet Example .......................................165 

Generating a Simple Report.........................................................................165 
Simple Report Example Page 1.............................................................166 
Simple Report Example Page 2.............................................................167 

Serial Analysis Laboratory .......................................................... 169 

About the Serial Analysis Laboratory (Lab)................................................169 
Recall Default Settings and Run RT-Eye SW .............................................170 
Reference Waveform File Setup..................................................................170 
Training Board 2 - Live Signal Source ........................................................172 
Use P7380SMA with CH1 as the Differential Source for Analysis ............173 
Use TCA-SMA Adapters on CH1 and CH3 as Single-Ended Sources for Analysis 175 



Table of Contents 

 

x                RT-Eye ®Serial Compliance and Analysis Application 

Run the Analysis and View the Results .......................................................177 
MJSQ Jitter Analysis ...................................................................................178 
Using MyTest ..............................................................................................181 
Defining a Limits Module............................................................................181 
Creating a Compliance Report.....................................................................183 
PCI Express Compliance Tests....................................................................184 

Results of PCI Express Add in Card Compliance Test .........................185 
Serial Analysis Lab Conclusion...................................................................188 

Parameters ................................................................................ 189 

About Application Parameters.....................................................................189 
File Menu Parameters ..................................................................................190 
File Preferences Menu Parameters...............................................................190 
Control Panel Parameters.............................................................................191 
Measurements Select Menu Parameters ......................................................191 
Autoset Summary Menu Parameters ...........................................................192 
Measurements Configure Menus .................................................................192 
Configure Source Menu Parameters for Differential Probes .......................193 
Configure Source Menu Parameters for Single-Ended Probes....................193 
Configure Ref Levels Menu Parameters......................................................194 
Configure Ref Level Autoset Setup Menu Parameters................................194 
Configure Smart Gating Menu Parameters..................................................195 
Configure Smart Gating Menu with Smart Gating Parameters ...................195 
Configure Clock Recovery Menu Parameters .............................................195 
Configure Jitter Menu Parameters ...............................................................197 
Configure Population Menu Parameters......................................................197 
Configure General Config Parameters.........................................................197 
Measurements Limits Menu Parameters......................................................198 
Results Menus..............................................................................................198 
Results Summary Menu Parameters ............................................................198 
Results Details Menu Parameters ................................................................199 
Plots Select Menu Parameters......................................................................199 
Eye Diagram Configure Menu Parameters ..................................................200 
Histogram Plot Configure Menu Parameters ...............................................200 
Spectrum Plot Configure Menu Parameters ................................................201 



Table of Contents 

RT-Eye ® Serial Compliance and Analysis Application  xi

Bathtub Plot Configure Menu Parameter.....................................................201 
Log Worst Case Configure Menu Parameters .............................................202 
Utilities Report Generator Menus Parameters .............................................202 
Help Menu ...................................................................................................202 

Algorithms ................................................................................ 203 

About Measurement Algorithms .................................................................203 
Oscilloscope Setup Guidelines ....................................................................203 
Test Methodology ........................................................................................204 
Measurements ..............................................................................................205 
Notation in Algorithms ................................................................................206 

About Notation in Algorithms...............................................................206 
Notational Rules....................................................................................206 

Summary Definitions of Fundamental Signals and Measurements .............207 
Waveforms ............................................................................................207 
Edge Time Threshold Voltages.............................................................208 
Crossing Times......................................................................................208 
Recovered Clock Times ........................................................................209 
Eye Center Voltages..............................................................................209 

Timing Measurements .................................................................................210 
About Timing Measurements................................................................210 
Eye Width Measurement .......................................................................210 
Rise Time Measurement........................................................................211 
Fall Time Measurement ........................................................................212 
Rising Edge Measurement ....................................................................213 
Falling Edge Measurement....................................................................214 
Unit Interval Measurement....................................................................215 
Bit Rate Measurement ...........................................................................216 
Differential Skew Measurement............................................................216 

Amplitude Measurements ............................................................................217 
About Amplitude Measurements...........................................................217 
Eye Height Measurement ......................................................................217 
Differential Amplitude Measurement ...................................................219 
Differential Peak Voltage Measurement ...............................................220 
Differential Average Measurement .......................................................220 



Table of Contents 

 

xii                RT-Eye ®Serial Compliance and Analysis Application 

High Amplitude Measurement ..............................................................220 
Low Amplitude Measurement...............................................................221 
CM Voltage Measurement ....................................................................221 
AC CM Voltage Measurement..............................................................222 
AC CM RMS Voltage Measurement ....................................................222 
De-Emphasis Measurement...................................................................223 

Jitter Measurements .....................................................................................224 
About Jitter Measurements....................................................................224 
Jitter @ BER Measurement...................................................................225 
Spectrum Analysis based Rj/Dj Separation on Repeating Pattern ........226 
Rj/Dj Separation based on Dual-Dirac Model.......................................229 
Jitter Measurements Field Notes ...........................................................230 
TIE Jitter Measurement .........................................................................230 
TIE Jitter Filtering Measurement ..........................................................231 

Statistics .......................................................................................................233 
About Statistics .....................................................................................233 
Maximum Value....................................................................................233 
Minimum Value ....................................................................................233 
Mean Value ...........................................................................................233 
Standard Deviation Value .....................................................................234 
Peak-to-Peak Value ...............................................................................234 
Population Value ...................................................................................234 

GPIB ................................................................................ 235 

About the GPIB Program.............................................................................235 
Guidelines to GPIB Programming ...............................................................236 
Program Example ........................................................................................237 
GPIB Commands .........................................................................................238 

Introduction to GPIB Command Syntax ...............................................238 
GPIB Reference Materials ....................................................................239 
Starting and Setting Up the Application using GPIB............................239 

Variable: Value RT-Eye Command.............................................................240 
Syntax....................................................................................................240 
Variable: Value RT-Eye Command Arguments and Queries (Part 1) ..241 
Variable:Value RT-Eye Command Arguments and Queries (Part 2) ...242 



Table of Contents 

RT-Eye ® Serial Compliance and Analysis Application  xiii

Measurements Results Queries ....................................................................243 
Measurements Results Queries Variable Names (Part 1)......................243 
Measurements Results Queries Variable Names (Part 2)......................244 

Serial Analysis Measurement Names for the resultFor Variable.................245 
InfiniBand Driver Measurement Names for the resultFor Variable ............246 
InfiniBand Receiver Measurement Names for the resultFor Variable.........247 
InfiniBand Cable Assembly Measurement Names for the resultFor Variable247 
PCI Express Measurement Names for the resultFor Variable for any ..............          
Test point except Reference clock ...............................................................248 
PCI Express Reference Clock Measurement Names for the resultFor Variable249 
FBDIMM Transmitter Measurement Names for the resultFor Variable .....250 
FBDIMM Receiver Measurement Names for the resultFor Variable..........251 
FBDIMM Reference Clock Measurement Names for the resultFor Variable252 
GPIB Commands Error Codes.....................................................................252 
GPIB Commands Warning Codes ...............................................................254 

 



Table of Contents 

 

xiv                RT-Eye ®Serial Compliance and Analysis Application 



 

RT-Eye ® Serial Compliance and Analysis Application  xv

General Safety Summary 
Review the following safety precautions to avoid injury and prevent damage to 
this product or any products connected to it. To avoid potential hazards, use this 
product only as specified. 

Only qualified personnel should perform service procedures. 

While using this product, you may need to access other parts of the system. Read 
the General Safety Summary in other system manuals for warnings and cautions 
related to operating the system. 
To Avoid Fire or Personal Injury: 

Connect and Disconnect Properly: Do not connect or disconnect probes or test 
leads while they are connected to a voltage source. 

Observe All Terminal Ratings: To avoid fire or shock hazard, observe all 
ratings and markings on the product. Consult the product manual for further 
ratings information before making connections to the product. 

Do Not Operate With Suspected Failures: If you suspect there is damage to 
this product, have it inspected by qualified service personnel. 

Symbols and Terms: The following terms and symbols may appear in the online 
help. 

  WARNING: Warning statements identify conditions or practices that 
could result in injury or loss of life.  

: CAUTION: Caution statements identify conditions or practices that could 
result in damage to this product or other property. 

Terms on the Product: The following terms may appear on the product: 

 DANGER indicates an injury hazard immediately accessible as you read the 
marking. 

 WARNING indicates an injury hazard not immediately accessible as you 
read the marking. 

 CAUTION indicates a hazard to property including the product. 
 

Symbols on the Product: The following symbol (s) may appear in the product: 

 

CAUTION Refer to Help 
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Welcome to the RT-Eye® Serial Compliance                     
and Analysis Application 

The RT-Eye product is an application that enhances the basic capabilities of 
some high-performance oscilloscopes from Tektronix. The application 
incorporates MATLAB run-time and uses it to display real-time graphical 
representations of the measurement results in plot windows. 

The Real-Time Eye (RT-Eye) application provides general compliance 
measurements and analysis capabilities for emerging serial data standards, and 
includes the following features:  

 Selects and configures multiple measurements on one differential or two 
single-ended probe inputs 

 Performs Timing, Amplitude, and Jitter measurements per industry standard 
methods 

 Displays an RT-Eye rendering of the serial bit stream, and other plots such 
as Waveform (with Bit Error Locator), Jitter Histogram, Jitter Spectrum, and 
Jitter Eye Opening analysis 

 Specifies configurable Limits for Pass/Fail analysis on waveforms and 
measurements when a Limits file is enabled  

 Performs "Plug-Fest" level compliance measurements defined by industry 
working groups using optional Compliance Modules such as Fully Buffered 
DIMM (FB-DIMM), InfiniBand, PCI Express, SAS, and Serial ATA. 

 Exports analysis results to a .csv file for further analysis 

 Tracks and saves the worst case waveforms to .wfm files 

 Creates, formats, and generates reports 

 Automates compliance tests for production 

 To return to the Table of Contents, select Help Topics from the Help menu 
bar. 
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Five-Time Free Trial 
A five-time free trial is available for all applications in the "Applications on this 
CD and Compatible Oscilloscope" table found in the Optional Applications 
Software on a Windows-Based Oscilloscope Installation Manual. You can start 
and exit an application up to five times to help you evaluate Tektronix software 
solutions. 

Note: To evaluate an application, first check that your TDS6000- or 
TDS/CSA7000-series oscilloscope firmware version is consistent with the 
version requirements mentioned in the application’s readme file. You can check 
the firmware version number from the oscilloscope Help drop-down list (About 
…). You can check the application’s firmware compatibility by referring to the 
System Requirements section in the application’s readme.txt file. 

If an application becomes available after you receive your oscilloscope, you can 
download the application as described in the installation manual (Tektronix part 
number 071-1078-xx) to obtain the free trial.  

Related Documentation 
In addition to the online help, the application includes a Reference guide. Refer 
to the  

RT-Eye™ Serial Compliance and Analysis Quick Start User Manual (071-1769-
xx) for the following information: 

 The manual provides task-oriented procedures to explain the basic 
operations that cover the set up of the application. 

Refer to the Optional Applications Software on a Windows-Based Oscilloscope 
Installation Manual for the following information: 

 Software warranty 

 List of all available applications, compatible oscilloscopes, and relevant 
software and firmware version numbers 

 Applying a new label 

 Installing an application  

 Enabling an application 

 Downloading updates from the Tektronix Web site 
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Note: You can view PDF file of the installation manual from the CD Installation 
Browser and from the Documents directory on the Optional Applications 
Software on a Windows-Based Oscilloscope CD-ROM. 
 

GPIB Information 
For information on how to operate the oscilloscope and use the application-
specific GPIB commands, refer to the following documents: 

 This online help provides a sample RT-Eye program that illustrates how to 
set up and use remote automation 

 The user manual for your oscilloscope provides general information on how 
to operate the oscilloscope 

 The online help for your oscilloscope can provide details on how to use 
GPIB commands to control the oscilloscope if you install the GPIB 
Programmer guide (and code examples) from the oscilloscope CD-ROM 

 The online help for Option SST Serial ATA and Serial Attached SCSI 
Analysis module provides details on how to use GPIB commands for SAS 
and SATA 

Relevant Web Sites 
You can also find useful information on serial data standards on the following 
Web sites: 

 www.Infinibandta.org 

 www.pcisig.com 

 www.T11.org 

 www.tektronix.com/search RT-Eye. 
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Application CD Contents 
The Optional Applications Software on a Windows-Based Oscilloscope CD-
ROM includes files for the following types of documentation: 

 Printable file of the RT-Eye Serial Data Compliance and Analysis online 
help formatted to resemble a user manual 

 Printable file of the Option SST online help formatted to resemble a user 
manual 

 Printable file of the Report Generator online help formatted to resemble a 
user manual 

 PDF files of the Methods of Implementation (MOI) for serial data standards 
as they apply to the corresponding compliance modules 

 RT-Eye™ Serial Compliance and Analysis Quick Start User Manual (071-
1769-xx) 

 Optional Applications Installation manual 

  

Figure i. Application CD Contents 
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Access to PDF Files 
You can use any of the following methods to view the various PDF files 
associated with this application: 

 Access a file in the Documents directory on the Applications CD from any 
PC. 

 Access documents on the CD from the Installation Browser.  

 Note: The documents are available on Application CD at 
Documents\TDSRT-Eye. The CD Installation Browser page for TDSRT-
Eye is accessed from "Serial Data Compliance and Analysis" and also 
includes a link to "Browse the Documentation". This link opens a Microsoft 
Explorer Window to the folder above. 

 Select a file from the Start menu in the oscilloscope task bar; you may need 
to first minimize the RT-Eye application  

 Access a file from the Help drop-down list in the RT-Eye application 

Note: If you do not have an Acrobat reader to view a PDF file, you can get a free 
copy of the reader from the www.adobe.com/products/acrobat Web page. 
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Conventions 
Online help topics use the following conventions: 

 The terms "RT-Eye application" and "application" refer to the RT-Eye 
Serial Compliance and Analysis Application. 

 The term "oscilloscope" refers to any product on which this application runs.  

 The term "select" is a generic term that applies to the two mechanical 
methods of choosing an option: with a mouse or with the Touch Screen.  

 The term "Compliance Module" refers to optional "plug-in applications" 
from Tektronix used for compliance testing to specific serial data standards. 

 The term "Limits Module" refers to a formatted text file used to specify user 
limits on mask geometry and measurement boundary conditions for 
Pass/Fail testing. 

 The term "channel" is context dependent. It can refer to the transmit channel 
of the device under test or to an oscilloscope channel. 

 The term "DUT" is an abbreviation for Device Under Test.  

 There may be minor differences in the display of user interface screen 
graphics on other types of oscilloscopes such as TDS6000 or TDS7000. 

 When steps require a sequence of selections using the application interface, 
the ">" delimiter marks each transition between a menu and an option. For 
example, one of the steps to recall a setup file would appear as File> Recall. 
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Types of Online Help Information 
The online help contains the following types of information: 

 A Getting Started group of topics briefly describes the application, contains 
connection procedures, and includes an optional deskew procedure. 

 An Operating Basics group of topics covers basic operating principles of the 
application. The sequence of topics reflects the steps you perform to operate 
the application and includes definitions for all menus and options. 

 A Tutorial group of topics teaches you how to set up the application to 
acquire a waveform, take a measurement, view the results, view a plot, and 
save data to a file. 

 A Serial Analysis Laboratory group of topics demonstrates how to use serial 
analysis measurements to identify a problem with a serial data waveform 
through the process of elimination. This should give you ideas on how to 
solve your own measurement problems. 

 A Reference group of topics includes the parameters (range of values) for all 
options and the default values. 

 A Measurement Algorithms group of topics includes information on 
measurement guidelines and on how the application calculates each 
measurement. 

 A GPIB Command Syntax group of topics contains a list of arguments and 
values that you can use with the remote commands and their associated 
parameters. The application includes a simple remote interface program to 
show you how to operate the application using GPIB commands. 

The application Help drop-down list includes a PDF Help menu item you can use 
to access a PDF file of the help topics. The file is printable and is formatted to 
resemble a user manual. 

The Report Generator utility also has an independent online help system that you 
can launch from the Report Generator window. 
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Using Online Help 
Online help has many advantages over a printed manual because of advanced 
search capabilities. You can select Help> Topics on the right side of the 
application menu bar to display the Help file.  

The main (opening) Help screen shows a series of book icons and three tabs 
along the top menu, each of which offers a unique mode of assistance: 

 Table of Contents (TOC) tab - organizes the Help into book-like sections. 
Select a book icon to open a section; select any of the topics listed under the 
book. 

 Index tab - enables you to scroll a list of alphabetical keywords. Select the 
topic of interest to display the corresponding help page. 

 Find tab - allows a text-based search. Follow these steps: 

1. Type the word or phrase you want to find in the search box. If the word or 
phrase is not found, try the Index tab.      

2. Select some matching words in the next box to narrow your search. 

3. Choose a topic in the lower box, and then select the Display button. 

Note: The Find tab function does not include words found in graphics. Refer to 
the Find Tab and Searches topic for more information.  
 

 To print a topic, select the Print button from the help topics menu bar. 

 Select Options from the menu bar for other commands, such as to annotate a 
topic, to keep the help window on top, or to use system colors. 

 Select the Back button to return to the previous help window. Sometimes 
you can jump from one topic to another through a hyperlink. If the Back 
button is grayed out, or a jump is not available, choose the Help Topics 
button to return to the originating help folder.  

 Browse buttons (Next >> and Previous <<) allow you to move forward and 
backward through topics in the order of the Table of Contents (TOC). 

 A Note: in the topic text indicates important information.  

Note: Green-underlined text indicates a Jump (hyperlink) to another topic. Select 
the green text to jump to the related topic. For example, select the green text to 
jump to the topic on Feedback to contact Tektronix.  
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You can tell when the cursor is over an active hyperlink (button, jump, or 
popup), because the arrow cursor changes to a small pointing hand cursor. 

The light bulb icon and word Tip indicate additional information to help 
you operate the application more efficiently. 

Online Help for the Report Generator 
The Report Generator utility is a separate program that allows you to create a 
new test template or report layout, or edit an existing one. The online help for the 
Report Generator explains how to use the utility.  

Online Help for Compliance Modules 
Each compliance module has its own help documents: online help or PDF 
documents called as MOIs (Methods Of Implementation). To view compliance 
specific help topics, refer to the Help menu in the module of interest. 
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Find Tab and Searches 
Many online help topics contain only tables. To retain vertical and horizontal 
lines, the tables are graphical objects. The Find tab in the online help does not 
recognize words in these tables.  

The online help is extensively indexed with the proper names of all menus and 
options as they appear in the application and in the left column of graphical 
tables.  

Note: If you conduct a Find tab search with no results, try the Index tab instead. 
 

Feedback 
Tektronix values your feedback on our products. To help us serve you better, 
please send us suggestions, ideas, or other comments you may have about your 
application or oscilloscope. 

You can send us your feedback by e-mail to techsupport@tektronix.com, by 
FAX at (503) 627-5695 (North America), or by telephone (See Contacting 
Tektronix) . Please be as specific as possible and include the following 
information: 

General Information 

 Oscilloscope model number and hardware options, if any 

 Probes used 

 Serial data standard 

 Signaling rate 

 Your name, company, mailing address, phone number, FAX number 

Note: Please indicate if you would like to be contacted by Tektronix regarding 
your suggestion or comments. 
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Application-Specific Information 

 Software version number 

 Description of the problem such that technical support can duplicate the 
problem 

 If possible, save the oscilloscope waveform file as a .wfm file 

 If possible, save the oscilloscope and application setup files from the 
application to obtain both the oscilloscope .set file and the application .ini 
file. Refer to Saving a Setup File. 

Once you have gathered this information, you can contact technical support by 
phone or through e-mail. If using e-mail, be sure to enter in the subject line "RT-
Eye Problem," and attach the .set, .ini, and .wfm files. 

 To include screen shots, from the oscilloscope menu bar, select File> 
Export. In the Export dialog box, enter a file name with a .bmp extension and 
select Save. The file is saved in the C:\TekScope\Images directory. You can then 
attach the file to your email (depending on the capabilities of your email editor)  
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Getting Started 

Product Description 
The RT-Eye Serial Compliance and Analysis Application is a software product 
that enhances basic capabilities of some high-performance oscilloscopes offered 
by Tektronix. The RT-Eye application is a general analysis tool you can use to 
test, debug, and verify serial-data based designs. The compliance applications are 
specific tools you can use with device designs that must comply with serial data 
standards, such as PCI Express, FB-DIMM, Serial ATA, Serial Attached SCSI, 
or InfiniBand. 

You can use this application to do the following tasks:  

 Select and configure many amplitude and timing measurements on a serial 
data signal 

 Conduct RT-Eye rendering and mask testing, Time Interval Error analysis, 
Rj/Dj (random jitter and deterministic jitter) analysis, and display results as 
a Bathtub plot  

 Locate bit errors (mask violations) on the acquired waveform 

 Display the results as eye diagram, histogram, spectrum, or bathtub curve 
plots 

 Perform Pass or Fail limits testing based on waveform masks and based on 
measurements that use Limits Modules 

 Perform "plug-fest" level compliance tests for available compliance modules 
that test against a specific standard 

 Save the statistical results to a file 

 Save the worst case waveforms to files 

 Generate reports 

Note: There are no standard accessories for this product. Refer to Accessories 
for a list of recommended probes. 
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Analysis and Compliance Modules 
You can use the RT-Eye (real-time eye) serial data analysis application and 
industry specific compliance modules to characterize serial transmission signal 
integrity. The applications were developed to help you perform analysis on the 
following types of designs: 

 General serial-data based designs 

 Device designs that need to comply with a specific serial-data standard  

The RT-Eye application is the foundation for current and for future compliance 
modules. Each enabled compliance application shows at least two choices in the 
Modules drop-down list; one will always be for Serial Analysis. 

Compatibility 
For information on oscilloscope compatibility, refer to the Optional Application 
Software on Microsoft Windows Based Oscilloscopes Installation Manual, 
Tektronix part number 071-1888-xx. The manual is available as a PDF file.  



                                                                                                                                                            Getting Started 

 

RT-Eye ® Serial Compliance and Analysis Application  3

Requirements and Restrictions 
The Sun Java Run-Time Environment (JRE) and the Mathworks MATLAB Run-
Time Server are components of the RT-Eye application. When you install the 
application, the InstallShield Wizard automatically installs the proper software 
components.  

MATLAB Server: The MATLAB server is dedicated to the RT-Eye application 
and cannot be used for other purposes. Do not close the Matlab Server icon  
in the oscilloscope task bar because this will disrupt the operation of the RT-Eye 
application. The application will close the MATLAB sever when you exit the 
application. 

Oscilloscope: Maximum sampling rate of 20 GS/s with interpolation is often 
necessary to ensure accurate results. Be sure to consider the following differences 
in sampling rates before taking measurements: 

 The TDS6604 oscilloscopes sample at 20 GS/s on two channels and at 10  
GS/s on four channels.  

 The TDS7404 oscilloscopes sample at 20 GS/s on one channel and at 10  
GS/s on two channels. 

 The TDS6000C oscilloscopes sample at 40 GS/s on two channels and 20 
GS/s on four channels. 

 The TDS6000B oscilloscopes sample at 20 GS/s on two and four channels. 

 The TDS7000B oscilloscopes sample at 20 GS/s on one channel, 10 GS/s on 
two channels, and 5GS/s on four channels. 

When the Record Length of the oscilloscope is set to 4M or less, the application 
can take all measurements. When the Record Length is set to 4M or 20M, the 
RT-Eye application can take one TIE measurement. 

Keyboard: You may need to use a keyboard to enter new names for some file 
save operations. 

Distiller Software: To convert an RTF file from the Report Generator utility to a 
PDF file, you require distiller software, such as Adobe Acrobat 6.0 or freeware 
such as CutePDF. 
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Minimum Required System Configuration 
Before operating the RT-Eye application, check the readme.txt file to verify 
whether the oscilloscope configuration meets the minimum requirements. If the 
RT-Eye application is installed on the oscilloscope, select Start> Programs> 
TekApplications> tdsRT-Eye> readme file. If the application is not installed, the 
readme.txt file is in the same directory as the setup.exe file on the Optional 
Applications CD. 

Accessories 
There are no standard accessories for this product. However, you can refer to the 
product datasheet available on the Tektronix Web site for information on 
optional accessories relevant to your application. For example, Tektronix 
recommends that you use the following probes: 

Table 1: Probes 
Probe* Description 
P73XX (Includes P7350, 
P7380, P7313) 

Z-Active TM Differential Probe family. 

P73XXSMA  SMA Input Differential Acquisition System. 
*Check the www.Tektronix.com web site for an up-to-date list of probes and 
information on standard-specific test fixtures. 
  

Installation 
Refer to the Optional Applications Software on a Windows-Based Oscilloscope 
Installation Manual, Tektronix part number 071-1078-xx, for the following 
information: 

 Available applications, compatible oscilloscopes, and relevant software and 
firmware version numbers 

 Using the free trials  

 Applying a new authorized Option Installation key label 

 Installing the application 

 Enabling an application 

 Downloading updates from the Tektronix Web site 

The manual is also available as a PDF file.  
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Connecting to a Device Under Test (DUT) 
You can use any compatible probes to connect your DUT (Device Under Test) 
with your oscilloscope.  

There are four typical probing configurations for serial data links: two for Pseudo 
Differential Waveforms and two for True Differential Waveforms. The method 
of setting up your measurement channel(s) is dependent on your application and 
what you want to measure. 

  WARNING: To avoid electric shock, you must ensure that power is removed 
from the DUT before attaching probes to it. Do not touch exposed conductors 
except with the properly rated probe tips. Refer to the probe manual for 
proper use. Refer to the General Safety Summary in your oscilloscope 
manual. 

 

Probe Information 

Table 2. Probe Information 

  
 

 When you are deciding what oscilloscope and probe combination to use, 
the system bandwidth should be greater than 1.5 times the bit rate. This provides 
adequate bandwidth for most of the measurements because most of the energy in 
high-speed serial data signals is contained in the 1st and 3rd harmonic. To ensure 
accurate Rise time measurements, 2.5 times the bit rate (5th harmonic) is 
required.   
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Power Spectrum of a 2.5 Gb/sec Signal Example 

Note: The 1st and 3rd harmonics are the two highest peaks. 
 

  

Figure 1: Power Spectrum of a 2.5 Gb/sec signal 

 

Two TCA-to-SMA Adaptors, Diagram A 

   

Figure 2: Two TCA-to-SMA Adaptors, Diagram A 
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One P73XX SMA Differential Probe, Diagram B 

  

Figure 3: One P73XX SMA Differential Probe, Diagram B 

Two P72XX Single-Ended or P73XX Differential Probes, Diagram C 

  

Figure 4: Two P72XX Single-Ended or P73XX Differential Probes, Diagram C 



Getting Started 

8                RT-Eye ®Serial Compliance and Analysis Application 

 

One P73XX Differential Probe, Diagram D 
 

  

Figure 5: One P73XX Differential Probe, Diagram D 

Deskewing Probes and Channels 
When using two channels to perform pseudo-differential measurements, it is 
important to deskew the probes. Be sure to use the proper deskew fixture and 
procedure as described in the online help of your oscilloscope. 

Note: The RT-Eye application relies on upsampled, deskewed data from the 
oscilloscope to conduct math operations for differential and common mode 
waveform measurements. Upsampling prior to deskew is required to ensure 
accurate measurements.  
 

Oscilloscope firmware V 2.4.0 and above implements sub-sampled deskew and is 
required if you use the RT-Eye application for Single-Ended measurements.
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Operating Basics 

About Basic Operations 
The topics in the Operating Basics book cover the following definitions and 
tasks: 

 Application user interface 

 Basic oscilloscope functions  

 Saving and recalling 

 Setting up the application  

 Using a Limits file  

 Using User Masks  

 Taking measurements  

 Saving the measurement results  

 Viewing the measurement results as plots  

 Using the plot window zoom and cursors  

 Saving plots  

 Logging the worst case waveforms  

 Creating and generating a custom compliance report  
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Starting the Application 
On the oscilloscope menu bar, select File> Run Application> RT-Eye Serial 
Compliance and Analysis. View how to start the application. For B and C series 
oscilloscopes, select App> RT-Eye Serial Compliance and Analysis from the 
menu bar to run the application. For DPO series oscilloscopes, select Analyze> 
RT-Eye Serial Compliance and Analysis. 

The application starts and displays the Measurements> Select menu.  

After the application initializes, the Welcome dialog box, if enabled, will appear. 
If it is disabled, you can use File> Preferences to configure it to appear the next 
time the application is launched. 

  

Figure 6: RT-Eye Welcome dialog box 

 

You can perform the following functions in this dialog box as shown in the table: 

Table 3. RT-Eye Welcome dialog box options 
Click To 
Run MyTest Recall the previously saved MyTest setup and automatically 

start the sequencer. See also: Running MyTest. 
Run Wizard Launch the RT-Eye Wizard. The application takes the 

measurements and displays the results in the result 
summary window. See also: About Serial data Wizard. 

Cancel Close the RT-Eye Welcome dialog box and work directly 
with the application. 

Show this dialog 
at startup 

Enable or disable display of the RT-Eye Welcome dialog the 
next time when you launch the application. 
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Oscilloscope Menu Bar and Selected Application 
For non-B series oscilloscopes, select File> Run Application> RT-Eye Serial 
Compliance and Analysis to start the application. 

  

Figure 7: Oscilloscope menu bar and selected application 

For B/C series oscilloscopes, select App> RT-Eye Serial Compliance and 
Analysis to start the application. 

 

Figure 8: B/C series oscilloscope menu bar and selected application 

Application Interface 
The RT-Eye application uses a Microsoft Windows based interface. Display the 
definitions of the application user interface items, or view a menu labeled with 
the user interface items.  

Note: The oscilloscope application shrinks to half size and appears in the top 
half of the screen when the application is running. 
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User Interface Definitions 

Table 4. User Interface Definitions 
 Item  Description 
Area Visual frame that encloses a set of related options. 
Box Use to define an option; enter a value with the Keypad or 

turn the Multipurpose knob to select a value. 
Browse Displays a window where you can look through a list of 

directories and files. 
Button Use to define an option; not a command button.  
Check box Use to select or clear an option. 
Command button Initiates an immediate action, such as the Start command 

button in the Control panel. 
Control panel Located to the right of the application; contains command 

buttons that you use often, such as to Start sequencing. 
Keypad On-screen keypad that you can use to enter numeric 

values. 
List box Use to define an option from a list.     
Menu All options in the application window (except the Control 

panel) that display when you select a menu bar item. 
Menu bar Located at the top of the application display and contains 

application menus. 
Option Any named button (other than a command button) or any 

named box that defines a control or task. 
Status bar Line located at the bottom of the application display that 

shows the name of the current menu (location) and the 
next step that you might take (action). 

Tab Short cut to a menu in the menu bar or a category of 
menu options; most tabs are short cuts. 

Virtual keyboard On-screen keyboard that you can use to enter 
alphanumeric strings, such as for file names. 

Scroll bar Vertical or horizontal bar at the side or bottom of a 
display area that you use to move around in that area. 
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Menu With Application User Interface Items 

Figure 9: Menu with application user interface items 
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Application Menu Bar and Drop-Down Lists 

  

Figure 10: Application menu bar and drop-down lists  

Using Basic Oscilloscope Functions 

You can use oscilloscope controls and functions while running the application. 
To do so, select a menu from the oscilloscope Menu bar (or Toolbar) and access 
menus, or use the front-panel knobs and buttons. You can also use the 
oscilloscope Help menu to access information about the oscilloscope and how to 
use it. When you access some oscilloscope controls, the oscilloscope fills the 
display.  
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Returning to the Application 

 
Figure 11: Returning to the application 

For B and C series oscilloscopes, select App> Restore Application to return to 
the RT-Eye application. 

Hiding the Application 

The Hide function minimizes the application and the oscilloscope fills the 
display. To hide and return to the application, follow these steps:  

1. Select the  command button in the application menu bar. 

2. Use the oscilloscope. 

3. Return to the application.  

Minimizing and Maximizing the Application 

To minimize the RT-Eye application, select File> Minimize in the application 
menu bar.  

To maximize the application, select  in the task bar. 

Exiting the Application  

To exit the RT-Eye application, select File> Exit or the  (Exit) command 
button in the application menu bar. When you exit the application, you can 
choose to keep the oscilloscope setup currently in use with the application or to 
restore the oscilloscope setup that was present before you started the application. 
If you select the Save MyTest check box, the current setup of both the 
oscilloscope and the application will be saved for convenient recall next time. 
Refer to MyTest for more information. 
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Figure 12: Exiting the application 

Docking the Application 

To Dock the RT-Eye application, select File> Dock in the application menu bar. 
This positions the application at the default location. 

 
Figure 13: Docking the application 

Undocking the Application 

To Undock the RT-Eye application, select File> Undock in the application menu 
bar. After you undock the application, you can click and drag the application tool 
bar to position the application anywhere on the screen. 
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Figure 14: Undocking the application 

Application Directories  

During installation, the application sets up directories for various functions, such as to save setup files, and uses 
extensions appended to file names to identify the file types. 

Table 5. Application directories 
Default directory names* Directory use 
\modules\SerialAnalysis Serial Analysis application home location. 
\modules\SerialAnalysis\data Measurement results files.  
\modules\SerialAnalysis\limits Limits files for Pass or Fail compliance 

tests. 
\modules\SerialAnalysis\masks Waveform mask files for plots and limits 

testing. 
\modules\SerialAnalysis\setup Setup files. 
\modules\SerialAnalysis\waveforms Log worst case waveforms and recall 

waveform files. 
\Masks Mask files for various serial data 

standards. 
\Examples\RemoteCtrl Sample remote control program. 
\Examples\WFMS Waveforms for learning. 
\images Plot files. 
\temp Temporary files.  
\ReportGenerator\modules\Serial 
Analysis\Reports 

Files created by the Report Generator 
utility. 

* All subdirectories are located in the C:\TekApplications\tdsrt-eye directory. 
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Directory Structure for the Serial Analysis Application 

  

Figure 15: Directory structure of serial analysis application 
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File Name Extensions 

Table 6. File name extensions 
Extension Description 
.bmp File that uses a “bitmap” format. 
.csv File that uses a "comma separated variable" format. 
.dat File with binary format; stores waveform vectors. 
.f ig Plot file with binary data. 
.gif File that uses a “graphics interchange format”. 
.ini RT-Eye application setup file. 
.jpg File that uses a “joint photographic experts group” format; also 

known as JPEG. 
.lim Limits file used with Pass/Fail compliance tests. 
.mat MATLAB waveform vector header saved to the hard disk. 
.msk Waveform mask file used with plots. 
.pdf File that uses a “portable data format”. 
.png File that uses a “portable network graphics” format. 
.rgt File that defines the report template. 
.rpl File that defines the report layout. 
.rpt File created by the Report Generator utility. 
.rtf  File that uses a “rich text format”. 
.set Oscilloscope setup f ile saved that is recalled with an application 

. ini file; both files will have the same name. 
.wfm Waveform file; can be recalled into Reference memory. 
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How to Enter Alphanumerical Values 

Note: Press the FINE button on the oscilloscope to enter or select the smallest 
values or units. 
 

Note: Be sure to select the CLR button before you enter a value using the keypad. 
 

Table 7. How to enter alphanumeric values 
Method Description 

 Keypad When you select the keypad icon, the virtual keypad 
appears (looks similar to a calculator); use to enter a 
value. 

 Multipurpose 
   knob* 

When you select a knob icon, a line appears between the 
upper icon and the option box. This activates the upper 
multipurpose knob on the front panel of the oscilloscope; 
turn the knob to select a value. 

 Keyboard  When you select the keyboard icon, the virtual keyboard 
appears (looks similar to a physical keyboard); use it to 
enter a file name. 

Edit box* Type in a value from the physical keyboard and press the 
Enter key. 

* When selected twice, the Keypad appears. 
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Virtual Keypad 

Note: Select the  icon, and then use the virtual keypad to enter information, 
such as reference voltage levels. 
 

  

Figure 16: Virtual Keypad 
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Virtual Keyboard 

Note: Select the  icon, and then use the virtual keyboard to enter 
information, such as file names. 
 

 

Figure 17: Virtual Keyboard 

Using MyTest 

About My Test 

The MyTest feature allows you to save a single measurement configuration so 
that it can be recalled and run at any time with a single click. This is similar to 
the save/recall feature (which allows as many named configurations as you 
want), except that MyTest is designed to be easily accessible and runs 
automatically when selected.   
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Saving MyTest 

To save the current application and oscilloscope settings without closing the RT-
Eye application, select Measurements> Save MyTest. 

  

Figure 18: Save Mytest 

You can also save your MyTest before exiting the RT-Eye application. When 
you select File> Exit from the RT-Eye application, the application prompts you 
to save the oscilloscope settings. If you select the Save MyTest check box, the 
current setup will be saved as the new MyTest.   

Running MyTest 

Select Measurements> Run MyTest to run MyTest at any time. 

  

Figure 19: Run Mytest 

The application takes the measurements from the saved MyTest and displays the 
results in the Result summary window. You can also run MyTest directly from 
the RT-Eye Welcome dialog. Refer to Starting the Application. 
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Using Serial Data Wizard 

About the Serial Data Wizard 

The RT-Eye application Setup Wizard guides you through the process of setting 
up, running, and displaying the results of a measurement using an intuitive 
sequential process. The Wizard can be used for accurate measurements for a 
single acquisition, or as a starting point for advanced configurations, or free-run 
measurements. 

Note: The statistical results for the Setup Wizard and RT-Eye application are 
identical if the measurements and setups are the same. 
 

Select Measurements> Wizard to open the Setup Wizard anytime. You can also 
open the Setup Wizard during the launch of the RT-Eye application by clicking 
Run Wizard in the RT-Eye Welcome dialog. Refer to Starting the Application for 
more information.  

The Setup Wizard takes you through the steps to configure the following 
parameters: 

 Probe type  

 Measurement Sources  

 Standards  

 Measurement Categories  

 Autoset Source Levels  

 Autoset Source Reference Levels  

 Plots  

Note: You can exit the Setup Wizard without affecting any settings in the Serial 
Analysis application by clicking Cancel anytime before clicking the Run button. 
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Probe type 

In this step, you can select the type of probe. The default probe type is Single-
ended. In the single-ended probe configuration, you connect two probes or two 
SMA cables to the unit under test and the application forms a pseudo-differential 
signal by subtracting them. See Probe Diagrams A and C ". In the differential 
probe configuration, you connect a single differential probe, as shown in Probe 
Diagrams B and D. 

Note that the currently selected step is always highlighted in the left column of 
the Wizard.  

Click Next to accept your probe type and proceed to Measurement Sources. 

  

Figure 20: Probe Type 
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Measurement Sources 

In step 2, you can select the Measurement sources. The available sources depend 
on which probe type you have selected in the previous step. The selection in the 
previous step is displayed in yellow text as shown in the following figure.  

Click Next to proceed to Standards. Click Back if you want to change the probe 
type. 

  

Figure 21: Measurement sources 
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Standards Selection 

In step 3, you select the Serial Analysis standards that guide clock recovery by 
establishing the bit rate. The default standard is PCI-E : 2.5 G.  

Click Next to proceed to Measurement Categories. 

  

Figure 22: Standards 
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Measurement Categories 

In step 4, you select the Measurement that will be performed. Various 
measurement parameters are grouped under these categories. You need to select 
at least one measurement to advance to the next step. For more details, refer to 
Selecting a Measurement. 

If you select Jitter@BER measurement, you can set the pattern length by 
selecting Repeating pattern and then entering the pattern length in the Pat Len 
text box. The default value is 2500 unit intervals. If you have a non-repeating 
waveform pattern or if the pattern length is unknown, select Arbitrary.  

Note: The measurements that you select also determine which plot types will be 
available in step 7.  
 

Click Next to proceed to step 5, where you select whether to Autoset the source 
scales. 

  

Figure 23: Measurement categories 
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Autoset Source Levels 

In step 5, you can choose to automatically adjust the horizontal and vertical 
scaling before the measurement. This is similar to the Autoset feature of the 
oscilloscope. The default of Yes is recommended unless you select a reference 
source. If you select No, you will retain the current oscilloscope settings.  

Click Next to proceed to Autoset the source reference levels.   

   

Figure 24: Autoset source levels 
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Autoset Source Reference Levels 

In step 6, you can choose to automatically adjust the reference levels before the 
measurement. The reference levels are the voltage thresholds that are compared 
to the waveform to determine when timing events occur. The default of Yes is 
recommended. 

Click Next to proceed to Plot selection. 

  

Figure 25: Autoset source reference levels 

Plots 

In step 7, you can select the plot types that you want to display. Some plot types 
may not be available depending on the measurements that you chose in the 
Measurement Categories step. The default is to select all plot types. The types of 
plots available are: 

 Eye Diagram—Default and is available for all measurements  

 Spectrum—if TIE Jitter is selected 

 Bathtub Curve—if Jitter@BER is selected 

 Jitter Histogram—if TIE Jitter is selected                                                                          
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Figure 26: Plots 

Click Run to start a single acquisition sequence using the selected settings. The 
Plot waveform diagrams are displayed in the chosen order, as shown in the 
following figure. 
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Figure 27: Plot waveform diagrams 
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File Menus 

File Menu Definitions 

Table 8. File menu definitions 
Menu/function Description or function 
Recall Default  Recalls most default (startup) parameters for the active module. 
Recall* Browse to select an application setup (.ini) file to recall the setup 

file. Recall restores the application to the values saved in the setup.  
Save* Save the current application settings in a .ini file. 
Recall Recent Select from a list of the four most recently accessed setup files 

(saved or recalled) and recall that setup. 
Preferences Displays the Preferences menu; settings apply until you exit the 

application; saved setup files include the settings. 
Dock Locks the RT-Eye user interface to its default position. 
Undock Allows the RT-Eye user interface to be repositioned. 
Minimize Minimizes the application. 
Exit Exits the application; you can choose to retain the current 

oscilloscope settings or restore the oscilloscope to settings prior to 
starting the application. 

*Save or Recall functions also save or recall the associated oscilloscope setup file (.set); 
an oscilloscope file is recalled if the application finds a .set file with a matching name. 
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About the File menus 

You can use the File menus to save and recall different application setups and 
recently accessed files. Display the definitions of the file menus.  

Note: The File> Save function saves application settings in an .ini file and the 
settings of the oscilloscope application in a .set file with a matching name. 

If an oscilloscope .set file with a matching name is found when you recall an 
application setup file, then the oscilloscope settings are also recalled. If the .set 
file is missing or cannot be opened by the oscilloscope, then the application 
recalls the application settings and displays a message that the Recall of the .set 
file failed. 

  CAUTION: Do not edit a setup file or recall a file not generated by the 
application. 

 

Saving a Setup File 

To save the application and oscilloscope settings to a setup file, follow these 
steps: 

1. Select File> Save.  

2. The Save dialog box appears. To view details about the file, such as size, 
type, and modified date, select the Details tool. 

3. In the file browser, select the directory in which to save the setup file or use 
the current directory. 

4. Select or use the keyboard to enter a new file name. The application appends 
an ".ini" extension to the name of the application setup file. 

5. Select the  command button. 

Note: The application also saves the oscilloscope setup to a ".set" file when you 
save an application setup. Both the application .ini file and oscilloscope .set file 
have the same file name. 
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File: Save Browser 

To view details, such as file size, type, and modified date, select the Details tool. 

 

Figure 28: Save Browser 
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Recalling a Saved Setup File 

To recall the application and oscilloscope settings from saved setup files, follow 
these steps: 

1. Select File> Recall.  

2. The Recall dialog box appears. To view details about the file, such as size, 
type, and date modified, select the Details tool.  

3. In the Recall dialog box, select the directory from which to recall the setup 
file.  

4. Select a setup file name, and then select Open. 

Note: The application recalls the .ini setup file and the associated oscilloscope 
setup if the application can find a .set file with a matching name.  
 

  CAUTION: Do not edit setup files. If you try to recall a setup file that has 
been edited, the recall operation fails. 

 

  CAUTION: If a matching .set file is not found or if the .set file does not recall 
correctly to the oscilloscope, then a warning appears that says the 
oscilloscope recall failed while the RT-Eye application recall succeeded. 
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File: Recall Browser 

To view details, such as file size, type, and modified date, select the Details tool. 

 

Figure 29: Recall browser  
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Recalling the Default Setup 

To recall the default application settings, select File> Recall Default. 

Note: Most of the settings for the active module are recalled to the default state.  
 

Recalling a Recently Saved or Accessed Setup File 

To recall a recently saved or accessed setup file, select File> Recall Recent and 
then the file from the drop-down list of setup file names. 

Note: The application also recalls the associated oscilloscope setup if the 
application can find a .set file with a matching name.  
 

 CAUTION: Do not edit setup files. If you try to recall a setup file that has 
been edited, the recall operation fails. 

 

  CAUTION: If a matching .set file is not found or if the .set file does not recall 
correctly to the oscilloscope, then a warning appears that says that the RT-Eye 
application recall succeeded but the oscilloscope recall failed. 
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Recall Recent Drop-Down List Example 

 

Figure 30: Recall recent drop-down list  

Defining Preferences 

The application includes options that you can set, and these options remain 
applied until you change them. The options can help you to operate the 
application more efficiently. 

The File Preferences menu contains several check box options that you can set 
(enable) or clear (disable). Saved setup files include the File> Preferences 
settings. View the File Preferences menu.  
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File Preferences Options 

Table 9. File preferences options 
Option Description  
Show Welcome dialog at Start 
up 

Determines whether welcome dialog box is 
displayed whenever the application is launched. 

Show Autoset Summary when 
Autoset is selected 

Determines whether a summary table of autoset 
values is displayed every time autoset is run. 

Enable high-performance eye 
rendering 

When unchecked, all unit intervals (UI) in the 
waveform(s) are included in the rendered eye. 
This gives the highest fidelity eye rendering, but 
can take considerable amount of time for long 
records. 
When checked, a statistically representative 
subset of the UI is rendered, so that eye diagrams 
for long waveforms can be displayed in a 
reasonable time.  
The rules for high-performance rendering are as 
follows: 
1) If the waveform contains 15,000 or fewer UI, all 
the UIs in the waveform are rendered. 
2) If the waveform includes more than 15,000 UI, 
it is subdivided into segments of 2000 UI each. 
The entire waveform is scanned to find the UI, 
which are the worst-case violators for six different 
points around the eye. For each of these worst-
case violators, the entire segment of 2000 UI in 
which it lies is rendered. Depending on whether 
multiple worst-case violators lie in the same 
segment or not, as few as 2000 UI but typically 
from 8000 to 12,000 UI will be rendered in the 
final eye. 

Cancel Discards changes and closes. 
OK Accepts changes and closes. 
  

File: Preferences Menu 

  

Figure 31: File preferences menu 
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Setting up the Application 

About Setting up the Application for Analysis 

You need to set up the RT-Eye application for serial data analysis or for serial 
data standard compliance testing. To do so may require that you perform some or 
all of the following tasks:  

 Choose the probe configuration: differential or single-ended  

 Select all desired measurements  

 Select the Autoset command button  

 This automatically sets the range of the vertical scale, sets the horizontal 
resolution, and dynamically sets the waveform crossing thresholds based on 
signal characteristics.  

 Configure measurement options manually in the Source, Ref Levels, Smart 
Gating, Jitter, Population, and General Config menus. 

 Select and configure all desired plots (up to four at one time)  

After setting up the application, you can select the Start command button to take 
measurements. The application displays the results as statistics and as plots if you 
set up the Plots menus and enabled the Plots Display option.  

Note: You can enable and adjust Measurement Limits checking to create a Pass 
or Fail type of compliance test. You can also import industry standard masks and 
modify or create your own masks files. 
 

After taking measurements, you can do any of the following tasks:  

 View the results as statistics  

 Save statistics in a .csv file  

 View the results as a plot  

 Use the Zoom functions in a plot  

 Use the Cursors functions in a plot  

 Save a plot file  

 Print a plot  

 Save the worst case waveforms as .wfm files  
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 Generate a report file  

General Steps to Set Up the Application 

 

Figure 32: Steps to set up the application 
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Selecting an Analysis or Compliance Module 

The RT-Eye application supports dedicated, technology-specific compliance 
modules. 

The application accepts Tektronix compliance modules for industry-specified 
testing. These modules are available as options and require the RT-Eye software. 
If the application does not detect a compliance module, only "Serial Analysis" 
appears in the Modules drop-down list. If the application detects other 
compliance modules, then multiple selections appear in the list.  

The RT-Eye online help only discusses the "Serial Analysis" module operation. 
However, the application also includes separate PDF files with Methods of 
Implementation (MOI) for the InfiniBand and the PCI Express serial data 
standards specific to the corresponding compliance module.  

The Control Panel shows which module is active.  

Selecting the Analysis Module 

View the default Measurements Select menu.  

  

Figure 33: Modules 
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Selecting a Compliance Module 

Note: The compliance module must be installed and enabled before you can 
select it Compliance modules have static configurations and reporting formats 
unique to a specific standard. In general, you can use these modules for design 
verification and "Plug-Fest" testing. 
 

 

Figure 34: Selecting a compliance module  

Choosing the Probe Configuration 

Two of the four typical probing configurations discussed in Connecting to a 
Device Under Test use two channels to make up the differential serial data signal. 
Additional measurements are also available with these probing configurations. 
To set the probing configuration (or if you have two reference waveforms), select 
Single-Ended as the Probe Type option. If the signal is probed differentially so 
that the differential signal is delivered to the oscilloscope on a single channel, 
select Differential as the Probe Type option.  
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Probe Type Definitions 

Table 10. Probe type definitions 
Probe type Description 
Differential* Displays source selections and measurements suitable for 

true differential probing (single connection to scope). 
Single-Ended Displays source selections and measurements suitable for 

pseudo-differential probing (two connections to scope, with 
difference operation performed in software). 

* The default Probe Type for the RT-Eye serial analysis application.  
  

Selecting a Measurement 

You can use the Measurements> Select menu to select measurements for the 
application to take. The application takes all selected measurements.  

This is the default menu when you start the application. You can also access the 
menu by selecting Measurements> Select in the menu bar.  

The measurements will vary depending on the type of probe selected as the Probe 
Type option.  

Use the  button to automatically set the Horizontal and Vertical scales 
of the Sources and the corresponding reference voltage levels. Refer to Autoset 
Button in Measurements Select menu.  

 Use the  button as a short cut to the Plots> Select menu.  

 Use the  button as a short cut to the Measurements> Configure 
menus.  

 Use the  button as a short cut to turn on all the available 
Measurements instead of selecting one measurement at a time.  
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Measurement Definitions 

Table 11. Measurement definitions 
  Area Option Description Units 

Eye Width/ 
Eye Height 

Eye Width is the measured minimum horizontal eye 
opening at the middle reference level as shown in the 
eye diagram. 
Eye Height is the measured minimum vertical eye 
opening at the UI center as shown in the eye 
diagram. 

s or V 

Rise Time** Time difference between when the Hi reference level 
is crossed and the Lo reference level is crossed on 
the rising edge of the waveform. 

s 

Fall Time** Time difference between when the Hi reference level 
is crossed and the Lo reference level is crossed on 
the falling edge of the waveform. 

s 

Unit Interval Cycle duration of the recovered clock. s 
Bit Rate Inverse of Unit Interval. Gb/s 

Timing* 

Differential 
Skew† 

Time delay between two single ended waveform 
sources. 

s 

Differential 
Voltage** 

Statistics for a differential waveform. V 

High 
Amplitude 

Histogram mode of all differential waveform values 
greater than zero. 

V 

Low Amplitude Histogram mode of all differential waveform values 
less than zero. 

V 

CM Voltage† Statistics of the Common Mode voltage waveform. V 
AC CM 
Voltage† 

AC statistics of the Common Mode voltage 
waveform. 

V 

Amplitude 

De-Emphasis Ration of any non-transition eye-voltage to its nearest 
preceding transition eye voltage. 

dB 

Jitter @ BER Deterministic and random components of jitter. s Jitter* 
TIE Jitter Measured time difference between a data edge and a 

recovered clock edge.  
s 

* Use the Time Units option (Results menu) to convert and display the results as Unit Interval. 
** Use the File Preferences menu to restrict measurements to transition bits only. 
† Added when Single Ended is the Probe Type option. 
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Measurements: Select Menu for Differential Probes 

Note: This is the default menu that appears when you start the RT-Eye 
application. 
 

 

Figure 35: Measurement selections for differential probe  

Measurements: Select Menu for Single-Ended Probes 

Note: The application adds measurements when Single-Ended is selected as the 
Probe Type option: Differential Skew, CM Voltage, and AC CM Voltage.  
 

 

Figure 36: Measurement selections for single-ended probe  
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Autoset Button in the Measurements Select Menu 

Select the  button in the Measurements> Select menu to automatically 
set the vertical scale, horizontal resolution, and reference voltage levels for all 
active sources. Depending on the settings in the File> Preferences menu, either 
the autoset operation will occur immediately or the application will display the 
Autoset Summary menu and wait for you to choose the next action.  

The Autoset Summary menu shows the current source autoset and reference level 
autoset values and parameters in a brief outline view. No autoset operation is 
performed until you select  

the  command button. 

 Use the  button as a short cut to the Measurements> Configure 
menus. 

 

Autoset Summary Menu Options 

Table 12. Autoset summary menu options 
Option/function Description 
Autoset Performs the Source Autoset and the Ref Levels Autoset 

functions; values update accordingly. 
Configure Accesses the Configure Ref Levels menu. 
Close Discards changes and closes the menu. 
Do not show this 
menu again* 

Defines whether or not the application displays the Autoset 
Summary menu every time you select the Autoset 
command button in the Measurements>Select menu. 

* If set, use the File Preferences menu to display the Autoset Summary menu. 
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Autoset Summary Menu Example 

  

Figure 37: Autoset Summary 
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Configuring a Measurement 

About Configuring a Measurement 

Measurements may or may not require configuration. A quick way to configure 
measurements is to select the Autoset button in the Measurements Select menu.  

 Use the  button from the Measurements> Select menu as a short 
cut to the Configure menus.  

 

The application includes the following Configure menus: 

  
 Source  

 Ref Levels  

 Smart Gating  

 Clock Recovery  

 Jitter  

 Population  

 General Config  

  



                                                                             Operating Basics                  

RT-Eye ® Serial Compliance and Analysis Application  51

Configure Menu Definitions 

 Table 13. Configure Menu definitions 
Menu name Description 
Source* Specify the source of the measurement as a channel (live) or 

reference waveform, or a File; you can use the Autoset 
functions (only for live sources) to change the vertical scale 
or horizontal resolution of the waveform. 
The automatic Vertical Scale function ensures that the entire 
waveform occupies the full vertical space available in the 
graticule. 
The automatic Horizontal Resolution function ensures that 
there are enough samples for accurate results. 

Ref Levels 
 

Set the reference voltage levels for the thresholds of the 
rising and the falling edges as an absolute value 
The automatic function sets the thresholds relative to the 
minimum and maximum levels of the peak-to-peak values; 
default percentages are 20% and 80%. 

Smart Gating Sets a gated region: Cursor gating, Smart Gating (Custom), 
or no gating at all (Off). 

Clock 
Recovery 

Sets clock recovery to an industry standard method: PLL 
Standard BW, PLL User BW, Constant Clock Mean, or 
Constant Clock Median. 

Jitter Defines the analysis method, data pattern, and Bit Error Rate 
threshold for Jitter@BER measurements. These parameters 
are not required for TIE Jitter measurements. 

Population** Sets the required population for each measurement or 
specifies the number of acquisitions. 

General 
Config 

Sets whether Rise/Fall and Amplitude measurements are 
limited to transition bits or performed for all bits. Enables 
logging of worst case waveforms obtained during scan mode 
in the waveform files directory.  

* All sources must have the same Horizontal Sample Rate, Record Length, and 
Position to assure that measurements function properly. 
** In Free Run mode, sequencing stops when the population limit is met. 
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Sources 

About Configuring the Sources 

The application takes measurements from waveforms or files specified as input 
sources. You can select an oscilloscope channel input (live), a reference 
waveform, or a saved waveform file as the source. The selections available for 
Source Type depend on the Probe Type selected in the Measurements> Select 
menu. 

 Use the  button as a short cut to the Measurements Select menu.  

View the Configure Source menu for Differential probes  

View the Configure Source menu for Single-Ended probes  

  



                                                                             Operating Basics                  

RT-Eye ® Serial Compliance and Analysis Application  53

Configure Source Menu Options for a Differential Probe 

Note: Differential probes do not provide common mode voltage components. 
 

Table 14. Configure source menu for a differential probe 
Area Option Description 

Live/Ref Lists channel or reference waveforms 
for the Select Differential option. 

Source Type 

File* Recalls the input from a single .csv or 
.wfm file; enables the Select File area. 

Select 
Differential** 

Ch1, Ch2, Ch3, Ch4, 
Ref1, Ref2, Ref3, Ref4 

Use a channel or reference waveform 
from which to take VD IFF 
measurements. 

Vertical Scale Sets the display of the waveform to the 
full screen vertically based on the 
amplitude of the source; the Peak-
Peak of the waveform is 80% of the 
ADC full scale. 

Horizontal Resolution Sets the time base parameters to the 
necessary horizontal resolution and 
record length to ensure accurate 
results. 

Autoset† 

Vertical & Horizontal Sets the vertical scale and the 
horizontal resolution. 

* Use the Browser to select a Differential File. 
** Uses a differential mode waveform as the source when Differential is the Probe 
Type option. You can use a Math waveform, such as for a CH1-CH3 operation, if 
you save the resultant waveform, recall the waveform to a reference memory 
location (Ref1, Ref2, Ref3, or Ref4), and then use the Ref waveform as a source.  
† Only available for live (channel) waveforms.  
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Configure Source Menu for Differential Probes 

 

Figure 38: Configure source menu for differential probes  

Configure Source from a File for Differential Probes 

 

Figure 39: Configure source from a file for differential probes  
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Configure Source Menu Options for Single-Ended Probes 

Note: You must use single-ended probes for common mode voltage 
measurements. 
 

Table 15. Configure source menu options for single-ended probes 
Area Option Description 

Live Uses one of the following channel combinations 
for the D+ and D- waveforms:  
CH1, CH3 
CH1, CH4 
CH2, CH3  
CH2, CH4  

Ref Uses any combination of reference waveforms for 
the D+ and D- waveforms. 

Source Type 

File Enables the Select File area. 
Select D+, D- Selections are based on a Live or Ref Source Type option. 

Vertical 
Scale 

Sets the display of each waveform to the full 
screen vertically based on the amplitude of the 
source; the Peak-Peak of the waveform is 80% of 
the ADC full scale. 

Horizontal 
Resolution

Sets the time base parameters to the necessary 
horizontal resolution and record length to ensure 
accurate results. 

Autoset* 

Vertical & 
Horizontal 

Sets the vertical scale and the horizontal 
resolution. 

Select Files** Browse Recalls single-ended inputs from two .csv or .wfm 
files, a D+ and D-. 

* Only available for channel waveforms. 
** Use the Browser to select the Differential File(s). 
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Configure Source Menu for Single-Ended Probes 

 

Figure 40: Configure source menu for single-ended probes 

Configure Source from Ref Waveform for Single-Ended Probes 

 

Figure 41: Configure Source from Ref Waveform for Single-Ended Probes 
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Configure Source from File for Single-Ended Probes 

 

Figure 42: Configure source from file for single-ended probes
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Autosetting Sources for Live (Channel) Waveforms 

In most situations when you want to take measurements from a "live" (channel) 
waveform, you can usually improve measurement accuracy by using the Autoset 
options to optimize the vertical scale or horizontal resolution settings of the 
oscilloscope.  

To automatically define the vertical and horizontal settings for a source, follow 
these steps: 

1. Select Measurements> Configure> Source (or the  tab). 

2. For differential probes, select the  button.  

3. For single-ended probes, select the  button. 

4. In the Select area, choose the specific channel or channels that you are 
using.  

5. Select one of the Autoset area command buttons. Refer to the Configure 
Source Menu Options for Single-Ended Probes topic for a description of 
each option.  

Note: The horizontal autoset in RT-Eye places the instrument in the maximum 
sample rate available. If the 20-80% rise time of the signal is faster than 2X the 
sample interval, interpolation is recommended to increase accuracy of rise time 
and jitter measurements. 
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Reference Voltage Levels 

About Reference Voltage Levels 

You need to set reference voltage levels so that the application can identify state 
transitions on a waveform. Serial data timing measurements are based on state 
transition times in waveforms. By definition, edges occur when a waveform 
crosses specified reference voltage levels. There are two ways to set the reference 
voltage levels: automatically and manually. 

High, Mid, and Low Reference Voltage Levels 

The application uses three reference voltage levels: High, Mid, and Low. 

 For most Time Interval and Jitter measurements, the application only uses 
the Mid reference voltage level.  

The Mid reference level defines when the waveform transition occurs at a given 
threshold. For most NRZ AC coupled signals, you would set the Mid reference 
level to Zero volts.  

The Configure Ref Levels menu includes a "Mid = 0V" option which is set by 
default. You can clear the check box to allow the Autoset function to calculate 
the proper Mid reference level in the presence of common mode voltages 
frequently encountered when using single-ended probes. 

 For Rise Time and Fall Time measurements, the High and Low reference 
voltage levels define when the waveform is fully high or low. 

Reference Voltage Levels Diagram 

  

Figure 43: Reference voltage levels diagram 
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Rising Versus Falling Thresholds 

The option to set separate thresholds for Rising edges vs Falling edges is 
available in Ref Level Control panel, though the feature is not currently 
implemented. The High, Mid and Low thresholds entered in the Rise column are 
actually applied to both rising and falling edges. The values entered in the Fall 
column are ignored. 

Using the Hysteresis Option 

The hysteresis option can prevent small amounts of noise in a waveform from 
producing multiple threshold crossings. You can use a hysteresis when the rising 
and falling thresholds for a given reference voltage level are set to the same 
value. 

The reference voltage level ± the hysteresis value defines a voltage range that 
must be fully crossed by the waveform for an edge event to occur. If the decision 
threshold is crossed more than once before the waveform exits the hysteresis 
band, the mean value of the first and last crossing times is used as the edge event 
time.  

For example, if the waveform rises through the Threshold - Hysteresis, then rises 
through the Threshold, then falls through the Threshold, and then rises through 
both the Threshold and the Threshold + Hysteresis, a single edge event occurs at 
the mean value of the two rising crossings. 

Example of Hysteresis on a Noisy Waveform 

  

Figure 44: Example of Hysteresis on a noisy waveform  
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Cursor Gating and Reference Voltage Levels Autoset 

You can use cursor gating with the reference voltage levels Autoset function. If 
you enable and set up Cursors in the Configure Smart Gating menu, the 
application uses the data within the gated region to automatically calculate the 
reference voltage levels. 

Configuring Reference Voltage Level Autoset 

The Autoset Run button on the Ref Levels tab sets all reference voltage 
thresholds and the hysteresis value to percentages of the base-top voltage 
amplitude for the waveform. The Ref Level Autoset Setup menu allows you to 
configure the percentages to define each threshold. 
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Configuring Reference Voltage Autoset Percentages 

The default Reference Level Autoset parameters should be appropriate for most 
conditions, but you can adjust them for specific situations if you require different 
behavior. 

To configure the Ref Level Autoset Setup menu options, follow these steps:  

1. Select Measurements> Configure> Ref Levels> Autoset Setup.  

2. The Ref Level Autoset Setup menu appears. View the Ref Level Autoset 
Setup menu. 

3. For each reference voltage level you want to adjust, select the keypad icon 
or multipurpose knob icon, and enter the percentage of the base to top span 
of the waveform. The settings are based on the following definitions: 

))((%0 nvmean TRANHIEYE −−=  

))((%100 nvmean TRANLOEYE −−=  

4. Select the OK button to update the values and close the Ref Level Autoset 
Setup menu. 

5. Select the Run command button in the Configure Ref Levels menu. 

6. The application calculates the reference voltage levels based on the 
percentages set in the Ref Level Autoset Setup menu. 

7. If desired, you can manually refine the calculated values in the Configure> 
Ref Levels menu to suit your analysis situation. 
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Steps to Set the Reference Voltage Levels 

  

Figure 45: Steps to set reference voltage levels 



Operating Basics 

64                RT-Eye ®Serial Compliance and Analysis Application 

Reference Level Autoset Setup Menu Options 

Table 16. Reference level autoset setup menu options 
Option* Description** 
Rise, High Sets the high threshold level for the rising edge of the source. 
Rise, Mid Sets the middle threshold level for the rising edge of the source. 
Rise, Low Sets the low threshold level for the rising edge of the source. 
Fall, High Sets the high threshold level for the falling edge of the source. 
Fall, Mid Sets the middle threshold level for the falling edge of the source. 
Fall, Low Sets the low threshold level for the falling edge of the source. 
Hysteresis Sets the threshold margin to the reference level which the 

voltage must cross to be recognized as changing; the margin is 
the relative reference level plus or minus half the hysteresis; use 
to filter out spurious events. 

* Default settings are 80% (High), 50% (Mid), 20% (Low), and 3% (Hysteresis) 
** Where 0% = mean(vEYE-HI-TRAN(n)) and 100% = mean(vEYE-LO-TRAN(n)). 

 

Ref Level Autoset Setup Menu 

 

Figure 46: Reference level autoset set up menu 

Manually Adjusting the Reference Voltage Levels 

Whether or not you use the application to automatically calculate the reference 
voltage levels, you may need to manually change the values. To set the reference 
levels manually, follow these steps:  

1. Select Measurements> Configure> Ref Levels> Source and choose a source 
(channel or reference waveform) for which you want to set the reference 
levels. If the Probe Type is differential, only one choice is available. 

2. In the Set Reference Level area, adjust the values of the reference voltage 
levels and the hysteresis. View the Configure Ref Levels menu.  
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Configure Ref Levels Menu Options  

Table 17. Configure reference levels menu options 
Area Option Description 

Differential Selects the reference levels for the Differential 
waveform or file. 

DPlus* Selects the reference levels for the DPlus 
waveform or file. 

Source 

DMinus* Selects the reference levels for the DMinus 
waveform or file. 

Setup Displays the Ref Level Autoset Setup menu. Ref Level 
Autoset Run Automatically calculates and sets the reference 

levels according the settings in the Ref Level 
Autoset Setup menu. 

Rise, High Sets the high threshold level, in volts, for both 
rising and falling edges of the source waveform. 

Rise, Mid Sets the middle threshold level, in volts, for both 
rising and falling edges of the source waveform. 

Rise, Low Sets the low threshold level, in volts, for the rising 
and falling edges of the source waveform. 

Fall, High Reserved for future use. 
Fall, Mid Reserved for future use. 
Fall, Low Reserved for future use. 

Set Reference 
Level  

Hysteresis Sets the threshold margin, in volts, relative to the 
reference level which the voltage must cross to 
be recognized as changing; the margin is the 
reference voltage level plus or minus half the 
hysteresis; use to filter out spurious events. 

Mid = 0V** Set or clear When checked, sets the middle threshold level to 
0 Volts; when cleared (unchecked), sets the level 
to the value calculated by the application. 

* Only available when Single Ended is the Probe Type. 
** Common mode voltages can be frequently found with single-ended probes. 
Clear this option before you use the Reference Level Autoset function. 
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Configure Ref Levels Menu 

Note: The Source DPlus and DMinus options are only usable when you select 
Single-Ended as the Probe Type option in the Measurements> Select menu.  
 

 

Figure 47: Configure reference levels menu  

Gating Measurements 

About Gated Measurements 

Gating allows you to focus the analysis on a specific area of the waveform bound 
by a gated region, which is a way to filter unnecessary information. To access the 
Smart Gating menu, select Measurements> Configure> Smart Gating. 

You can set up a gated region in one of the following ways: 

 Vertical Cursors  

 Smart Gating 

The application uses the Smart Gating function when you select Smart Gating as 
the Gating option. With Smart Gating, the application establishes a Clock 
Recovery Window, part of the waveform on which the selected clock recovery 
method is applied. An Analysis Window is the part of the waveform on which 
measurements are taken and it is defined relative to the clock recovery window. 
If you enable scanning, the clock recovery window (with its contained analysis 
window) is scanned across the acquired waveform according to the scanning 
parameters. In this case, the results from each scan increment contribute to the 
population of measurements. 

The population of measurement appears in the results panel and the associated 
plots. 
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Configure Smart Gating Menu Options 

Table 18. Configure smart gating menu options 
Area Option Description 

Off No gating occurs; applicat ion takes measurements over 
the entire waveform. 

Cursors Gates the waveform with Vertical cursors. 

Gating 

Smart 
Gating 

Enables the Smart Gating function; refer to the Configure 
Gating Menu Options for Custom Gating topic. 

  

Configure Smart Gating Menu with Gating Off 

 

Figure 48: Configure smart gating menu with gating off  
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Configure Smart Gating Menu with Cursors Gating 

 

Figure 49: Configure smart gating menu with cursors gating  
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Configure Smart Gating Menu Options for Smart Gating 

Table 19. Configure smart gating menu options  
Area Option Description 

Unit Intervals Gates the waveform by Unit Intervals. Gating Units 
Edges Gates the waveform by Edges.  
Length Number of Unit Intervals or Edges that defines 

the size of the window over which the application 
recovers the clock. 

Start Specific Unit Interval or Edge within the record 
where the application starts to recover the clock. 

Clock Recovery 
Window 

Stop Reports the Unit Interval or Edge on which the 
application will stop the clock recovery.  

 Scan Incr Amount by which the Start and Stop values are 
incremented for each new scan, if scan is 
enabled. 

 #Scans Number of scans, if scanning is enabled and 
scan-to-end is disabled. 

 Scan to End of 
Record 

Causes scanning to repeat based on scan 
increment, until the end of the record. 

 Enable Scan Enables scan mode for the measurements. 
Same as 
Clock 
Recovery 
Window 

Enables or disables reusing the same settings for 
the Analysis Window as for the Clock Recovery 
Window option. 

Centers the Analysis Window within the Clock 
Recovery Window. 

Alignment 
Centered 
 
User Defined 

Specifies the absolute position of the Analysis 
Window within the Clock Recovery Window. 

Length Number of Unit Intervals or Edges that defines 
the size of the window. 

Start Specific Unit Interval or Edge where the window 
starts.  

Analysis 
Window  

Stop Reports the UI or Edge on which the window will 
stop. 
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Using Smart Gating 

The Smart Gating control consists of a Clock Recovery (CR) window and an 
Analysis window (Refer to the Smart Gating Diagram). The Clock Recovery and 
Analysis window can be set to scan the waveform record. You can configure the 
starting point and length of the CR window. The resulting Stop value (end point) 
is calculated and displayed. You can also configure the scan increment. The 
clock recovery method selected on the Clock Recovery tab will be applied to the 
CR window to establish the reference clock edges for this portion of the 
waveform. 

The Analysis window is defined relative to the CR window using the Length and 
Alignment controls. If the Alignment control is set to Custom, the Start control 
defines where the Analysis window begins relative to the CR window. As a 
convenience, you can select the "Same as Clock Recovery window" check box to 
make the two windows coincide. 

The following example shows how to apply a CR window of 3500 UI and an 
analysis window of 250 UI, centered within the CR window: 

In the CR window: 

Start: 1, Length: 3.5k. 

In the Analysis window: 

Alignment: Centered 

Length: 250 

 

Configure Smart Gating Menu with Clock Recovery Window 

 

Figure 50: Configure smart gating menu with clock recovery window 
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Configure Smart Gating Menu with Analysis Window 

 

Figure 51: Configure smart gating menu with analysis window 
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Smart Gating Diagram 

 

 Figure 52: Smart gating diagram 

Clock Recovery Measurements 

Clock Recovery Methods 

In serial data standards, jitter measurements are defined in several ways by 
working standards groups. To make the Time Interval Error (TIE) measurement, 
you need to first set the jitter reference clock (or ideal clock). All jitter 
measurements are based on TIE. To comply with industry standards, the RT-Eye 
application allows you to select various clock recovery methods, which can be 
generally categorized as either Constant-Clock (mean-squared best fit straight 
line) or PLL-based. 

Whether the clock recovery method is PLL-based or not, you can specify a 
nominal bit rate to help the clock recovery process. This is especially helpful, for 
example, when the data pattern on the serial link can be interpreted as a different 
pattern at a lower rate. A data pattern of 110011001100… at 5.0 Gb/s looks 
exactly like a pattern of 101010… at 2.5 Gb/s. The application normally uses 2.5 
Gb/s rate but you can also select the 5.0 Gb/s by enabling the Nominal data rate 
control and setting the bit rate. 
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About Constant (Straight-Line) Clock Recovery 

Constant (straight line) Clock Recovery can be applied to the measurements by 
selecting a Constant Clock Mean or Median method in the Clock Recovery tab. 
In Constant Clock Recovery, the clock is assumed to be of the form A*sin 
(2πft+ø), where the frequency (f) and phase (ø) are treated as unknown constants. 
Once a source waveform is acquired and the edges extracted, the clock frequency 
is selected using linear regression, so that the recovered clock minimizes the 
mean squared sum of the Time Interval Error (TIE) for that waveform. 

If Constant Clock: Mean is selected as the clock recovery method, the phase ø is 
also chosen to minimize the mean squared error. If Constant Clock: Median is 
used, the phase is chosen so that the median error between the recovered and 
measured edges is zero. 

  

Figure 53: Constant clock recovery diagram 
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About PLL-based Clock Recovery 

When PLL-based clock recovery is selected, the application simulates the 
behavior of the hardware PLL clock recovery circuit. This is a feedback loop in 
which the voltage-controlled oscillator (VCO) is used to track or follow slow 
variations in the bit rate of the input waveform. Such loops are frequently used to 
recover the clock in communication links that do not transmit the clock as a 
separate signal. The PLL parameters in the application may be adjusted to 
synchronize with the behavior of a receiver in such a link, with certain 
guidelines. 

 

  

Figure 54: PLL-based clock recovery diagram 

PLL-based Clock Recovery Setup 

If PLL-based clock recovery is selected, you can choose the loop bandwidth and 
the loop order. If a second-order loop is chosen, you can specify the damping 
factor. The loop bandwidth can be selected implicitly by specifying a data 
communications standard, or it can be set explicitly. 

To set the loop bandwidth automatically, based on a serial standard, select PLL: 
Standard BW as the clock recovery method. From the Standard: b/s list box, 
select the standard that matches your data link. For example, choose "PCI-E: 2.5" 
to test a 2.5 Gbit/second PCI-Express link. The PLL bandwidth will be set to 
1/1667 of the baud rate. 

To manually control the loop bandwidth, select PLL: User BW as the clock 
recovery method and use the User BW control to select the 3 dB bandwidth of 
the loop, in Hertz. 

You can use the PLL Order list box to choose between first-order and second-
order loop. More correctly, this is the loop type, where a type 1 loop has a 
transfer function that approaches zero frequency with a slope of 1/s and a type 2 
loop approaches zero frequency with a 1/s2 slope. The term Order is used in the 
application in line with popular usage. For a thorough discussion of loop type 
versus order, see Frequency Synthesis by Phase Lock, by William Egan. 
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If you choose a second-order loop, the Damping option is enabled. (The 
Damping Factor does not apply to first-order loops.)  

Note: Although it is possible to configure a second-order PLL with a bandwidth 
as high as 1/10 of the baud rate, such a loop will have poor dynamic 
performance. This is because second-order loops have less phase margin than 
first-order loops.  
 

Clock Recovery Menu Options 

Table 20. Clock recovery menu options 
Area Option Description 
Clock Recovery Method Selects an industry standard clock 

recovery method: Const Clk: Mean, Const 
Clk: Median, PLL: Standard BW, or PLL: 
User BW. 

On/Off Enables or disables bit rate guidance to the 
clock recovery algorithm. 

Nominal Data Rate 
 

Bit Rate Suggests the nominal bit rate. Helpful if 
data rate is ambiguous due to the data 
pattern (for example: “110011001100”). 

Standard: b/s* Implicitly sets the loop bandwidth of the 
clock recovery PLL, based on selection of 
the industry standard and data rate in 
bits/second. 

PLL Loop Bandwidth 
 

User BW** Explicitly sets the loop bandwidth of the 
clock recovery PLL. 

PLL Order Selects between a first- or second-order 
phase-locked loop. 

PLL 

Damping For only second-order loops, adjusts the 
damping ratio of the loop. 

* Only available when you use the PLL: Standard BW Method option. 
** Only available when you use the PLL: User BW Method option. 
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Configure Clock Recovery Menu 

 

Figure 55: Configure clock recovery menu   

Jitter Measurements 

Jitter Measurement Methods 

The basic jitter measurement is the Time Interval Error (TIE) measurement. TIE 
is a measure, on a cycle-by-cycle basis, of how far each edge differs in time from 
where the edge ideally should have occurred. In this context, "Ideal" is 
determined by the clock recovery method. Apart from choosing and configuring 
the clock recovery method and reference levels, no specific setup is required for a 
TIE jitter measurement. 

The advanced form of jitter analysis is jitter separation, also known as Rj/Dj 
analysis. This analysis breaks the timing jitter into various categories and uses 
the results to predict the total jitter at a selected bit error rate (BER). The RT-Eye 
application offers two methods of Rj/Dj analysis:  

 A method based on spectral analysis that is appropriate for cyclic repeating 
data patterns  

 A method that works for any arbitrary data pattern 
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Rj/Dj Analysis of Repeating Patterns Using a Spectral Approach 

This method of Rj/Dj analysis uses a Fourier transform of the time-interval error 
signal to identify and separate jitter components. It is described in the Fibre 
Channel - Methodologies for Jitter and Signal Quality Specification (MJSQ) and 
was the analysis method originally introduced with the RT-Eye application. 

This method requires that the data signal be composed of a pattern of N bits that 
are repeated over and over. The pattern length (N) must be known, although it is 
not necessary to know the specific bits that make up the pattern.  

RjDj Analysis of Arbitrary Pattern 

When the data pattern is not repeating, or is unknown, a second method of Rj/Dj 
analysis may be used. (It may also be used if the pattern is repeating, and 
correlates well with the Spectral method in this case.) This method assumes that 
the effects of Inter Symbol Interference (ISI) only last for a few bits. For 
example, in a band-limited link where a string of ones follows a string of zeros, 
the signal may require three or four bit periods to fully settle to the "high" state. 

In this method, an analysis window with a width of K bits is slid along the 
waveform. For each position of the window, the time interval error of the 
rightmost bit in the window is stored, along with the K-1 bit pattern that preceded 
it. After the window has been slid across all positions, it is possible to calculate 
the component of the jitter that is correlated with each observed K-1 bit pattern, 
by averaging together all the observed errors associated with that specific pattern. 

In the configuration menu for the arbitrary-pattern method, the Window Length 
field allows you to select how many bits are included in the sliding window. The 
window should include enough bits to encompass the impulse response of the 
system under test, usually 5 to 10 bits. A good practical test is to check whether 
increasing the window length causes any appreciable change in the jitter results; 
if not, the window length is effectively capturing all the ISI effects. The 
disadvantage of increasing the window length is that it uses more memory and 
slows the processing. 

The configuration menu also includes a field for selecting what population of 
each K-1 bit pattern must be accumulated before the TIE associated with that 
pattern is considered accurate. Using a larger population means that more 
observations are averaged together, so that the variance of the measurement is 
reduced. Specifying a larger population has the disadvantage of requiring a 
longer measurement period before results can be calculated.  

It may be necessary to sequence the instrument several times before enough 
statistics are accumulated to provide results. 

The arbitrary pattern approach for measuring jitter may not be appropriate if 
there are very-long-duration memory effects in your data link. An example would 
be if there are impedance mismatch reflections that arrive long enough after the 
initial edge to fall outside the analysis window. 
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Configure Jitter Menu Options 

Table 21. Configure jitter menu options 
Option Description 
Type Must be set to correspond to the 

data pattern on the serial link. Use 
Repeating for cyclically repeating 
patterns, and Arbitrary for any data 
content. 

Pattern* Sets the repeating data pattern 
length automatically for various 
popular patterns. 

Length* Sets the data pattern length 
explicitly if the Pattern list box is 
set to Custom. 

Window 
Length** 

 

Sets the number of history bits 
over which the effects of DDJ can 
be monitored. 

Data 
Pattern 

Population** Sets the required population of 
observations of each DDJ pattern 
that must be reached before the 
TIE caused by that pattern is 
deduced. 

Rj/Dj BER=10-e? Sets the Bit Error Rate exponent, 
thereby setting the statistical level 
at which Total Jitter and Eye 
Opening are reported. 

* Only available when you use Type = Repeating. 
** Only available when you use Type = Arbitrary. 
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Configure Jitter menu for Repeating patterns 

 

Figure 56: Configure jitter menu for repeating patterns  

Configure Jitter menu for Arbitrary patterns 

 

Figure 57: Configure jitter menu for arbitrary patterns  
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Bathtub Curve: BER versus Decision Time 

The Bathtub Curve plot shows the eye opening and total jitter values as functions 
of the BER level. The plot is obtained from the Rj/Dj separation that is 
automatically performed when a Jitter@BER measurement is executed. 

  

Figure 58: Bathtub Curve 

Population for Measurements 

Setting the Population for the Measurements 

The Population control allows you to limit the amount of waveform data that is 
analyzed. This is often done in industry standards to make sure that there is 
consistency between measurement techniques. You can use the Configure 
Population menu to set a limit on a maximum population to obtain for all selected 
measurements. View the Configure Population menu.  

To define the maximum population for measurements, follow these steps: 

1. Select Measurements> Configure> Population> On. 

2. Select Limit By and choose a waveform characteristic on which to base the 
population. 

3. Select Limit and specify a population limit from one to one million. 

If you use a population limit, Statistics individually accumulate for each 
measurement that reports the Current acquisition statistic to the population limit. 
A Free Run stops when all such active measurements reach the population limit. 
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An acquisition population limit applies to all active measurements; statistics will 
accumulate until the acquisition limit is reached. 

You can use a population limit for a Single Run. If the limit is less than the 
normal population for that Single Run then the measurement statistics will stop at 
the limit.  

Configure Population Menu Options 

Table 22. Configure Population menu options 
Area Option Description 
Population Limit On 

Off 
Enables or disables the application from using a 
population limit while taking measurements. 

Limit By Uses Acquisitions or Measurements to count 
the population. 

Configure 

Limit Specifies the maximum number of Acquisitions 
or Measurements the application takes before 
sequencing stops. 

  

Configure Population Menu  

 

Figure 59: Configure Population menu  
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General Config 
The General Config control allows you to set rise, fall, and amplitude 
measurements either for transition bits or all bits. The transition bits refer to edge 
transitions for which the preceding transition was only one unit interval away. 
This may be important for signals with pre-emphasis, since the transition 
following a string of two or more like bits has an intentionally low swing that 
you may not want to measure. 

You can also set the option to save maximum and minimum values of the worst 
case waveforms obtained during scan mode to files in the waveforms directory. 

 

Figure 60: General config menu     

Table 23. General config options 
Option Description 
Limit Rise/Fall 
measurements to transition 
bits 

Acquires and takes Rise Time/ False Time 
measurements only from transition bits; non-
transition bits are not acquired. 

Limit Amplitude 
Measurements to transition 
bits 

Acquires and takes amplitude measurements 
only from transition bits; non-transition bits are 
not acquired. 

Enable worst case logging 
while in scan mode 

Enables or disables saving the maximum and 
minimum values of the worst case waveforms to 
files for each source. 
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Measurement Limits 

About Using Measurements Limits File 

Each serial data application provides a Limits file that includes combinations of 
all measurements and statistical characteristics, and an appropriate range of 
values for each combination. The application can use the Limits file and a mask 
file to determine the Pass or Fail status for compliance tests. 

To test against a Limits file, you need to enable measurements limits checking, 
and enable a mask file in the Plots menus. View the Measurements Limits menu.  

Creating a Measurements Limits File 

You can use the Limits File Editor functions to create a Limits file. The editor 
includes variable range options to suit your specific needs. 

To create a Limits file, follow these steps: 

1. Select Measurements> Limits. 

2. Select . The Limits Editor window appears. 

3. Select . The editor adds a measurement with None selected. 

4. In the new row, select a Measurement, type of Statistic, a Lower Limit value 
and an Upper Limit value as appropriate. View an example of a 
Measurements Limits Editor window.  

5. Select . The application verifies that the limits for each 
measurement are valid and that there are no duplicates.  

6. Select . The application removes measurements where the 
selection is None. 

7. Select File> Show Summary. View an example of a Show Summary list 
from the limits file.  

The next time you select , the application compares the measurement 
results against the Limits file and the mask file, and then displays the status as 
Pass or Fail in the results menus. 
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Editing a Measurements Limits File 

You can use the Limits File Editor functions to edit an existing Limits file. To 
edit a Limits file, follow these steps: 

1. Select Measurements> Limits. 

2. Select  and navigate to the directory where the Limits file resides. 

3. Select a file, and then Open. 

4. The selected file appears in the Limits Editor window.  

5. Edit the file as necessary. To delete a measurement, select None. 

6. Select . The application verifies that the limits for each 
measurement are valid and that there are no duplicates. 

7. Select  to remove the rows where None is selected as the 
measurement. 

8. Select File> Show Summary. View an example of a Show Summary list 
from the limits file.  

Measurements Limits Menu Options 

Table 24. Measurement limit menu options 
Area Option Description 
Limits On 

Off 
Enables or disables the application from checking the 
measurements limits; when enabled, the application 
displays the results as Pass or Fail. 

Current Edit the currently displayed Limits f ile. Limits File 
Editor* New Create a new Limits file. 
Limits File Browse Locate the directory and select an existing Limits file; 

you can use the virtual keyboard to enter a f ile name. 
* Opens the Limits File Editor window. 
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Measurements Limits Menu 

 

Figure 61: Measurement Limits menu  

Measurements Limits Editor Toolbar Functions 

Table 25. Measurement limits editor toolbar functions 
Tool/option Description 

 New 
 

Opens a new file. 

 Open 
 

Opens an existing file. 

 Add 
 

Adds a measurement and associated limits. 

 Clear All 
 

Deletes all measurements. 
  

Measurements Limits Editor Menu Options 

Table 26. Measurement limits editor menu options 
Tool/option Description 
Compact Removes measurements where None is selected. 
Validate Verif ies that limits are valid, such as an upper limit cannot be 

lower than a corresponding lower limit. 
Save As Opens a Save File dialog box. 
Cancel Discards changes and closes the Limits Editor window. 
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Measurements Limits Editor Menu 

  

Figure 62: Measurement limits menu 
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Measurements Limits File Summary 

  

Figure 63: Measurement limits file summary 
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User Masks 

About Using Standard Masks 

You can use masks based on serial data standards for compliance testing of 
DUTs. 

Industry standard masks are available from the file browser in the Plots 
Configure menu (for an Eye Diagram plot). The mask files are selected from the 
following directory: 

  C:/TekApplications/tdsrt-eye/Examples/Masks  

The standards supported are as follows: 

 InfiniBand  

 PCI Express 

 Ethernet (Including XAUI) 

 1394B 

 Fibre Channel 

 FB-DIMM  

 Serial ATA 

 SAS (Serial Attached SCSI) 

 Serial Rapid IO 

 

You can edit a mask file to create a custom user mask through one of the 
following methods: 

 Using the User Mask File Editor available in the Mask menu (if enabled) in 
your oscilloscope 

 Manually using a text editor  
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Using the User Mask File Editor 

To edit a mask file with the User Mask File Editor of the oscilloscope, follow 
these steps: 

1. From the menu bar of the oscilloscope, select Masks> Mask Edit Setup. 

2. Select the Recall button and navigate to the following directory: 
C:\TekApplications\tdsrt-eye\modules\SerialAnalysis\masks 

3. Recall the user.msk file. 

4. Follow the instructions in the online help of the oscilloscope to edit and save 
the file.
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Mask File in the Oscilloscope Mask Editor 

 

Figure 64: Mask file in oscilloscope mask editor  
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Import of User Mask 

 

Figure 65: Import of user mask  
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Manually Editing a Mask File 

If you do not have a Mask Editor available in your oscilloscope, you can use a 
text editor to manually edit a mask file.  

The User Mask File Opened in a Text Editor diagram shows an .msk file revised 
using the Mask Editor in a TDS7000 series oscilloscope. The diagram shows the 
fields used by the RT-Eye application in red boxes. 

Note: The application ignores all other fields. The mask file must contain SEG1, 
SEG2, and SEG3 fields for proper operation.  
 

To change the geometry of the mask, use a text editor to edit the following fields: 

Table 27. Mask fields 

 

Mask file field Description* 
MASK: USER: WID Defines unit interval. 
MASK: USER: SEG1: POINTS Defines 1st segment vertices in X,Y coordinates.
MASK: USER: SEG2: POINTS Defines 2nd segment vertices in X,Y 

coordinates. 
MASK: USER: SEG3: POINTS Defines 3rd segment vertices in X,Y coordinates.
* Where the X coordinate is in time (ps) and the Y coordinate is in amplitude (V). 
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User Mask File Opened in a Text Editor 

This diagram shows the fields used by the RT-Eye application in red boxes. You 
can edit these fields to change the geometry of the mask. 

 

Figure 66: User mask file opened in text editor  
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Creating a New User Mask File 

If need be, you can create a new User Mask file using a text editor. This is an 
alternative to editing an existing mask. To do so, follow these steps: 

1. Create a new file using a text editor. 

2. Enter User Mask information. 

3. Save as a .msk file. 

4. Recall the file in the Plots Configure menu. 

Mask File Edited Using a Text Editor Example 

  

Figure 67: Mask file edited using a text editor 

Recalling a User Mask in the Plots Configure Menu 

To recall a User Mask file to the RT-Eye application, follow these steps: 

1. From the menu bar of the RT-Eye application, select Plots> Configure. 

2. Select On in the Mask area. 

3. Select User as the Standard option.  
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Taking Measurements 

About Taking Measurements 

If you want to change trigger settings or localize the measurement, you should do 
so before you take any measurements.  

Note: If you select a reference waveform as the source, you need to recall and 
display the waveform on the oscilloscope before the application can take a 
measurement. To do so, refer to recalling a waveform file. 
 

Note: If an error message appears because there are not enough cycles from 
which to take a measurement, adjust the Horizontal setting on the oscilloscope to 
increase cycles. 
 

  

Localizing Measurements 

By specifying the trigger position, the starting point, and the length of the 
waveform, you can effectively filter out information that is not useful to analyze 
before taking a measurement.  

To focus the application measurement on a part of the waveform, you can use the 
Configure Smart Gating menu. You can also adjust the Record Length, Scale, or 
pre-trigger information in the oscilloscope Horizontal menu, or the trigger level 
and slope in the Trigger menu. 

You can also set up the File Preferences menu for the application to use only 
transition bits.  

About Sequencing 

You use the Control Panel to start or stop the sequence of processes for the 
application and oscilloscope to acquire information from a waveform. The 
application then determines if the algorithm for the selected measurement can be 
applied to the waveform information. Sequencing is the steps to acquire 
waveform information, determine if the information is usable for the 
measurement, take the measurement, and display the results. 

There are three Sequencing modes: Single Run, Single No Acq, and Free Run.  
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Acquiring Data 

To acquire data from waveforms and take measurements, follow these steps: 

1. In the Control Panel (on the right side of the application display), select a 
Sequence mode.  

2. The application uses the Sequence mode to acquire waveforms and take 
measurements when you select the Start command button. The choices are: 
Single Run, Free Run, and Single No Acq. 

3. Select the  button for continuous acquisitions or for measurements 
on a new or existing acquisition.  

4. If you select the Single Run or the Single No Acq mode, the application 
displays the results when the sequencing is complete.  

If you select the Free Run mode or decide to stop sequencing,  

select the  Stop button to stop the sequencing. 

In Free Run mode, the sequencing also stops once the application has reached the 
limit set in the Configure Population menu. 

Note: The application displays a status bar when it is busy sequencing. The 
status at the bottom of the Control Panel indicates Ready when the sequencing is 
complete. It may also indicate Stopping before indicating Ready.  
 

 Use the  command button to delete all measurement results. 
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Control Panel Functions 

Table 28. Control panel functions 
Command button Description 
Start Start command button; use to start the sequencing based 

on the selected Sequence Mode. 
Stop Stop command button; use to stop the sequencing. 
Clear Results Clear Results command button; use to clear all previous 

results in the Results Summary menu, Results Details 
menu, Plot Summary window, and Plot Details window; 
data saved to files remains intact (.csv, .wfm files, etc). 

  

Sequence Mode Option Definitions 

Table 29. Sequence mode option definitions 
Mode Description 
Single Run Acquires a new waveform if the source is Ch1, Ch2, Ch3, or 

Ch4; for all sources, the application sequences until complete 
and displays the results or plots (if set up). 

Single No Acq Recalculates the selected measurements without acquiring 
new data and displays the results or plots (if setup). 

Free Run* Continuously acquires waveforms and sequences until you 
select the Stop command button. 

*Sequencing stops when the sequencing reaches the population limit; plots 
display (if set up and enabled) when you select Stop. 
  

Chunking/Scan mode behavior of Eye Plot 

In this mode, the waveform is analyzed from the Start value to the Stop value 
configured in Smart Gating tab. The number of scans depends upon the scan 
increment and size of the window values. For example, if an eye diagram is 
selected, then the eye diagram plot keeps updating with new result for each 
window.  
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Figure 68: Scan mode behavior of eye plot  

The RT-Eye application can be configured in different modes and the results vary 
accordingly. The modes are: 

 Single shot, scan mode off 

 Single shot, scan mode on 

 Free run, scan mode on 

 Free run, scan mode off 

Single shot, Scan mode off 

The application acquires and analyzes the entire waveform and then holds with 
the analyzed waveform on the oscilloscope display. The entire waveform (or the 
gated portion of the waveform, if cursor or smart gating is employed) is analyzed 
and the result is displayed in a single shot. For example, if an eye diagram is 
selected, then each data bit in the gated portion of the waveform appears in the 
center of the eye diagram exactly one time. 
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Single shot, Scan mode on 

The application acquires and retains the entire waveform, and then analyzes the 
configured scan windows. After each scan window is analyzed, the results for 
that window are added to the cumulative results and the eye diagram, if 
displayed, accumulates the eye results from the latest window with all prior 
windows. Depending on the gating and scanning parameters, some bits in the 
waveform may not be analyzed or some may be analyzed two or more times.  An 
option is available to select worst case results, in which case, the worst of all the 
scan windows analyzed is shown. An option is available to select worst case 
results in which case the worst of all the scan windows analyzed is shown. 

 

Free run, Scan mode off 

The application acquires the waveform, analyzes it, accumulates the results with 
any existing results, and refreshes all plots. The cycle repeats immediately. This 
continues until the Stop button is clicked or the population limit is reached.  

 

Free run, Scan mode on 

The application acquires the waveform and performs one analysis cycle on each 
scan window, thus updating the results and plots after each scan window. Once 
the configured number of scan windows has been analyzed, a new waveform is 
acquired and the measurement cycle is repeated. This continues until the Stop 
button is clicked or the population limit is reached. 
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Control Panel 

  

Figure 69: Control Panel 

About the Results 

There are two ways to view the results after an analysis is complete: statistical 
values or graphical plots.  

If you enable the plots before taking measurements, the application shows the 
selected plots in a separate window in the oscilloscope part of the display. The 
application shows statistics in the application part of the display. When you use a 
Limits Module, the application also shows the results as Pass or Fail. 
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 Statistical Results 

About Viewing Statistics 

There are two ways to view the statistical results of measurements: Results 
Summary Menu and Results Details Menu.  

Viewing Statistics 

To view measurement statistics, select the Results Summary or the Results 
Details menu. The application displays results for the measurements of all 
acquisitions or for the current acquisition. 

The Results Summary menu shows the current data and all acquisition data for 
each statistical value.  

The Results Details menu contains statistical values for the following 
characteristics: 

 Population 

 Mean 

 Standard deviation (StdDev) 

 Maximum (Max)  

 Minimum (Min) 

 Pk-Pk 

See the Results Summary menu for an example of the tabular listing of statistics 
of selected measurements. 

See the Results Details menu for an example of details of selected measurements.  
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Results Summary Menu Options 

Table 30. Result summary menu options 
Option Description 
Select View Bases the results summary on All Stats or Limits Status*. 

 
Lists selected measurements. 
Lists a statistical value for the mean characteristic. 
Lists a statistical value for the minimum characteristic. 
Lists a statistical value for the maximum characteristic. 
Lists a statistical value for the peak-to-peak characteristic. 

(Table) 
  Measurement 
  Mean 
  Min 
  Max 
  Pk-Pk 
  Status Displays if the measurement is Pass or Fail. 
Show Plot Updates and displays the Plot window, if enabled. 
Export to CSV Displays the Export to CSV file dialog where you can locate 

a suitable directory and enter an appropriate file name. 
Details Shortcut to the Results Details menu. 
Time Units Displays results in Unit Intervals, seconds, or the natural unit 

for the measurement, such as mV. 
* Only available when you enable measurement limits.   
  

Results Summary Menu 

 

Figure 70: Results summary menu 
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Results Details Menu Options 

Table 31. Results details menu options 
Option Description 
Select View Displays details for the measurement selected as this 

option. 
Show Plot Displays the Plot window if enabled. 
Export to CSV Displays the Export to CSV file dialog where you can locate 

a suitable directory and enter an appropriate file name.  
Summary Shortcut to the Results Summary menu. 
Time Units Displays results based on Unit Intervals seconds, or the 

natural unit for the measurement, such as mV. 
  

Results Details Menu 

 
Figure 71: Results details menu 
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Saving Statistics to a .CSV File 

You can save the statistics to a "comma separated variable" file to import into a 
text editor, a spreadsheet, or an analysis tool. View the Results Summary menu 
or the Results Details menu. 

To save the results summary or details to a "comma separated variable" (.csv) 
file, follow these steps: 

1. Select either Results menu. 

2. For the Results Details menu, select the measurement whose details you 
want to save from the Results Details Select View drop-down list.  

3. For the Results Summary menu, Limits Status is only available if you 
enabled measurement limits before taking measurements.  

4. Set the Time Units option to Seconds or to Unit Interval. To save both types 
of information, you need to save two .csv files. 

5. Select the  button. The Save browser opens.  

6. Enter a file name. The application appends the .csv suffix to the name. 

7. Select the Save button to save the file. 

 If the oscilloscope is connected to a network, you can use the Explorer 
to move the file. 

 If the oscilloscope is not connected to a network, you can copy the file 
to a floppy disk.  
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Plotting the Results 

About Plotting 

The application can display the results as two-dimensional plots for easier 
analysis. Before you take measurements, you can set up the Plots Select and Plots 
Configure menus to define up to four plots. When enabled, the plots will display 
when the application completes sequencing. 

The application uses MATLAB-based windows to display plots.  

Note: When taking measurements in the Free Run mode, you must stop the 
sequencing before you use the Plots Select or Plots Configure menus.  
 

Note: Be sure to configure a printer before you print a plot.  
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Plot Type Definitions 

Table 32. Plot type definitions 
Plot type Description 
Eye Diagram Represents data for the eye diagram based on the recovered 

clock as the timing reference; used for mask testing. 
Waveform 
with Bit Error 
Locator 

Represents the acquired waveform. It is available for use with 
eye diagram mask tests to locate bit errors in the real-time 
waveform.   

Histogram Represents measurements sorted by value as a distribution of 
measurement values versus the number of times the value 
occurred. 

Spectrum Represents the frequency content computed using the FFT of 
the Time Trend plot. 

Bathtub Represents the Bit Error Rate versus the jitter eye opening for 
measurements that include Rj/Dj analysis. 

  

Measurements and Available Plots 

Note: Measurements not listed are unsuitable for plots (Unit Interval, 
Differential Skew, Differential Voltage, High Amplitude, Low Amplitude, CM 
Voltage, and AC CM Voltage). 
 

Table 33. Measurement and available plots 
Measurement Eye Diagram Histogram Spectrum Bathtub  Waveform
Eye Width/ 
Eye Height 

Yes No No No Yes 

Rise Time No Yes No No No 
Fall Time No Yes No No No 
Unit Interval No Yes No No No 
Bit Rate No Yes No No No 
Differential Skew No Yes No No No 
Differential 
Amplitude 

No Yes No No No 

De-Emphasis No Yes No No No 
Jitter@BER No No No Yes No 
TIE Jitter No Yes Yes No No 
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Plot Window Layouts 

  

Figure 72: Plot window layouts 

Eye Diagram Plot Usage 

The clock recovery used for Real-Time Eye (RT-Eye) rendering is software 
based. The ideal clock (jitter reference clock) is recovered from the serial bit 
stream. The actual locations of the rising and falling edges of the acquired 
waveform are then "rendered" with respect to the recovered clock, creating an 
eye diagram. The clock is recovered from a single waveform acquisition which 
means that trigger jitter is eliminated from the eye diagram.  

If you use a CSA7000 series or a TDS6000/7000 series oscilloscope with Option 
SM, hardware (HW) clock recovery is also available through the Masks menu in 
the oscilloscope application. The HW clock recovery is based on phase-locked 
loop (PLL).  

Eye diagrams created using HW PLL are called Equivalent Time (ET) eye 
diagrams and are susceptible to trigger jitter. The ET Eye diagram is useful as a 
first check of signal quality and for debug purposes. RT-Eye rendering provides 
high precision "de-jittered" eye diagram with a very small Jitter Noise Floor 
(JNF) required for compliance testing.  
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RT-Eye (Real Time) Rendering  

 

Figure 73: RT-Eye rendering  
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ET-Eye (Equivalent Time) Rendering 

 

Figure 74: ET-Eye rendering 
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Usage of Waveform with Bit Error Locator  

You can find eye diagram mask failures on waveforms using the Bit Error 
Locator feature. The white on the mask shows waveform mask violations. The 
same violations can also be seen on pulse plot. The pulse plot shows the acquired 
waveform data similar to the oscilloscope screen. You can correlate the failures 
between the Eye Diagram and the waveform by looking at the red violations. 
From the waveform plot, and whether it failed on the rising or falling edge of the 
sample. This technique is useful for discovering data dependent behavior that 
may be causing bit errors. The waveform plot can be used in conjunction with the 
oscilloscopes waveform displays to time correlate failures due to crosstalk or 
power supply noise. For instance, Ch2 can be used to acquire the suspected 
offender signal and it can be compared to the serial data signal acquired on Ch1 
for time correlation. 

 

Figure 75: Waveform with bit error locator  
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Histogram Plot Usage 

Histogram plots display the results such that the horizontal axis represents the 
measurement values and the vertical axis represents the number of times that the 
value occurred. Unlike any other plot, a histogram plot accumulates 
measurements over multiple acquisitions, up to a total population size of 2.1 
billion. 

Histograms are particularly useful in analyzing jitter. A histogram of the Time 
Interval Error (TIE) represents the basis of jitter analysis using a histogram 
approach. In a histogram, Deterministic Jitter (Dj) is bounded in a system and 
shows up as a non-gaussian distribution. Random Jitter (Rj) is unbounded and 
amplitude will continue to grow the more population is acquired. The TIE 
histogram is a good first look analysis of jitter.  

 Spectrum Plot Usage 

A spectrum plot is the Fourier transform of measurement values versus time. 
This plot is useful in identifying frequency components that contribute to timing 
errors, such as modulation of the measurements. An example of where this is 
useful is plotting a "Jitter Spectrum". Jitter Spectrum is the FFT of the trend of 
time interval error. This reveals the frequency components of the output jitter.  

Further analysis on the Jitter Spectrum can be used to separate Random Jitter (Rj) 
from Deterministic Jitter (Dj) as well as separate Dj components of Periodic Jitter 
(Pj) and other Dj components such as ISI and DCD. The frequency of periodic 
jitter spikes that do not correlate to frequencies contained in the data pattern can 
be a clue that you should look at frequencies of different components in your 
design as possible sources of jitter.  
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Bathtub Plot Usage 

Bathtub curves are the industry standard way of viewing the Jitter Eye Opening. 
A Bathtub curve represents a plot of the eye opening versus the BER (Bit Error 
Ratio). Most 8B/10B encoded copper standards call for Total Jitter to be 
measured at 10-12 BER. The eye opening represented by the Bathtub Curve is 
what is left of the unit interval after the total jitter measurement is subtracted. A 
detailed discussion of bathtub analysis can be found in the MJSQ document at 
www.t11.org.  

The Jitter Eye opening and the Total Jitter have the following relationship: 

Total Jitter + Jitter Eye Opening = 1 Unit Interval 

Selecting and Configuring Plots 

Selecting Plots for Configuration 

Before you take measurements, you can set up plots in the Plots Select menu.  

To select a plot to configure, follow these steps: 

1. Select Plots>Select.  

2. Select the On button. 

3. Select a measurement in the Select Measurement column.  

4. Select a plot type in the Select Subplot column. 

 Use the  button as a short cut to the Measurements> Select 
menu. 
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Plots Select Menu Options 

Table 34. Plot select menu options  
Area Option Description 

Measurement Select an active measurement to plot. Select 
Subplot Plot Type Select the type of plot to depict.  
Plots Display On 

Off 
Enables or disables the display of plots. 

Plots Refresh Updates the plot window when you deselect a 
plot or when you reselect a plot. 

  

Plots: Select Menu 

 

Figure 76: Plots select menu  
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Configuring Plots 

After you select the plots, you can further configure each measurement and plot 
combination. The options are relative to the selected plot type in the Subplot 
column. 

To configure a plot, follow these steps: 

1. Select the  tab. 

2. Select a measurement in the Select Measurement column. 

3. Select a plot type in the Select Subplot column. Plot options depend on the 
type of selected plot. 

4. For the Eye Diagram plot, masks are available for many standards and you 
can create your own custom designed mask. For more information on User 
masks, refer to the About Using User Masks topic.  

5. Configure the plot. 

6. Select the  tab. 

7. Select the  command button. 

The Plot Summary Window updates and displays the selected plots. View an 
example of the Plot Summary Window.  
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Plots Configure Menu Options for an Eye Diagram 

Note: For more information, refer to Eye Diagram Plot Usage. 
 

Table 35. Plots configure menu options for an eye diagram 
Area Option Description 

Transition Renders an Eye Diagram only for transition bits.  
Non Transition Renders an Eye Diagram only for nontransition 

bits.  

Bit Type 

All Renders an Eye Diagram for all bits. 
On 
Off 

Enables or disables the display and mask testing. 

Standard Specifies a User-defined* mask or a mask based 
on a serial data standard, such as InfiniBand or 
PCI Express.  

Mask 

Type** Selects a type of mask specific to the selected 
standard; See list (receivers, cables, test points). 

* Browse for a mask file to import from the tdsrt-eye/Examples/Masks directory. 
** Available when you select a serial data standard as the Standard option. 
  

Plots Configure Menu for an Eye Diagram 

Note: For more information, refer to Eye Diagram Plot Usage. 
 

 

Figure 77: Plots configure menu for an eye diagram  
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Plots Configure Menu Options for a Histogram 

Note: For more information, refer to Histogram Plot Usage. 
 

Figure 36. Plots configure menu options for a histogram 
Option Description 
Vertical Axis Sets the vertical axis in a linear scale (default) or in a 

logarithmic scale. 
Bin Resolution Defines resolution by time. 
  

Plots Configure Menu for a Histogram 

Note: For more information, refer to Histogram Plot Usage. 
  

 

Figure 78: Plots configure menu for a histogram  
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Plots Configure Menu Options for a Spectrum 

Note: For more information, refer to Spectrum Plot Usage. 
 

Table 37. Plots configure menu options for a spectrum 
Option Description 
Vert. Scale Depicts the vertical axis in a linear scale (default) or in a 

logarithmic scale.  
Horiz. Scale Depicts the horizontal axis in a linear scale (default) or in a 

logarithmic scale.  
  

Plots Configure Menu for a Spectrum 

Note: For more information, refer to Spectrum Plot Usage. 
 

 

Figure 79: Plots configure menu for a spectrum  
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Plots Configure Menu Option for a Bathtub 

Note: For more information, refer to Bathtub Plot Usage. 
 

Table 38. Plots configure menu option for a bathtub 
Option Description 
Scale Depicts both axes in logarithmic scale (default) or in linear scale.  
  

Plots Configure Menu for a Bathtub 

Note: For more information, refer to Bathtub Plot Usage. 
 

 

Figure 80: Plots configure menu option for a bathtub  
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 Viewing Plots 

About Viewing Plots 

There are two windows you can use to view and analyze plots: Plot Summary 
and Plot Details. The application includes tools to help you size and position the 
window, display either window, and display the details of another plot directly 
from the details window. 

After you select and configure a plot, select the  command button. When 
sequencing is complete, the Plot Summary Window appears with up to four plots. 
View an example of a Plot Summary Window.  

If you reconfigure a plot and want to view the updated plot, follow these steps: 

1. Select the  button.  

2. Select the  command button.  

The plots window updates according to any changes you made to the Plots Select 
or Plots Configure menus. 

The Plot Details tools represent the plots by quadrant in the Plot Summary 
Window. View Show Plot Details tools. For example,  

you can select the  tool to display details for the plot in the upper left quarter 
of the Plot Summary window. View an example of a Plot Details Window.  

 If you have a keyboard, you can use the alt-tab Window shortcut to quickly 
select a window for viewing. 

 If you have a second monitor, you can select and drag the title bar of the 
plot window to position it in the other monitor. 
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Using a Separate Monitor to View Plots 

If your oscilloscope setup includes a second monitor that extends the Windows 
desktop, you can select and drag the title bar of the plot window to position it in 
the second monitor. This allows you to simultaneously display a waveform on 
the oscilloscope, the RT-Eye measurement results, and the plot for easy viewing. 

Toolbar Functions in Plot Windows 

The Plot Summary window includes the following toolbar: 

  
The Plot Details window includes the following toolbar: 

  
Some functions are specific to the Plot Summary window and others are specific 
to the Plot Details window. The next table lists the available functions in each 
type of plot window. 

Table 39. Plot details window options 
Tool icon Function Summary Details 

 Save Yes Yes 

 Print Yes Yes 

 View Details Yes No 

 Size and position window Yes Yes 

 Zoom No Yes 

 
Cursors No Yes 

 Grid No Yes 

 Return to Summary No Yes 
  



                                                                             Operating Basics                  

RT-Eye ® Serial Compliance and Analysis Application  121

Plot Summary Window Example 

This plot window includes save, print, view details, and size and position 
window functions.  

 

Figure 81: Plot summary window  
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Plot Details Window Example 

This plot window includes save, print, zoom, cursors, grid, view summary, and 
size and position window functions. 

 

Figure 82: Plot details window  
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Plot Summary and Details Window Example 

 

Figure 83: Plot summary and details window example  
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Viewing a Plot in the Whole Display or in Half the Display 

You can change the plot size to the whole display of the oscilloscope, or to half 
the display. When viewing a plot in half the display, you can position the plot in 
the upper or lower half. 

  enlarges the plot to fill the entire display 

  reduces the plot to half the display, if need be, and positions it in the 
upper half  

  reduces the plot to half the display, if need be, and positions it in the 
lower half 

Returning to the Plot Summary Window 

To return to the Plot Summary window, select the  tool. 
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Using Zoom and Cursors in a Plot 

You can use the zoom and the cursors functions simultaneously in the Plot 
Details window. To do so, follow these steps: 

 Select the  tool and draw a box around the area bound with the cursors. 

 Use the cursors to take measurements. 

 Repeat the previous steps if need be. You can zoom in by a magnification of 
20X. 

 Select the  and the  tools to display the horizontal and the vertical 
cursors. 

 Move the cursors to bound the area you want to view more closely. 
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Removing Plots 
To remove a plot from a plot window, follow these steps: 

1. Select Plots> Select. 

2. Select None for the measurement in the Select Measurement column. 

3. Select the  command button. 

The plot window updates and does not display the deselected plot.  

Using Zoom in a Plot 

About Using Zoom in a Plot 

Once you have created a plot, you can use the Zoom tools in either plot window 
to examine the data at various scales. View the Plot Zoom tools.  

 You can quickly restore the view to display all the data. To do so, select 
the  tool.  

 If you prefer to move the cursors in the plot window with your finger, you 
can activate the Touch Screen on the oscilloscope.  

 

Plot Zoom Definitions 

 Table 40. Plot zoom definitions 
Zoom type Description 

 In Expands part of the plot; the data appears in more detail. 

 Out Contracts part of the plot; the data appears in less detail. 

 X axis Expands the horizontal axis only and retains the vertical axis. 

 100% Restores the plot to display all the data. 
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Changing the Scale of Data in a Plot (Zoom) 

To change the scale of the data in a Plot Details window, select one of the 
following plot zoom tools: 

  zooms in to expand the scale 

  zooms out to contract the scale 

  zooms in to expand the horizontal axis only 

  zooms in to restore all the data  

When you select the  tool, you can use a select-drag-release action to expand 
part of the waveform (zoom in) by an arbitrary amount on both axes. After you 
select (touch with a finger or click with the mouse) and begin dragging, a 
bounding box shows what part of the waveform will be expanded upon release.  

Select any part of the plot to expand the data by a factor of two (2X) equally on 
both axes. Double selecting expands the data to the maximum factor.  

To contract an expanded part of the data (zoom out), select anywhere on the data. 
The view contracts to the values that existed before the most recent expansion of 
the data. Selecting multiple times will restore successively earlier views. 

To expand the scale of the horizontal axis only by a factor of two (2X), click a 
part of the waveform. The plot retains the scale of the vertical axis. 

 You can quickly restore the view to the entire waveform. To do so, select 
the  tool.  
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Using Cursors in a Plot 

About Using Cursors in a Plot 

Cursors allow you to view numerical values associated with a plot based on 
cursor locations. There are two cursor modes: Horizontal-paired and Vertical-
paired. Each mode displays two cursors. View the Plot Cursor tools.  

Plot Cursors Definitions 

Table 41. Plot cursors definitions 
Cursors type Description 

 Horizontal Displays the vertical coordinate where each cursor touches 
the plot and the difference (delta) between the cursors. 

 Vertical Displays the horizontal coordinate where each cursor 
touches the plot and the difference (delta) between the 
cursors. 

 Reset Brings the cursors into the visible part of the plot. 
  

Using Cursors in a Plot 

You can use cursors to read the coordinate where each cursor (line) touches the 
plot and also view the difference (delta) between the two cursors. 

To use cursors in the Plot Details window, follow these steps: 

1. Select one of the following cursor tools:  

a.  to use Horizontal cursors 

b.  to use Vertical cursors 

c.  to bring the cursors into the visible plot 

2. Select and drag either cursor to move the cursor to the desired part of the 
plot. 

The cursor readout changes value to reflect the cursor position.  

Note: You can drag cursors only when the Zoom functions are disabled. 
 

 If you prefer to move the cursors in the plot window with your finger, you 
can activate the Touch Screen on the oscilloscope. 
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Using Grid Points in a Plot 

To display or remove cursor points in a Plot Details window, 

 select the  tool. Grids are not available in eye diagrams. 

Horizontal and Vertical Cursors in a Plot Example 

 

Figure 84: Horizontal and vertical cursors in a plot example  
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Saving Plots to Files 

About Saving Plot Files 

Both plot windows include the save plot file tools. However, the contents of 
saved plot files are dependent on the type of plot window: Summary or Detail. 
View the Save Plot to a file command buttons.  

Save Plot Files Definitions 

Table 42. Save plot files definitions  
File type Description 

 Graphic Saves the contents of the plot window in the format you select 
from the list.  

 Data Saves the contents of the plot window as a binary .fig file.  

  

Saving Plot Files 

To save a plot file, follow these steps: 

1. Set up the plot window. 

2. Select one of the following save plot file tools: 

  to save the plot as graphic file 

  to save a data file 

3. Select the  button to select a directory and then enter a file name. 

4. Select the  button to save the plot file. The application saves the 
file. 
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Printing Plots 

About Printing Plots 

To send a plot to a printer, follow these steps: 

1. Verify that a printer is configured. 

2. Set up the plot window (with the zoom, cursor, or grid points functions). 

3. Select the  tool. 

4. The Plot Print dialog appears. View the Plot Print Preview window.  

5. Select the  button and set up the options.  

6. To customize the print of the plot, select the  tool.  

7. The Page Setup menu that is a part of the MATLAB software appears. View 
the Page Setup window  

Note: The online help topics for the RT-Eye application do NOT describe how to 
use the MATLAB Page Setup menu. Refer to the MATLAB documentation for 
more information. 
 

Select the Print button to print the plot file. If you selected Print  

to File, use the  button to select a directory and then enter a file name. 
The application saves the file. 
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Plot Print Preview Window 

  

Figure 85: Plot print preview window 
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Plot Page Setup Window 

  

Figure 86: Plot page setup window 

Logging Worst Case Waveforms  

Saving Worst Case Waveforms from a Live Source 

You can use the Log Worst Case menus to save the acquired waveforms 
whenever a selected measurement exceeds the highest or lowest prior value. 
When enabled, the waveforms are saved to a set of .wfm files.  

The application also exports the contents of the files to a worstcasetable.csv file 
located in the Log directory. 

To log worst case waveforms, follow these steps: 

1. Select Log> Worst Case> Configure. 

2. Select the  button to enable logging.  

3. Select the  button to select a directory. 
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4. Select the  command button in the Control Panel. 

5. The application saves the waveforms with the worst case maximum and 
minimum values for all selected measurements in the 
tdsrteye\modules\SerialAnalysis\waveforms directory. 

6. To disable logging, select the  button. 

Note: Use the  button to delete all the .wfm files in the selected 
directory. 
 

Log Worst Case Configure Options 

Table 43. Log worst case configure options 
Option Description 
Log Enables or disables saving the maximum and minimum 

values of the worst case waveforms to files for each 
source. 

Choose Directory Browse to select the directory in which to save the 
waveforms when the log worst case waveforms function is 
enabled. 

Purge Deletes all waveform files from the selected directory. 
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Log: Worst Case Configure Menu 

 

Figure 87: Log worst case waveform menu 

File Names of Worst Case Waveforms  

The application automatically names the files for you. The file names include the 
following information: 

 Type of measurement 

 Whether the file is a maximum or minimum value waveform  

 Date and time that the file was saved 

File names appear after sequencing is complete and measurement results display. 

Log: Worst Case File Names Menu 

 

Figure 88: Log worst case file name menu 
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Generating a Report 

About Generating a Report 

You can use the Report Generator utility to customize and generate a compliance 
report to view later or to share with others. The utility is independent from the 
RT-Eye application, yet is accessible from the application.  

Note: The utility yields a .rpt file that can be viewed only from the Report 
Generator. You can select to export to an .rtf format file. 
 

Report Generator File Directories 

Table 44. Report generator file directories 
Directory Description 
Reports Default location where the utility stores reports. 
Templates Each .rgt template file defines the contents and layout of one 

page in the report; you can use existing page templates, edit 
templates or create new templates. 

Layouts Each .rpl layout file defines all the pages (template files) to 
include in a report; you can use an existing report layout, edit 
layouts or create new layouts. 
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Directory Structure for the Report Generator Utility 

  

Figure 89: Directory structure for the report generator utility 
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Starting the Report Generator and Accessing the Online Help 

The online help for the Report Generator utility contains all the information you 
need to design and produce compliance report files. To start the report generator 
utility from the RT-Eye application and access the online help, follow these 
steps: 

1. Select Utilities> Reports. 

2. Select the Define Test Template or the Define Report Layout tab. 

3. Select the  command button.  

4. From the menu bar in the Report Generator window, select Help> Help 
Topics. The Help system for the utility appears. 

You can refer to the online help topics for the Report Generator utility for 
information on how to do the following tasks: 

 Use an existing test template or report layout 

 Edit an existing test template or report layout 

 Create a new test template or report layout 

 Add Fields: Native, Oscilloscope, Serial Analysis 
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Setting Up a Test Template and Layout for a Report 

The Report Generator utility allows you to design the contents and layout of a 
report that reflects your unique needs. In addition to a predefined template for 
each page, there is also a predefined report that includes all the predefined pages.  

Generating and Printing a Report 

To generate and print a report, follow these steps: 

1. Select Utility> Reports. 

2. Select the  tab. 

Do not touch the screen. Wait while the Report Generator creates the report. The 
oscilloscope fills the display while the application takes a screen print. When 
complete, the oscilloscope display shrinks to half size and automatically the RT-
Eye application reappears. 

 The report displays when it is complete. You may need to use the Alt+Tab key 
combination to bring the Report Generator window to the front. 

3. You need to save the report to retain the file. To save the report, select File> 
Save from the menu bar of the Report Viewer. The report file is in a .rpt 
format and can only be viewed with the Report Viewer. 

Later, you can use the Browse and View buttons in the Generate Report menu to 
open your saved report file. 

4. To use a different file, edit a file, or create a new report layout (or test 
template) file, refer to the Report Generator online help.  

5. To print the report, first verify that a printer is configured from the 
oscilloscope task bar. 

6. From the Report Generator menu in the RT-Eye application,  

select the  button.  

You can also navigate to the saved file in the Report Generator window and send 
the file to a printer without having to open the file in the Report Viewer. To share 
a report with others, you may want to generate a smaller file. To do so, refer to 
the Creating a PDF File of the Compliance Report topic. 

7. To export the report as an .rtf file, select File> Export to RTF from the menu 
bar of the Report Generator window. You can transfer the .rtf file to a 
personal computer, and view or print the file from a word processing 
program. 
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Creating a PDF File of the Compliance Report 

You can send a report file to a "virtual" printer to create a smaller and more 
portable PDF file of your compliance report. To create a PDF file, follow these 
steps: 

1. Verify that a distiller program (for example, Adobe Acrobat Distiller 6.0) is 
configured from the oscilloscope task bar.  

2. From the Report Generator menu in the RT-Eye application,  

select the  button.  

3. Select the Distiller from the Printer Name selection menu. 

  

Figure 90: PDF creation of Compliance report 

 
4. Send the report to the distiller (select OK). 

  

Figure 91: Print report status 
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5. When the PDF file is complete, you can use other features of the distiller to 

further enhance the report, such as add watermarks if available. 

Test Template Menu 

Note: Refer to the online help topics for the Report Generator utility for 
information on how to create a new test template or on how to edit an existing 
test template. 
 

 

Figure 92: Test template menu 
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Report Layout Menu 

Note: Refer to the online help topics for the Report Generator utility for 
information on how to create a new report layout or how to edit an existing 
report layout. 
 

 

Figure 93: Report layout menu  

Report Generate Menu Options 

Table 45. Report Generator menu options 
Option Description 
Browse Select a directory in which to save the report file and enter a 

file name; select a file for the template or layout and edit as 
needed. 

Generate Create a report. 
View View a report. 
Print Print a report. 
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Report Generate Menu 

 

Figure 94: Report generator menu   

Report Generator Fields 

You can use the fields in the report generator utility to customize the contents 
and layout of a report. The utility has the following groups of fields: 

 Oscilloscope 

 Application 

 Native 
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Application Fields General Information List 

This is an example of the fields available for the general oscilloscope information 
in the report. 

 

Figure 95: Application fields-general information  
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Application Fields Configuration List and Ref Levels Example 

This is an example of the fields available for the configuration information. This 
example also shows the expanded list of fields available for the Ref Levels in the 
report. 

  

Figure 96: Application Fields Configuration List and Ref Levels Example 
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Application Fields Results List and Specific Measurements Example 

This is an example of the fields available for the measurement results 
information. This example also shows the expanded list of fields available for an 
EyeWidth/Eye Height measurement and for a Rise Time measurement in the 
report. 

   

Figure 97: Application Fields Results List and Specific Measurements Example 
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Oscilloscope Fields and Native Fields Lists 

This is an example of the fields available for the oscilloscope controls and other 
miscellaneous features in the report, such as lines. 

  

Figure 98: Oscilloscope Fields and Native Fields Lists 



Operating Basics 

148                RT-Eye ®Serial Compliance and Analysis Application 



                                              

RT-Eye ® Serial Compliance and Analysis Application 
      

149

Tutorial 

Introduction to the Tutorial 
This tutorial teaches you how to set up the application, take measurements, and 
view the results.  

Before you begin the tutorial, you must do the following tasks: 

 Set up the oscilloscope 

 Start the Application 

 Recall the tutorial waveform  

Note: The screen captures shown are from a TDS7000 oscilloscope; there may 
be minor differences in the screens from other types of oscilloscopes. 
 

Setting Up the Oscilloscope 
To set up the oscilloscope, follow these steps: 

1. In the oscilloscope menu bar, select File> Recall Default Setup to set the 
oscilloscope to the default factory settings. 

2. Press the individual CH1, CH2, CH3, and CH4 buttons as needed to remove 
active waveforms from the display. 

Starting the Application 
In the oscilloscope menu bar, select File> Run Application> RT-Eye Serial 
Compliance and Analysis.  

The application starts up and displays the Measurements Select menu.  

Waveform Files 
The application includes a waveform file to use with this tutorial. The file is from 
a PCE Express signal and is named RT-EyeTutorial.wfm. 
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Recalling a Waveform File 
To recall a waveform file, follow these steps: 

1. In the oscilloscope menu bar, select File> Reference Waveforms> Reference 
Setup. Ref1 is the default memory location to recall a waveform file.  

2. Select the  button for Recall Ref1 from File. 

3. Navigate to the C:\TekApplications\ tds-rteye\examples\WFMs directory. 

4. Select the RT-EyeTutorial.wfm file and then .  

5. The oscilloscope recalls the waveform file to reference memory and 
displays the waveform when the recall is complete. 

6. To return to the application, select the  button in the oscilloscope 
menu bar.  
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Oscilloscope Reference Memory Setup Menu 

 

Figure 99: Oscilloscope Reference memory set up menu  
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Taking an Eye Width Measurement 
In this lesson, you will learn how to use the application to take an Eye Width/Eye 
Height measurement and view the results. This lesson teaches you how to do the 
following tasks: 

 Select a measurement 

 Configure a measurement 

 Take measurements 

 View the measurement results 

 View a Real-Time Eye diagram 

 Stop the application 

 Return to the application  

To perform these lessons, the application must be installed and enabled on the 
oscilloscope. See Installation.  

Setting Up an Eye Width Measurement 

To set up the application to take an Eye Width/Eye Height measurement, follow 
these steps: 

1. To set the application to default values, select File> Recall Default. The 
tutorial uses the default measurement and probe type. The measurement 
selections vary depending on the Probe Type option: Differential or Single 
Ended. 

2. Select the  button.  

3. The Configure Source menu appears with tabs for other Configure menus. 

 
4. Select Ref1 as the source. View the waveform recalled to Ref1 and selected 

as the source.  

5. Select the  tab. The Configure Ref Levels Menu appears. 

6. Select the  command button. The application automatically 
calculates the appropriate reference voltage level values. View the reference 
voltage level values as calculated by the application.  
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 Ref1 Selected as the Source 

 

Figure 100: Ref1 as source  

Using Autoset for Reference Voltage Levels 

 

Figure 101: Using autoset for reference voltage levels  
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Taking a Measurement and Viewing as an Eye Diagram 
The default setup for the application includes an Eye Diagram plot. To take 
measurements and view the results as statistics and as a plot, follow these steps:  

1. Select the  command button in the Control Panel. The application 
displays a real-time eye diagram that shows the characteristics of the 
waveform in a Plot Summary window.  

2. You can view details of the results and details of the plot.  

        To do so, select the  command button in the  

        Results Summary menu and the  in the Plot Summary window. View 
the details of the results and of the Eye diagram plot.  

3. You can use the Results Details: Select Measurement option to view details 
of other measurements. 
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Results Summary and Plots Summary Window Example 

 

Figure 102: Results summary and plots summary window example 
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Results Details and Plot Details Window Example 

 

Figure 103: Results Details and Plot Details Window Example 

Ending a Tutorial Lesson 
If you need more than one session to complete the tutorial lessons, you can stop 
the tutorial and return to it later. Refer to Stopping the Tutorial and Returning to 
the Tutorial.  

Note: The purpose of this tutorial is to familiarize you with the basic functions of 
the application, menus, and steps you may need to take if the quick method does 
not yield expected results. 
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Stopping the Tutorial 

If you need more than one session to complete the tutorial lessons, you can stop 
the tutorial and return to it later.  

To save the application setup and stop your session, refer to Saving a Setup File 
and to Exiting the Application. 

Returning to the Tutorial 

To return to the tutorial setup, you can start the application and then recall the 
saved setup. To recall the application setup, refer to Recalling a Saved Setup File. 

Quick Method Concept 
There is a quick method you can use to take measurements that may yield 
reasonable results for your situation. The results from the quick method should 
indicate whether or not the setup is adequate. If it is not, then you can set up the 
application manually as shown in the first lesson. 
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Quick Method to Take Measurements 

You can use the quick method to take measurements from channel (live) 
waveforms. To quickly take measurements, follow these steps: 

1. Start the application (also clears previous results), and make your Probe 
Type and measurement selections in the Measurements> Select menu. 

2. Select . The Autoset Summary menu appears 

3. In the Autoset Summary menu, select . The application calculates 
and applies appropriate settings for the vertical scale and horizontal 
resolution of the source and values for the reference voltage levels. 

4. If the values are acceptable, select .  

5. If need be, select  to adjust the reference voltage levels in the 
Configure Ref Levels menu. 

6. Select the  command button to take measurements.  

When sequencing is complete, the application displays statistical results and a 
real-time eye diagram that shows the characteristics of the waveform. View the 
results of the Eye Width measurement as an Eye Diagram.  
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Taking a TIE Jitter Measurement 
In this lesson, you will learn how to use the application to take a TIE Jitter 
measurement on the waveform already recalled to the Ref1 location. This lesson 
teaches you how to do the following tasks:  

 View the results as a Histogram, and a Spectrum plot 

 Save statistical results to a .csv file 

 View a .csv file with Wordpad or in a spreadsheet 

 Generate a simple report 

Clearing Results 

Before taking more measurements, be sure to clear the results.  

To do so, select the  command button in the Control Panel. 
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Setting Up a TIE Jitter Measurement and Plots 

To set up, take, and plot a TIE Jitter measurement, follow these steps: 

1. Clear any previous results. 

2. Select Measurements> Select and deselect the Eye Width/Eye Height 
measurement (from the previous lesson). When you deselect a measurement, 
the application discards the corresponding options in the Plots menus. 

3. Select the  measurement. The vertical scale, horizontal resolution 
and reference voltage levels were set for the source (Ref1) in the previous 
lesson. 

4. Select the  button. 

5. In the Select Subplot table, select TIE Jitter in the Measurement column and 
Histogram in the Plot Type  

 column. Select the  command button. The   application displays the 
Results Summary menu and the Histogram plot. View the results of the TIE 
Jitter measurement. 

6. Select Plots> Select.  

7. In the second row of the Select Subplot table, select TIE Jitter in the 
Measurement column and Spectrum in the Plot Type column. 

8. Select  to update the plot window.  
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TIE Jitter Results with Histogram Example 

 

Figure 104: TIE jitter results with Histogram example 
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TIE Jitter Histogram and Spectrum Plot Example 

 
Figure 105: TIE Jitter Histogram and spectrum plot example 
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Examples of Plot Details 

Here are details from the plots in this lesson. 

 

 
Figure 106: Example of plot details
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Saving Statistical Results to a .CSV File 

To save the statistical results to a .csv (comma separated variable) file, follow 
these steps: 

1. Select the  command button. The Save dialog appears. 

2. Use the  command button to select a directory in which to save the 
.csv file in. 

3. Enter a file name and select . 

4. Start the Wordpad program on the oscilloscope and select File> Open.  

5. Navigate and select the file you just created. View the .csv file with 
Wordpad.  

6. Close the Wordpad program. 

7. Copy the file to your PC, start a spreadsheet or other analysis program, and 
open the .csv file. You can customize the results to suit your analysis needs. 
View the .csv file as a spreadsheet.   
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 .CSV File Viewed with Wordpad Example 

  

Figure 107:.CSV file viewed in wordpad 

.CSV File Viewed in a Spreadsheet Example 

  

Figure 108:.CSV file viewed in spreadsheet 

Generating a Simple Report 
To generate a simple report, follow these steps: 

1. Select Utilities> Report. The Report Generator menu appears and is set to 
use the default Define Test Template and Define Report Layout definitions. 

2. Select the  command button. 

3. The application generates and displays the report. View the simple report.  

4. To print the report, select the  command button.  

Note: Before the application can send the file to a printer, you need to check if 
the printer is set up from the Start menu (in the oscilloscope task bar). 
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Simple Report Example Page 1 

 

Figure 109: Simple report example Page 1 
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Simple Report Example Page 2 

  

Figure 110: Simple report example Page 2 
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Serial Analysis Laboratory 

About the Serial Analysis Laboratory (Lab) 
The Serial Analysis Laboratory presents a typical application example that 
highlights the compliance and analysis capabilities of the RT-Eye application, 
and will give you ideas on how to use the application to solve your own test 
problems. This lab covers and explores the following areas: 

 Using the Serial Data Wizard to perform serial analysis on a 2.5 Gb/s serial 
bit stream 

 Performing jitter measurements that are compliant to the T11.2 MJSQ using 
the spectrum approach to jitter analysis  

 Saving and using MyTest  

 Creating Limits Module File for custom Compliance Test 

 Creating a Compliance Report 

 Performing a PCI Express Compliance test (PCI Express Compliance 
Module required) 

Note: To use this lab, you must have the RT-Eye application installed, enabled 
and running on the oscilloscope. For information, see Installation and Starting 
the application. 
 

Requirements:  

 TDS/CSA7000 series oscilloscope (1.5  GHz and above) or TDS6000 series 
oscilloscope if you use a reference waveform.  

Optionally, the Training Board 2 (P/N 020-2460-00) or Training Board 3 by 
Tektronix. A minimum bandwidth of 4 GHz is required for a live signal. 

 RT-Eye Serial Data Compliance and Analysis software (Opt. RTE)  

Note: If your oscilloscope setup includes a second monitor, you can select and 
drag the title bar of the online help window to position it in the second monitor. 
This allows you to simultaneously display these lab exercises in the second 
monitor, the waveform (or a plot) on the oscilloscope, and the RT-Eye 
measurement results for easy viewing. 
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Recall Default Settings and Run RT-Eye SW 
To ensure that your lab results match the results shown in these lab exercises, 
you will recall the default settings to the oscilloscope and to the RT-Eye 
application. To do so, follow these steps: 

 Push the DEFAULT SETUP front-panel button to start from a known setup. 

 From the oscilloscope application menu, select File> Run Application> RT-
Eye Serial Compliance and Analysis on non-B models, or Applications > 
RT-Eye Serial Compliance and Analysis on B/C models 

Will you be using a Reference Waveform File or a live signal from the Training 
Board? 

Reference Waveform File Setup 
This lab uses a 2.5 Gb/s differential signal saved to  

C:\TekApplications\tds- 
rteye\modules\SerialAnalysis\waveforms\examples\2_5Gbps_PRBS.wfm. 

You can recall the waveform to reference memory, view the waveform, and 
analyze it with any RT-Eye compliance and analysis application. To recall the 
waveform file to reference memory, follow these steps: 

 

1. Click the DEFAULT SETUP button on the front panel. 

2. Push the CH1 front-panel button to turn off the Channel 1 waveform Push 
the CH1 front-panel button to turn off the Channel 1 waveform. 

3. From the Oscilloscope application menu, select Reference Waveforms> 
Recall Wfm  

4. Select Recall Ref1 from Wfm File 

5. Browse to and select: 
C:\TekApplications\tdsrteye\modules\SerialAnalysis\waveforms\examples\2
_5Gbps_PRBS.wfm as the waveform file. 

6. Use the Zoom control to zoom in and view individual bits.   

7. Select Measurement> Wizard, to run the Serial Data Wizard. 
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Figure 111: Select measurement wizard 

8. Make Wizard Selections as shown in the yellow text in the following figure.  
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Figure 112: Plots selection  

 

9. Proceed to Run the Analysis and View the Results. 

Training Board 2 - Live Signal Source 
You can use the Training Board 2 or Training Board 3 to work through these 
exercises. To do so, use the 2.5 Gb/s PRBS signal. This signal has rise times of 
<100 ps, and thus needs full sample rate (20 GS/s) to perform measurements 
accurately. You can use the following configurations: 

 TDS7000 Series (TDS7404): Use P7380SMA with CH1 as the Differential 
Source for Analysis.  

 TDS6000 Series: Use P7380SMA with CH1 as the Differential Source for 
Analysis or Use TCA-SMA Adapters on CH1 and CH3 as Single-Ended 
Sources for Analysis.  
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Use P7380SMA with CH1 as the Differential Source for Analysis 
1. Use the phase-matched SMA cables (provided with the P7380SMA probe) 

to connect the positive and negative leg of the 2.5Gb/s signal on the training 
board and CH 1 on the oscilloscope. 

2. Connect the other end of the phase-matched cables to the "D+" and "D-" 
connections of the P7380SMA probe input. 

3. Connect the TekConnect end of the P7380SMA probe to CH1 of the 
oscilloscope. 

4. Push the AUTOSET front-panel button to view the differential signal. 

5. Select Measurement> Wizard, to run the Serial Data Wizard.  

 

Figure 113: Select Wizard  

6. Make Wizard Selections as shown in the yellow text in the following figure.  
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Figure 114: Plots  

 

7. Proceed to Run the Analysis and View the Results. 
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Use TCA-SMA Adapters on CH1 and CH3 as Single-Ended Sources for Analysis 
 

1. Use a 1 Meter SMA cable and TCA-SMA adapter to connect between "D+" 
on the training board and CH1 on the oscilloscope. 

2. Use another 1 Meter SMA cable and TCA-SMA adapter to connect between 
"D-" on the training board and CH3 on the oscilloscope. 

3. Push the CH3 vertical channel button to display Ch3. 

4. Push the AUTOSET front-panel button to view both signals.  

5. Adjust both Ch1 and Ch3 to 200 mV/div to get a better view of the 
waveforms.  

6. Select Measurement> Wizard to run the Serial Data Wizard.  

 

Figure 115: Measurement wizard screen  

7. Make Wizard Selections as shown in the yellow text in the following figure.  
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Figure 116: Types of plots selected   

 

8. Proceed to Run the Analysis and View the Results. 
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Run the Analysis and View the Results 

1. Run the Analysis by clicking  in the Wizard. 

2. The result of the analysis is displayed as shown in the following figure. 

 

Figure 117: Analysis results 

Statistics of measurement results are shown in the lower half of the oscilloscope 
display. The RT-Eye diagram and Mask are shown in the upper half of the 
oscilloscope display. You can change the Time units from UIs to seconds 
depending on what the standard calls for. The magenta dots in the Eye diagram 
represent the recovered clock. The Eye diagram shows statistical representation 
of the Eye diagram in an accumulated waveform database display. Multiple jitter 
plots (the TIE Jitter Histogram, Spectrum, and Bathtub curve) are also displayed. 
Click the Details button to view the details of each measurement. 

3. Proceed to MJSQ Jitter Analysis.  



Serial Analysis Laboratory 

178                RT-Eye ®Serial Compliance and Analysis Application 

MJSQ Jitter Analysis  
This section describes how to perform jitter analysis compliant with the T11.2 
MJSQ methodology using the Spectrum Approach to Jitter Analysis. In the 
previous section, the default method (Arbitrary Pattern) was used as the Jitter 
method. To perform analysis consistent with T11.2 MJSQ "spectrum approach", 
a repeating pattern is used. The signal being used in this lab is a 127 bit PRBS 
repeating pattern. To change to the repeating pattern method, follow these steps:  

1. Select Measurements> Configure> Jitter  

2. Select Type> Repeating 

3. Select Pattern> Custom 

4. Input 127 UI into the Pattern Length Control.  

 

Figure 118: Jitter   

5. Click Clear Results.  

6. Click Start to perform the Analysis.  

7. Select Jitter @ BER from the Results Details: Select Measurement pull-
down.  
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Figure 119: Results Summary 
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Figure 120: Results details 

The three views of Jitter and the measurements provide a good way to see how 
Jitter measurements are made with the Spectrum Method of Rj/Dj separation. 
The TIE Histogram (lower left plot) is the traditional way of measuring jitter on 
an oscilloscope. This method is limited by the amount of statistical certainty that 
can be achieved in a reasonable amount of time. Thus, more advanced DSP 
methods are used to determine the Jitter Eye Opening, Total Jitter, Random Jitter, 
and Deterministic Jitter. 

The TIE measurements are transformed into the frequency domain by performing 
an FFT on the raw TIE data, thus creating the jitter spectrum shown in the upper 
right plot. The spikes in the frequency domain represent Deterministic jitter. 
Further analysis can be done to determine which spikes are Duty Cycle 
Distortion (DCD) or Data Dependent (DDJ-also known as ISI), and which are 
Periodic (PJ). Once these values are removed (DJ), then what is left is a noise 
floor which represents the Random Jitter (RJ). These values are used to create the 
Cumulative Distribution Function (CDF), commonly known as the Bathtub 
Curve, shown in the lower right hand plot. The magenta line at 10-12 BER 
represents the Jitter Eye Opening measurement.  

The following equation can be solved using the measurement results: 

    Jitter Eye Opening + Total Jitter = 1UI 

8. Proceed to Using MyTest.  
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Using MyTest 
MyTest allows you to save your favorite test and run it automatically when you 
start the application. For example, now that you have performed the MJSQ jitter 
test, you can use the following procedure to save and run the MJSQ jitter test as 
MyTest.  

1. Select Measurements> Save MyTest 

2. Select File> Exit  

3. Select No when the dialog asks if you want to save oscilloscope settings.  

4. Push the DEFAULT SETUP front-panel button to start from a known setup. 

5. From the Oscilloscope application menu, select File> Run Application> RT-
Eye Serial Compliance and Analysis on non-B models, or Applications> 
RT-Eye Serial Compliance and Analysis on B or C models. 

6. After you launch the RT-Eye application, select Run Mytest from the 
welcome dialog box. In this example, the MJSQ test is run automatically. 

  

Figure 121: RT-Eye Welcome  

The RT-Eye MyTest feature allows you to run your favorite test with a single 
click.  

Defining a Limits Module 
This section demonstrates how to apply a limit to a measurement and create a 
custom Pass/Fail condition on the TIE jitter measurement described in the 
previous section. 

1. Select the Measurement> Limits menu. 

2. Select New under Measurement Limits Editor. 

3. Select TIE Jitter as the Measurement. 
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4. Select Min as Statistic and Enter –60ps for limit. 

5. Select the + button to add a measurement limit. 

6. Select TIE Jitter as the Measurement. 

7. Select Max as Statistic and Enter +60ps for limit. 

  

Figure 122: Measurement limits 

8. Click the Save As button. 

9. Save file as Jitter.lim. 

10. Close Limits Editor. 

11. Select Limits> Browse.  

12. Select Jitter as the Limits File.  

13. Click Open. 

14. Select Limits> On. 

15. Return to Results> Details menu. 

16. Click the Clear Results button.  

17. Click the Start button.  

  

Figure 123: Results details 

 

18. The defined Pass/Fail status appears in the Status column of the Results 
panel. Proceed to Creating a Compliance Report.  
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Creating a Compliance Report 
This section demonstrates how to create a compliance report based on the 
previous analysis. 

1. Select Utilities> Reports. 

2. Click Generate. The resulting report can be exported to an RTF file format 
and read by other applications such as Microsoft Word. The report can also 
be printed to a PDF file if a PDF distiller is installed on the instrument. 

  

Figure 124: Report in PDF format 

3. Proceed to PCI Express Compliance Test. 
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PCI Express Compliance Tests 
This section demonstrates how to perform a PCI Express Compliance Test. The 
PCI Express module must be present to complete this part of the lab. If your 
instrument does not have a PCI Express Compliance Module installed, proceed to 
Serial Analysis Lab Conclusion. 

1. Select Modules> PCI Express from the RT-Eye menu. 

2. Click the Select Required button. 

3. Select Test Point> Driver. 

4. Select the correct Probe Type (Single Ended or Differential) depending on 
your probe configuration. 

5. Click the Autoset button.  

 

Figure 125: PCI express compliance test 

6. Click the Start Button. 
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Results of PCI Express Add in Card Compliance Test 

 

Figure 126: Results of PCI express Add in card compliance test  

In this example, the signal under test fails the PCI Express compliance test. This 
is because the PCI Express specification calls for 3-4dB of De-emphasis on the 
nontransition bits (or pre-emphasis on transition bits). Since the signal does not 
have the proper level of de-emphasis, it fails the transition bit mask. The number 
of mask hits shows up in the compliance results as a mask failure. 

7. Click the Clear Results button. 

8. Return to the Measurement> Select menu. 

9. Select Receiver as the Test Point. 

10. Click the Select Required button. 
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Figure 127: PCI express compliance test  

11. Click the Start button. 

 

Figure 128: Results of PCI express compliance test  

 



                                                         Serial Analysis Laboratory                      

RT-Eye ® Serial Compliance and Analysis Application  187

In the PCI Express Receiver test, there is a single Receiver Mask. This test is 
performed by probing a device close to the receiver pins of a SerDes. This signal 
passes the receiver compliance test. 

12. Proceed to Serial Analysis Lab Conclusion.  
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Serial Analysis Lab Conclusion 
Congratulations! You have completed the RT-Eye Serial Analysis Lab. We hope 
that this has been helpful in understanding the capabilities of the RT-Eye 
software solution and will help you in the validation and compliance testing of 
your devices.    
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Parameters 

About Application Parameters 
This section describes the RT-Eye application parameters and includes the menu 
default settings. Refer to the user manual for your oscilloscope for operating 
details of other controls, such as front-panel buttons.  

The parameter tables list the selections or range of values available for each 
option, the incremental unit of numeric values, and the default selection or value. 

Refer to the GPIB topics for a complete list of the GPIB Command Syntax. The 
topics include a complete list of the GPIB commands along with the arguments, 
variables, and variable values that correspond to the RT-Eye parameters. 

Note: Unit values shown are valid when the FINE button is enabled on the 
oscilloscope.  
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File Menu Parameters 
The File drop-down list includes the following command buttons: 

 Recall Default 

 Minimize  

 Exit 

Table 46. File menu parameters 
Option Parameters Default setting 
Recall <Browser> Default directory* 
Save <Browser> Default directory* 
Recall Recent Lists up to five most recently saved or 

accessed setup files:  
1. <setup file name>  
2. <setup file name>  
3. <setup file name>  
4. <setup file name>  
5. <setup file name> 

Default directory* 

Preferences See File Preferences Menu Parameters topic, next 
* Refer to the Application Directories and Usage topic for default path names.  
  

File Preferences Menu Parameters 
The File Preferences menu includes the following command buttons: 

 Cancel 

 OK 

Table 47. File preferences menu parameters 
Option Parameters Default setting
Show Welcome Dialog at Startup Set, Clear Set 
Show Autoset Summary when Autoset is 
selected 

Set, Clear Set 

Enable high-performance eye rendering Set, Clear Set 
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Control Panel Parameters 
The Control Panel menu includes the following command buttons: 

 Start 

 Stop 

 Clear Results 

Table 48. Control panel parameters 
Option Parameters Default setting
Mode Single Run, Single No Acq, Free Run Single Run 
  

Measurements Select Menu Parameters 
Available measurements in the Measurements Select menu are dependant on the 
selection for the Probe Type option. Measurements available by area are as 
follows: 

 Timing area: Rise Time, Fall Time, Unit Interval, Bit Rate, Eye Height, Eye 
Width, and Differential Skew 

 Amplitude area: Differential Voltage, High Amplitude, Low Amplitude, CM 
Voltage, AC CM Voltage, and De-Emphasis 

 Jitter area: Jitter@BER and TIE Jitter 

Note: The Differential Skew, CM Voltage, and AC CM Voltage measurements 
are added when you select Single Ended as the Probe Type option. 
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Autoset Summary Menu Parameters 
The Autoset Summary menu includes the following command buttons: 

 Autoset 

 Configure 

 Close 

Table 49. Autoset summary menu parameters 
Option Parameters Default setting
Do not show this menu again Set, Clear Clear 
  

Measurements Configure Menus 
The application includes the following Measurements Configure menus: 

 Source for Single Ended Probes or Source for Differential Probes 

 Ref Levels  

 Smart Gating  

 Clock Recovery  

 Jitter Method  

 Population  

 General Config  

Note: These menus are generally referred to as the Configure menus.  
 

The application automatically calculates parameters for reference voltage levels 
in the Ref Level Autoset Setup menu. Display the Ref Level Autoset Setup menu 
parameters.  
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Configure Source Menu Parameters for Differential Probes 
The Configure Source menu includes the following command buttons in the 
Autoset area: 

 Vertical Scale  

 Horizontal Resolution  

 Vertical & Horizontal  

Table 50. Source menu parameters for differential probes 
Option Parameters Default setting 
Live/Ref 
   Select Differential 

 
Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, 
Ref3, Ref4 

 
Ch1 

File 
   Differential File 

 
<Browser> 

 
Default directory* 

* Refer to the Application Directories and Usage topic for default path names.  
  

Configure Source Menu Parameters for Single-Ended Probes 
The Configure Source menu includes the following command buttons in the 
Autoset area: 

 Vertical Scale  

 Horizontal Resolution  

 Vertical & Horizontal  

Table 51. Source menu parameters for single-ended probes 
Option Parameters Default setting 
Live 
   Select D+, D- 

 
Ch1, Ch3 
Ch1, Ch4 
Ch2, Ch3 
Ch2, Ch4 

 
Ch1, Ch3 

Ref All combinations of two Ref waveforms Ref1, Ref2 
 
<Browser> 

 
Default directory* 

File 
   Select File D+ 
   Select File D- <Browser> Default directory* 
* Refer to the Application Directories and Usage topic for default path names.  
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Configure Ref Levels Menu Parameters 
The Configure Ref Levels menu includes the following command buttons in the 
Autoset area: 

 Setup  

 Run  

Table 52. Reference level parameters 
Option Parameters Default setting 
Source Differential, DPlus*,DMinus* Differential 
Rise, High 10.00 V to -10.00 V in units of 1 mV 400 mV 
Rise, Mid 10.00 V to -10.00 V in units of 1 mV 0 V 
Rise, Low 10.00 V to -10.00 V in units of 1 mV -400 mV 
Fall, High 10.00 V to -10.00 V in units of 1 mV 400 mV 
Fall, Mid 10.00 V to -10.00 V in units of 1 mV 0 V 
Fall, Low 10.00 V to -10.00 V in units of 1 mV -400 mV 
Hysteresis 0 V to 10.00 V in units of 10 mV 30 mV 
Mid = 0V** Set, Clear 0 V (set) 
* Only available when Single Ended is the Probe Type option. 
** 50% (VRefMID) of signal swing if the option is clear. 
  

Configure Ref Level Autoset Setup Menu Parameters 
The Configure Ref Level Autoset Setup menu includes the following command 
buttons: 

 OK 

 Cancel 

Table 53. Reference level autoset set up menu parameters 
Option Parameters* Default setting 
Rise, High 0 to 100% in units of 1% 80% 
Rise, Mid 0 to 100% in units of 1% 50% 
Rise, Low 0 to 100% in units of 1% 20% 
Fall, High 0 to 100% in units of 1% 80% 
Fall, Mid 0 to 100% in units of 1% 50% 
Fall, Low 0 to 100% in units of 1% 20% 
Hysteresis 0 to 50% in units of 1% 3% 
* Where 0% = mean(vEYE-HI-TRAN(n)) and 100% = mean(vEYE-LO-TRAN(n)). 
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Configure Smart Gating Menu Parameters 

Table 54. Smart gating menu parameters 
Option Parameters Default setting 
Gating Off, Cursors, Smart Gating Off 
  

Configure Smart Gating Menu with Smart Gating Parameters 
The value that displays under Stop shows the sum of the Length and Start options. 

Table 55. Smart gating menu with smart gating parameters 
Area Option Parameters Default setting

Off 
Cursors 

Gating 

Smart Gating 

- Off 

Length 1 to 50 M 3.5k 
Start 1 to 50 M 1 
Stop - - 
Scan Incr 1 to 50 M 1 
#Scans 1 to 50 M 1 
Scan to End of 
Record 

- Selected 

Clock Recovery 
(CR) Window 

Enable Scan - Cleared 
Gating Units Unit Intervals, Edges - Unit Intervals 

Same as Clock 
Recovery Window 

Select, Clear Selected 

Alignment* Centered, User 
Defined 

Centered 
 

Length* 1 to 50 M in 
increments of 1 

250 

Start*** 1 to 50 M in 
increments of 1 

1.626k 

Analysis Window 
(Relative to CR 
Window) 

Stop - - 
* Available when you clear the Same as Clock Recovery Window check box. 
** Available when you select User Defined as the Alignment option. 
  

Configure Clock Recovery Menu Parameters 

Table 56. Clock recovery menu parameters 
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Area Option Parameters Default setting 
Clock Recovery Method Const Clk: Mean, 

Const Clk: Median, 
PLL: Standard BW, 
PLL: User BW 

PLL: Standard 
BW 

On 
Off 

 Off Nominal Data 
Rate 

Bit Rate* 1 to 10 e9 bits/second 2.5 Gb/s 
User BW** 10 kHz to 1 GHz 15 MHz PLL Loop BW 
Standard: 
b/s† 

PCI-E: 2.5 G, 
100BaseT: 125 M, 
1394b S400b: 491.5 M, 
1394b S800b: 983.0 M, 
1394b S1600b: 1.966 G, 
FC133: 132.8 M, 
FC266: 265.6 M, 
FC531: 531.2 M, 
FC1063: 1.063 G, 
FC2125: 2.125 G, 
FC4250: 4.25 G, 
FC8500: 8.5 G, 
FBD1: 3.2 G, 
FBD2: 4.0 G, 
FBD3: 4.8 G, 
GB Ethernet: 1.25 G, 
IBA2500: 2.5 G, 
IBA_GEN2: 5.0 G, 
OC1: 51.8 M, 
OC3: 155 M, 
OC12: 622 M, 
OC48: 2.488 G, 
PCI_E_GEN2: 5.0 G, 
RIO125: 1.25 G, 
RIO250: 2.5 G, 
SAS3: 3.0 G, 
SAS6: 6.0 G, 
SAS15: 1.5 G, 
SerATAG1: 1.5 G, 
SerATAG2: 3.0 G, 
SerATAG3: 6.0 G, 
USB FS: 12 M, 
USB HS: 480 M, 
XAUI: 3.125 G, 
XAUI_GEN2: 6.25 G 

PCI-E: 2.5 G 

PLL Order‡ First, Second First PLL 
Damping  0.5 to 1.0  0.7 

* Available only when Nominal Data Rate is On. 
** Available only when Method is PLL: User BW. 
†Available only when Method is PLL: Standard BW. 
‡Available only when Method is PLL: User BW or PLL: Standard BW. 

 Damping is only available for Second Order PLL. 
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Configure Jitter Menu Parameters 

Table 57. Jitter menu parameters 
Area Option Parameters Default setting 

Type Repeating, Arbitrary Repeating 
Pattern  B2BTS1, CJTPAT, 

CSPAT, PCE-CTP, FBD-
IBIST, Custom 

CJTPAT 

Length* 1 to 200 k unit intervals 2.5 k UI 
Window 
Length† 

2 to 16 unit intervals 5 UI 

Data Pattern 
 

Population† 5 to 5000 samples 100 samples 
Rj/Dj BER=1 e-?‡ 2 to 15 (1e-2 to 1e-15) 12 (BER = 1e-12) 
* Available only when Type is Repeating. 
** Available only when Type is Repeating and Pattern is Custom. 
†Available only when Type is Arbitrary. 
‡Available only when the Jitter@BER measurement is selected. 
  

Configure Population Menu Parameters 

Table 58. Population menu parameters 
Area/option Parameters Default setting 
Population Limit On, Off Off 

 
Acquisitions, Measurement 

 
Acquisitions 

Configure  
   Limit By 
   Limit  1 to 10 T in units of 1 1 K 
  

Configure General Config Parameters 

Table 59. General config parameters 
Option Parameters Default setting
Limit Rise/Fall measurements to transition 
bits only 

Yes, No No 

Limit Amplitude measurements to transition 
bits only 

Yes, No No 

Enable worst-case logging while in scan 
mode 

Yes, No Yes 
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Measurements Limits Menu Parameters 

Table 60. Measurement limits parameters 
Option Parameters Default setting 
Limits  On, Off Off 
Limits File Editor Current, New none 
Limits File <Browser> Default directory* 
* Refer to the Application Directories and Usage topic for default path names.  
  

Results Menus 
The application includes the following Results Menus:  

 Summary  

 Details  

Results Summary Menu Parameters 
The Results Summary menu includes the following command buttons: 

 Show Plot 

 Export to CSV 

Table 61. Results summary menu parameters 
Option Parameters Default setting 
Select View All Stats, Limits Status* All Stats 
Time Units Unit Intervals, Seconds Unit Intervals 
* Available only when Measurements Limits is enabled. 
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Results Details Menu Parameters 
The Results Details menu includes the following command buttons: 

 Show Plot 

 Export to CSV 

Table 62. Results details menu parameters 
Option Parameters Default setting 
Select View <list of all selected measurements> <first selected> 
Time Units Unit Intervals, Seconds Unit Intervals 
  

Plots Select Menu Parameters 
The Plots Select menu includes the following command button: 

 Refresh 

Table 63. Plots select menu parameters 
Option Parameters Default setting
Measurement <any selected measurement> Eye Width 
Plot Type  See Measurement and Available Plots topic Eye Diagram 
Plots Display On, Off On 
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Eye Diagram Configure Menu Parameters 

Table 64. Eye diagram configure menu parameters 
Area/option Parameters Default setting
Bit Type All, Transition, Non Transition All 
Mask On, Off Off 
Standard InfiniBand, PCI Express, User* InfiniBand 

 
Receiver, Cable, TP1, TP2, TP3, TP4, 
TP5, TP6, TP7, TP8, TP9, TP10 

Receiver Type 
    for InfiniBand  
 
    for PCI Express  Receiver, Transmitter Tbit, Transmitter 

NTbit 
Receiver 

* When you select User, a file browser displays; refer to the User Mask topics. 
  

Histogram Plot Configure Menu Parameters 

Table 65. Histogram plot configure menu parameters 
Option Parameters Default setting 
Vertical Axis Linear, Log Linear 
Bin Resolution 1 to 50 K in units of 1 250 
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Spectrum Plot Configure Menu Parameters 

Table 66. Spectrum plot configure menu parameters 
Option Parameters Default setting 
Vert. Scale Linear, Log Linear 
Horiz. Scale Linear, Log Linear 
  

Bathtub Plot Configure Menu Parameter 

Table 67. Bathtub plot configure menu parameters 
Option Parameter Default setting 
Scale Linear, Log Linear 
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Log Worst Case Configure Menu Parameters 
The Log Worst Case menu includes the following command button: 

 Purge 

Table 68. Log worst case configure menu parameters 
Option Parameters Default setting 
Log On, Off Off 
Choose Directory <Browser> Default directory* 
* Refer to the Application Directories and Usage topic for default path names.  
  

Utilities Report Generator Menus Parameters 
There are no parameters for the Report Generator utility menus. 

Help Menu 
There are no parameters for the Help menu. 
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Algorithms 

About Measurement Algorithms 
The RT-Eye application can take measurements from one or two serial data 
waveforms. The number of waveforms used by the application depends on the 
probe selected in the Probe Type option of the Measurements> Select menu. 

 The Algorithms book includes Field Notes that you may use to ensure 
good measurement results.  

Oscilloscope Setup Guidelines 
For all measurements, use the following guidelines to set up the oscilloscope: 

1. The signal is any channel, reference, or math waveform. 

2. The vertical scale for the waveform must be set so that the waveform does 
not exceed the vertical range of the oscilloscope. 

3. The sample rate must be set small enough to capture sufficient waveform 
detail and avoid aliasing. 

4. Longer record lengths increase measurement accuracy (though at the same 
time decrease measurement speed) 
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Test Methodology 
The application performs the measurement according to the following steps: 

1. Imports the current waveform. 

2. For timing measurements, checks that there are a minimum number of edges 
in the waveform to calculate the measurement as follows: 

 Single edge: Rise Time, Fall Time 

 Two cycle-start edges: Unit Interval 

 Three cycle-start edges: TIE 

 Jitter measurements require at least 50 pattern repeats for RjDj 
analysis; accuracy may be degraded for fewer than 100 pattern repeats  

 Two edges on each of two waveforms: Differential Skew 

3. Performs the measurement. 

4. Displays the results as statistics where you can save the results to a .csv file. 

5. Displays the results as a plot if defined and enabled. 
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Measurements 

Table 69. Measurements 

Button name Measurement names Applicable module test 
Timing 
Eye Width/ 
Eye Height 

Eye Width 
Eye Height 
Eye Height: Transition Bits
Eye Height: Non-Transition 
Bits 

Eye Height: All 
Eye Width: Infinband-Cable 
Assembly, PCI Express, Serial 
Analysis. 

Rise  
Time 

Rise Time All. Applied to vD+ and vD- in 
PCI Express w/ Single-Ended 
Probes. 

Fall  
Time 

Fall Time All. Applied to vD+ and vD- in 
PCI Express w/ Single-Ended 
Probes. 

Unit  
Interval 

Unit Interval Infiniband-Driver, PCI-
Express, Serial Analysis. 

Bit Rate Bit Rate Serial Analysis. 
Differential 
Skew* 

Differential Skew Serial Analysis. 

Amplitude 
Differential Amplitude Infiniband-Driver/Receiver, 

Serial Analysis. 
Differential 
Voltage 

Differential Peak Voltage PCI Express. 
Differential 
Average 

 PCI Express-Driver. 

High 
Amplitude 

High Amplitude Serial Analysis. 

Low Amplitude Low Amplitude Serial Analysis. 
CM Voltage* CM Voltage Infiniband-Driver/Receiver, 

PCI Express, Serial Analysis. 
AC CM Voltage Serial Analysis. 
AC CM RMS Voltage InfiniBand and PCI-Express 

Driver. 

AC CM 
Voltage* 

AC CM Pk Voltage PCI-Express Receiver 
De-Emphasis De-Emphasis PCI-Express Driver, Serial 

Analysis. 
Jitter 
Jitter @ BER Jitter @ BER 

Jitter: Eye Opening 
Jitter: Total (TJ) 
Jitter: Deterministic (DJ) 
Jitter: Random (RJ) 

Infiniband-Driver/Receiver, 
Serial Analysis 
RJ only available in Serial 
Analysis. 

TIE Jitter TIE Jitter Infiniband-Cable Assembly, 
PCI Express, Serial Analysis. 

* Available only when Single Ended is the Probe Type option in the 
Measurements Select menu. 
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Notation in Algorithms 

About Notation in Algorithms 

All measurements are made on one of several voltage waveforms. Timing 
measurements are based on edge locations in the waveform or on clock edge 
times derived from the waveform edge locations. Amplitude measurements are 
made on the entire waveform or on waveform values based on recovered clock 
times. To represent measurements as formulas, the algorithm descriptions follow 
notational rules. 

  

Notational Rules 

Table 70. Notational rules 
Notation Use 
Lower case 
character 

Reserved for fundamental signals or measurements.  For 
instance, sampled waveforms are of the form v(i) and edge 
times are of the form t(n).  The character is indicative of the 
units of the quantity, such as v for a voltage and t for a time. 
They are always indexed. 

Upper case 
character 

Used for a quantity that is fixed or for a measurement. The 
character is indicative of the units of the quantity, such as V 
for a voltage and T for a time. 

Subscripts Used to identify the variable, measurement or quantity. 
Indices 
variables 

Indices for variables or measurements have multiple values 
over the course of an acquisition. The indices are between 
parentheses. If the index is a measurement, it will have 
statistics for both the current acquisition and all acquisitions 
(accumulated).  Non-indexed measurements that have a 
single result for the entire waveform will only have all 
acquisition statistics. 
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Summary Definitions of Fundamental Signals and Measurements 
The next several topics list the annotation of the signals and measurements as 
they appear in the algorithm specific to each measurement. The algorithms 
comprise the following types of annotation: 

• Waveforms  

• Edge Time Threshold Voltages  

• Crossing Times  

• Recovered Clock Times  

• Eye Center Voltages  

Waveforms 

Table 71. Waveforms 
Waveform Definition 
i Index into sampled voltage waveforms 

vD+(i) Positive conductor (D+) voltage acquired with a single ended 
probe 

vD–(i) Negative conductor (D–) voltage acquired with a single ended 
probe 

vDIFF(i) Differential voltage signal acquired with either a differential 
probe or calculated from two single ended probe signals: 
= vD+(i) – vD–(i) 

vCM(i) Common mode voltage calculated from two single ended probe 
signals: 
= (vD+(i) + vD–(i))/2 
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Edge Time Threshold Voltages 

Table 72. Edge time threshold voltages  
Edge Time 
Threshold Voltage 

 
Definition 

VREF-HI High level reference voltage 

VREF-MID Mid level reference voltage 

VREF-LO Low level reference voltage 

VHYST Hysteresis voltage; minimum voltage swing required at 
any threshold before a crossing is recognized 

  

Crossing Times 

Table 73. Crossing times 
Crossing Time Definition 
n Index into array of crossing times 

t Interpolated time when vDIFF crosses a VREF 
tHI(n) When vDIFF(t) crosses VREF-HI 
tDAT(n) When vDIFF(t) crosses VREF-MID 
tLO(n) When vDIFF(t) crosses VREF-LO 
tD+HI(n) When vD+(t) crosses VD+REF-HI 
tD+MID(n) When vD+(t) crosses VD+REF-MID 
tD+LO(n) When vD+(t) crosses VD+REF-LO 
tD–HI(n) When vD–(t) crosses VD–REF-HI 
tD–MID(n) When vD–(t) crosses VD–REF-MID 
tD–LO(n) When vD–(t) crosses VD–REF-LO 
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Recovered Clock Times 

Table 74. Recovered clock times 
Recovered Clock 
Time 

 
Definition 

tR-CLK(n) Recovered clock edge times referenced to the UI 
boundaries:  
= PLL(tMID) for PLL based clock recovery 
= CCR(tMID) for Constant Clock based clock recovery 

iUI-TRAN(n) List of transition UIs immediately following a transition 

iUI-NTRAN(n) List of non-transition UIs not immediately following a 
transition 

tR-DAT(n) Recovered data edge times:  
= tR-CLK(iUI-TRAN(n)) 

UI(n) Unit Interval (UI):  
= tR-CLK(n+1)  – tR-CLK(n) 

  

 Eye Center Voltages 

Table 75. Eye center voltages 
Eye Center Voltage Definition 
vEYE(n) Voltage at middle of a UI: 

= vDIFF(tR-CLK(n) + UIAVG/2) 
vEYE-TRAN(n) Voltage at middle of a transition UI*: 

= vEYE(iUI-TRAN(n)) 
vEYE-NTRAN(n) Voltage at middle of a non-transition UI*: 

= vEYE(iUI- NTRAN(n)) 
vEYE-HI(n) High voltage at middle of a UI*: 

= subset(vEYE(n) >= 0) 
vEYE-LO(n) Low voltage at middle of a UI*: 

= subset(vEYE(n) < 0) 
vEYE-HI-TRAN(n) High voltage at middle of a transition UI*: 

= vEYE-HI(iUI-TRAN(n)) 
vEYE-HI-NTRAN(n) High voltage at middle of a non-transition UI*: 

= vEYE-HI(iUI- NTRAN(n)) 
vEYE-LO-TRAN(n) Low voltage at middle of a transition UI*: 

= vEYE-LO(iUI-TRAN(n)) 
vEYE-LO-NTRAN(n) Low voltage at middle of a non-transition UI*: 

= vEYE-LO(iUI- NTRAN(n)) 
* A subset of vEYE(n). 
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Timing Measurements 

About Timing Measurements 

Timing measurements are all based on either Crossing Times or Recovered 
Clock Times. Crossing times are dependent on Ref Level thresholds. Recovered 
Clock Times are affected by the clock recovery method specified in Clock 
Recovery and Jitter Configuration. 

  

Eye Width Measurement 

The Eye Width measurement is the measured minimum horizontal eye opening 
at the zero reference level as shown in the eye diagram.  

 PkPkAVGWIDTHEYE TIEUIT −− −=  

Where: 

 AVGUI  is the average UI 

 PkPkTIE −  is the Peak-Peak TIE 
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Rise Time Measurement 

The Rise Time measurement is the time difference between when the HIREFV −  
reference level is crossed and the LOREFV −  reference level is crossed on the rising 
edge of the waveform.  

 )()()( jtitnt LOHIRISE ++ −=  

Where: 

 RISEt  is a Rise Time measurement 

 +HIt  is a set of HIt  for rising edges only 

 +LOt  is a set of LOt  for rising edges only 

 i and j are indexes for nearest adjacent pairs of +LOt  and +HIt  

 n is the index of rising edges in the waveform 

Rise time can be limited to only rising edges of consecutive transitions in the File 
Preferences menu. In the PCI-Express module, Rise Time is taken independently 
on each single-ended waveform sources when you use two single-ended probes 
as the signal source.  

Rise Time for )(tvD+  is as follows: 

 )()()( jtitnt LODHIDRISED +++++ −=  

and for )(tvD−  

 )()()( jtitnt LODHIDRISED +−+−− −=  
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Fall Time Measurement 

The Fall Time measurement is the time difference between when the HIREFV −  
reference level is crossed and the LOREFV −  reference level is crossed on the 
falling edge of the waveform.  

 )()()( jtitnt HILOFALL −− −=  

Where: 

 FALLt  is a Fall Time measurement 

 −HIt  is a set of HIt  for falling edges only 

 −LOt  is a set of LOt  for falling edges only 

 i and j are indexes for nearest adjacent pairs of −LOt  and −HIt  

 n is the index of falling edges in the waveform 

Fall time can be limited to only falling edges of consecutive transitions in the File 
Preferences menu. In the PCI-Express module, Fall Time is taken independently 
on each single-ended waveform source when you use two single-ended probes as 
the signal source.  

Fall Time for )(tvD+  is as follows: 

 )()()( jtitnt HIDLODFALLD −+−++ −=  

and for )(tvD−  

 )()()( jtitnt HIDLODFALLD −−−−− −=  
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Rising Edge Measurement 

The Rising Edge measurement or Rising Edge Rate measurement is defined as 
the ratio of voltage difference between IHDIFFREFCLKV −−  and ILDIFFREFCLKV −−  to 
the time difference between the crossing of IHDIFFREFCLKV −−  reference level and 
the crossing of ILDIFFREFCLKV −−  reference level on the rising edge of the 
waveform.  

 )()(
)(

jtit
VV

nER
ILRISEIHRISE

ILDIFFREFCLKIHDIFFREFCLK
RISE

−−

−−−−

−
−

=
 

Where: 

 RISEER  is a rising edge rate measurement  

 IHDIFFREFCLKV −−  is a predefined high voltage reference level  

 ILDIFFREFCLKV −−  is a predefined low voltage reference level 

 IHRISEt −  is a set of  time when IHDIFFREFCLKV −−  reference level is crossed 
on rising edges 

ILRISEt −  is a set of  time when ILDIFFREFCLKV −−  reference level is crossed on rising 
edges 

 i and j are indexes for nearest adjacent pairs of IHRISEt −  and ILRISEt −  

 n is the index of rising edges in the waveform 

The rising edge measurement is required for reference clock measurements in 
PCI-Express and FB-DIMM modules. In these two modules, rising edge is taken 
on differential signal, the value of IHDIFFREFCLKV −−  and ILDIFFREFCLKV −−  is 
specified as 150mV and -150mV respectively as shown in the following diagram. 

 

 

 Figure 129: Rising edge measurement 
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Falling Edge Measurement 

The Falling Edge measurement or Falling Edge Rate measurement is defined as 
the ratio of voltage difference between IHDIFFREFCLKV −−  and ILDIFFREFCLKV −−  to 
the time difference between the crossing of ILDIFFREFCLKV −−  reference level and 
the crossing of IHDIFFREFCLKV −−  reference level on the falling edge of the 
waveform.  

 )()(
)(

jtit
VV

nER
IHFALLILFALL

ILDIFFREFCLKIHDIFFREFCLK
FALL

−−

−−−−

−
−

=
 

Where: 

FALLER  is a falling edge rate measurement  

IHDIFFREFCLKV −−  is a predefined high voltage reference level  

ILDIFFREFCLKV −−  is a predefined low voltage reference level 

IHFALLt −  is a set of  time when IHDIFFREFCLKV −−  reference level is crossed on 
falling edges 

ILFALLt −  is a set of  time when ILDIFFREFCLKV −−  reference level is crossed on 
falling edges 

i and j are indexes for nearest adjacent pairs of ILFALLt −  and IHFALLt −  

n is the index of falling edges in the waveform 

The falling edge measurement is required for reference clock measurements in 
PCI-Express and FB-DIMM modules. In these two modules, falling edge is taken 
on differential signal, the value of IHDIFFREFCLKV −−  and ILDIFFREFCLKV −−  is 
specified as 150mV and -150mV respectively as shown in the Rising Edge 
Measurement diagram. 
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Unit Interval Measurement 

The Unit Interval measurement calculates the cycle duration of the recovered 
clock. 

 )()1()( ntntnUI CLKRCLKR −− −+=  

 ))(( nUIMeanUI AVG =  

Where:  

 CLKRt −  is a recovered clock edge 

 n is the index to UI in the waveform 
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Bit Rate Measurement 

The Bit Rate measurement calculates the baud (such as frequency) of the 
recovered clock. 

 BR(n) = 1/UI(n) 

Where:  

 UI is the associated Unit Interval measurement 

 n is the index to UI in the waveform 

Differential Skew Measurement 

The Skew measurement is the time delay between the two single-ended 
waveform sources.  

 )()()( ntntnt MIDDMIDDSKEW −+ −=  

Where:  

 SKEWt  is the Skew measurement 

 MIDDt +  is the mid level crossing time of +Dv  

 MIDDt −  is the mid level crossing time of −Dv  

 n is the index to edges in the waveform 
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Amplitude Measurements 

About Amplitude Measurements 

Some amplitude measurements can be limited to only the high or only the low 
amplitude of consecutive transitions in the File Preferences menu.  

Eye Height Measurement 

The Eye Height measurement is the measured minimum vertical eye opening at 
the UI center as shown in the plot of the eye diagram. There are three types of 
Eye Height values. 

Eye Height: 

 MAXLOEYEMINHIEYEHEIGHTEYE VVV −−−−− −=  

Where:  

 MINHIEYEV −−  is the minimum of the High voltage at mid UI 

 MAXLOEYEV −−  is the maximum of the Low voltage at mid UI 

Eye Height – Transition: 

MAXTRANLOEYEMINTRANHIEYETRANHEIGHTEYE VVV −−−−−−−− −=  

Where:  

 MINTRANHIEYEV −−−  is the minimum of the High transition bit eye voltage 
at mid UI 

 MAXTRANLOEYEV −−−  is the maximum of the Low transition bit eye voltage 
at mid UI 
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Eye Height – Non-Transition: 

  

MAXNTRANLOEYEMINNTRANHIEYENTRANHEIGHTEYE VVV −−−−−−−− −=  

Where:  

MINNTRANHIEYEV −−−  is the minimum of the High non-transition bit eye voltage at 
mid UI 

MAXNTRANLOEYEV −−−  is the maximum of the Low non-transition bit eye voltage at 
mid UI 
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Differential Amplitude Measurement 

The Differential Amplitude measurement calculates the change in voltage level 
across a transition in the differential waveform. 

 |)1()(|)( +−= −−− ivivnv LEVELDIFFLEVELDIFFAMPDIFF  

Where 

 n is the index of transitions of interest 

 i is the index of UI (bit) locations preceding/following the transition 

LEVELDIFFv −  is the state level of the unit interval (bit period) 
))(( jvmeanv DIFFLEVELDIFF =−  

Where 

j is the sample index; in the previous equation, j spans the samples that fall in the 
center 30% of UIs i or i+1. 

DIFFv  is the differential voltage. 

Note: Eligible transitions are all transitions (Blue and Red) or consecutive 
transitions (Red only). This is set in the File Preferences menu. 
 

  

Figure 130: Differential voltage 
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Differential Peak Voltage Measurement 

The Differential Peak Voltage measurement returns two times the larger of the 
Min or Max statistic of the differential voltage waveform.  

 )))(());(((2 ivMinivMaxMaxV DIFFDIFFPKDIFF ∗=−  

Where:  

 i is the index of all waveform values 

 DIFFv  is the Differential voltage signal 

 Differential Average Measurement 

The Differential Average measurement returns the Mean of the differential 
voltage waveform.  

 ))(( ivMeanV DIFFAVGDIFF =−  

Where: 

 i is the index of all waveform values 

 DIFFv  is the Differential voltage signal 

  

High Amplitude Measurement 

The High Amplitude measurement calculates the mode of all differential 
waveform values greater than zero. 

 )0)(( >= ivModeV DIFFHI  

Where: 

 DIFFv  is Differential voltage signal 

 i is the index of all waveform values 
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Low Amplitude Measurement 

The Low Amplitude measurement calculates the mode of all differential 
waveform values less than zero. 

 )0)(( <= ivModeV DIFFLO  

Where: 

 DIFFv  is Differential voltage signal 

 i is the index of all waveform values 

  

CM Voltage Measurement 

The Common Mode Voltage measurement (also called DC Common Mode) 
calculates the mean of the Common Mode voltage waveform. 

 ))(( ivMeanV CMCM =  

Where: 

 CMv  is the Common Mode voltage signal 

 CMV  is the Common Mode voltage signal 

 i is the index of Common Mode waveform values 
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AC CM Voltage Measurement 

The AC Common Mode Voltage measurement calculates the AC statistics of the 
Common Mode voltage waveform with the DC value removed. 

 CMCMCMAC Viviv −=− )()(  

Where: 

 i is the index of all waveform values 

 CMACv −  is the AC Common Mode voltage signal 

 CMv  is the Common Mode voltage signal 

 CMV  is the DC Common Mode voltage signal 

  

AC CM RMS Voltage Measurement 

The AC Common Mode RMS Voltage measurement calculates the RMS statistic 
of the Common Mode voltage waveform with the DC Value removed. 

 ))(()( ivRMSiV CMACCMRMSAC −−− =  

Where: 

 i is the index of all waveform values 

 CMRMSACV −−  is the RMS of the AC Common Mode voltage signal 

 CMACv −  is the AC Common Mode voltage signal 
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De-Emphasis Measurement 

The De-Emphasis measurement calculates the ration of any non-transition eye 
voltage (2nd, 3rd, etc. eye voltage succeeding an edge) to its nearest preceding 
transition eye voltage (1st eye voltage succeeding an edge). In the accompanying 
diagram, it is the ratio of the Black voltages over the Blue voltages. The results 
are given in dB. 

  

Figure 131: De-emphasis measurement 
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Where: 

 TRANHIEYEv −−  is the High voltage at mid UI following a positive 
transition 

 TRANLOEYEv −−  is the Low voltage at mid UI following a negative 
transition 

 NTRANHIEYEv −−  is the High voltage at mid UI following a positive 
transition bit 

 NTRANLOEYEv −−  is the Low voltage at mid UI following a negative 
transition bit 

 m is the index for all non-transition UIs 

 n is the index for the nearest transition UI preceding the UI specified by 
m 
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Jitter Measurements 

About Jitter Measurements 

In the context of this RT-Eye analysis package, the term Jitter is used solely in 
relation to timing errors between data signal edges and recovered clocks. The two 
measurements in this category are TIE Jitter and Jitter @ BER. TIE Jitter is a 
direct measurement of the time difference (error) between data edges and 
associated clock edges, which is recovered from the data signal edges. Jitter @ 
BER is the label for Random and Deterministic Jitter analysis (Rj/Dj) on a TIE 
Jitter measurement.  

The purpose of the Rj/Dj analysis is two fold: to decompose the TIE into 
component elements and to extrapolate jitter measurements (Total Jitter or Eye 
Opening) @ BERs that would require very large data sets for direct 
measurement. 

TIE, and therefore Jitter @ BER, correlates to Eye Diagram statistics. A time 
Histogram at the eye crossing (at the mid reference voltage level) is the same as 
Histogram Plot of the TIE Jitter measurement on the same signal. 

The method of clock recovery has a big impact on Jitter results. 
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Jitter @ BER Measurement 

The Rj/Dj measurement calculates the deterministic and random components of 
jitter. The jitter is obtained from the TIE measurements. Rj is the random jitter 
and is assumed to be Gaussian having flat spectrum. The Rj measurement 
calculates the RMS value of the random jitter.  

Dj is the deterministic jitter. It is predictable and can be generated consistently 
under known circumstances. Dj has a spectrum of impulses when the data signal 
has a repeating pattern. The Dj measurement calculates the peak-to-peak value of 
the deterministic jitter. Tj is the total jitter, which is composed of Dj and Rj. The 
Tj measurement calculates the peak-to-peak value of the total jitter at the 
specified BER.  

Dj comes from multiple sources: 

 Periodic jitter (PJ) from periodic interference that is not correlated to the 
data  

 Data dependent jitter (DDJ) from interference of nearby edges (also called 
ISI or Inter-Symbol Interference)  

 Duty Cycle Distortion jitter (DCD) from slew rate differenced between 
rising and falling edges.  

Two methods of jitter measurements are supported. The first method is a 
spectrum analysis based approach (default) when the data pattern is repetitive. A 
clock waveform is always repetitive. Other repetitive testing data patterns are 
used, such as the CJTPAT data pattern.  

The second method is Rj/Dj separation method is arbitrary pattern analysis based 
approach when the data pattern is not necessarily repetitive. It is useful for long 
PRBS data patterns. The data is virtually non-repetitive within a single 
acquisition for extremely long data pattern. 

  

 



Algorithms 

226                RT-Eye ®Serial Compliance and Analysis Application 

Spectrum Analysis based Rj/Dj Separation on Repeating Pattern 

Dj components can be identified in a jitter spectrum under a set of conditions. PJ 
will appear as spectral impulses regardless of the conditions. DDJ and DCD will 
appear as spectral impulses provided that the data signal is a repeating pattern. 
The frequencies of DDJ and DCD spectral impulses are at harmonics of the (Bit 
Rate / Pattern length). The remaining spectral energy is attributed to Rj. Dj 
components are spectrally separated from Rj.  

The Dj measurement is the peak-to-peak value of the inverse fourier transform of 
the deterministic jitter spectral components. Tj is the total jitter, which is 
composed of Dj and Rj. The Tj measurement calculates the peak-to-peak value of 
the total jitter. Rj is assumed to be near Gaussian. The Rj measurement is the 
calculated RMS value of random jitter. 

A Jitter PDF is formed by convolving Gaussian distribution of Rj and Histograms 
of Dj. A Bathtub curve is calculated from the left and right side CDFs of the 
Jitter PDF. The Bathtub curve will yield TJ and Eye Opening ( OPENEYET − ). View 
the Bathtub Curve: BER versus Decision Time Diagram.  

The application calculates the measurements using the following equation: 

   )()( TimeTime DjMinDjMaxDj −=  

   ( )TimeDjtieRMSRj −=  

)()( RjFGaussianPDDjHistogramnormalizedTJ PDF ∗=  

 MINMax TJTJTJ −=  

 TJUIT OPENEYE −=−  

Where: 

 Dj  is the Deterministic jitter 

 Rj  is the Random jitter 

 TJ  is the Total jitter 

 PDFTJ  is the PDF of the Total jitter 

 MINTJ  is the minimum value at the Bathtub curve at a given BER 
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MaxTJ  is the maximum value at the Bathtub curve at a given BER 

TimeDj  is the is the time domain record of the Dj  component of  

jitter obtained by performing an inverse FFT of the Dj  components of the TIE 
spectrum. 

tie  is the time domain record of measured TIE jitter. 

Additionally, Dj  is further decomposed as follows:   

 )()( TimeTime PJMinPJMaxPJ −=  

)()( Time
Fall

Time
Rise DCDDDJMeanDCDDDJMeanDCD −=

 

DCDDCDDDJMinDCDDDJMaxDDJ TimeTime −−= )()(  

Where: 

 PJ  is the periodic jitter 

 DCD  is the duty cycle jitter 

 DDJ  is the data dependent (or ISI) jitter 

TimePJ  is the time domain record of the PJ  component of jitter obtained by 
performing an inverse FFT of the PJ components of the TIE spectrum. 

TimeDCDDDJ  is the time domain record of the  

DCD + DDJ component of jitter  obtained by performing an  

DCD inverse FFT of the DCD + DDJ components of the TIE spectrum.  

Time
RiseDCDDDJ  is 

TimeDCDDDJ  on rising edges only. 

Time
FallDCDDDJ  is 

TimeDCDDDJ  on falling edges only. 



Algorithms 

228                RT-Eye ®Serial Compliance and Analysis Application 

Arbitrary Pattern Analysis based Rj/Dj Separation 

When the data pattern is non-repeating, Pj still has a spectrum of impulses while 
DCD+DDJ no longer has a spectrum of impulses. Therefore, Dj no longer has a 
spectrum of impulses.  

The DCD+DDJ value is obtained through the arbitrary data pattern analysis 
method, which is based on the assumption that any given bit is affected by a 
finite number of preceding bits. By averaging all events where the current bit is 
preceded by a particular bit sequence, for example, the current bit is preceded by 
the bit sequence 1001101, the DCD+DDJ with such a pattern is obtained because 
PJ and RJ are not correlated to a particular data sequence and thus are averaged 
out.  

If each bit is assumed to be affected by N preceding bits, there are a total of 2N 
possible data sequences. The sequence length N is a configurable parameter. To 
get statistically sound average values, a population limit is the other configurable 
parameter that prevents using an average value without enough population. Only 
DCD+DDJ values obtained from data sequences with a population above the 
limit are used to calculate DCD+DDJ values. 

After each edge is associated with a DCD+DDJ value, with known total jitter, the 
PJ+Rj value for each bit is then obtained by subtracting DCD+DDJ from TJ. 

Separation of DDJ and DCD from DCD+DDJ is the same as that in the spectrum 
based Rj/Dj separation method. 

PJ and Rj are then separated from PJ+Rj using the spectrum analysis method. PJ 
has a spectrum of impulses. Rj has a flat spectrum. Not all of the edges 
DCD+DDJ can be determined because of their associated data sequences, which 
have low populations and are treated as if there are no edges when performing PJ 
and Rj separation. 

The histogram of Dj is a convolution of the histogram of DCD+DDJ and the 
histogram of PJ. 

All other aspects of the arbitrary pattern analysis based Rj/Dj separation are the 
same as those of the spectrum analysis based Rj/Dj separation. 
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Rj/Dj Separation based on Dual-Dirac Model 

The Dual-Dirac model based Rj/Dj separation method fits the Bathtub curve to a 
theoretical model of Rj and Dj where Rj has a Gaussian distribution and Dj has a 
distribution of two Dirac impulses with the same height. Curve fitting at different 
BER levels in Bathtub curve yields the standard deviation value of Rj and peak-
to-peak value of Dj. The Bathtub curve is obtained from the spectrum analysis 
based or the arbitrary pattern analysis based Rj/Dj separation methods.  Rj and Dj 
based on the Dual- 

Dirac model can be denoted as gRJ  and ddDJ . 

After gRJ  and ddDJ  are obtained, Tj can be calculated using this formula: 

ddg DJRJBERQBERTJ +×= )(2)(  

Where Q is the function of BER that has a value of about 7 when  

1210−=BER . The Eye opening is computed in the same way as it is computed 
in the spectrum analysis based Rj/Dj separation. 

The Dual Dirac model based Rj/Dj separation method is used in PCI-Express and 
FB-DIMM modules.  

Dj does not usually have a pure Dual-Dirac distribution. So the  

value of gRJ  is often greater than the value of Rj obtained from the spectrum 
analysis based or the arbitrary pattern analysis  

based Rj/Dj separation. The value of ddDJ  is often less than that of Dj. 

Refer to www.T11.org for a detailed description of Rj/Dj separation based on 
Dual-Dirac model. 
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Jitter Measurements Field Notes 

Data pattern generation techniques vary from one serial data standard to another. 
Refer to the Standards Methods Of Implementation (MOIs) documents for 
specific details on how to set up those system-to-broadcast testable data/test 
patterns. 

Both PCI Express and InfiniBand serial data traffic test patterns are interspersed 
with Skip Ordered Sets (SOSs) on regular intervals. When conducting jitter 
measurements that require repeated data sets (such as for Jitter @ BER), you will 
need to set up the acquisition system to acquire between these non-deterministic 
Skip Characters. Refer to the Standards MOIs documents for specific details on 
how to set up the system to work under these conditions. 

TIE Jitter Measurement 

The measured time difference between a data edge and a recovered clock edge. 

 )()()( ntntntie DATDATR −= −  
Where: 

 DATt  is the original data edge 

DATRt −  is the recovered data edge (for example, the recovered clock edge 
corresponding to the UI boundary of DATt  

 n is the index of all edges in the waveform 
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TIE Jitter Filtering Measurement 

TIE Jitter Filtering measurement is used to apply a pre-defined filter to TIE jitter 
to get filtered TIE jitter measurement. 

 )()()( sTIEsHsTIE REFCLKFILTEREDREFCLK ⋅=−  

Where: 

FILTEREDREFCLKTIE −  is the frequency domain representation of a  

filtered TIE jitter FILTEREDREFCLKtie −  

 H  is the transfer function of a pre-defined filter  

REFCLKTIE  is the frequency domain representation of a TIE jitter  

before filtering REFCLKtie  

The TIE jitter filtering measurement is required by PCI-Express and FB-DIMM 
modules for reference clock measurements. In these two modules, the filter is 
used to emulate the effects of variation of the jitter transfer function of PLLs 
between transmitters and receivers; transport delays between them; differences in 
the propagation delays in the devices, and the phase tracking bandwidth of the 
clock phase recovery circuitry. One such transfer function )(sH  is defined as  
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Where the parameters iς , jω  and 1T  are pre-defined. An H(s) has a magnitude 
frequency response as follows: 
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Figure 132: Frequency response of H(s) 
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Statistics 

About Statistics 

The application calculates statistics for all selected measurements. The 
application displays the following statistics in the Results menus: 

 Maximum value 

 Minimum value 

 Mean value 

 Standard deviation value 

 Peak-Peak value 

 Population  

Maximum Value 

The application calculates this statistic using the following equation: 

    xofvalueHighestxMax =)(  

Minimum Value 

The application calculates this statistic using the following equation: 

    xofvalueLowestxMin =)(  

Mean Value 

The application calculates this statistic using the following equation: 
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Standard Deviation Value 

It may seem odd that the equation for the estimate of the Standard Deviation 
contains a 1/(N-1) scaling factor. If you knew the true mean of X and used in 
place of the estimated mean , then you would, in fact, scale by1/N. But,  is 
an estimate and is likely to be in error (or bias), causing the estimate of the 
Standard Deviation to be too small I scaled by 1/N. This is the reason for the 
scaling shown in the equation. (Refer to Chapter 9.2 in A. Papoulis, Probability, 
Random Variables, and Stochastic Processes, McGraw Hill, 1991.) 

The application calculates this statistic using the following equation: 
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Peak-to-Peak Value 

The application calculates this statistic using the following equation: 

    )()()( xMinxMaxxPkPk −=   

Population Value 

Population is the total number of data points applied to the displayed statistics. 



                                              

RT-Eye ® Serial Compliance and Analysis Application 
      

235

 

GPIB 

About the GPIB Program 
An example of a GPIB program that can execute the RT-Eye application is 
included with the application. The oscilloscope hard disk includes the example 
file, rt-eyectrl.c. On the hard drive, the file resides in the 
C:\TekApplications\tdsrt-eye\Examples\RemoteCtrl directory. 

The example shows how a GPIB program executes the application to do the 
following tasks: 

 Start the application 

 Recall a setup 

 Take a measurement 

 Check for an error 

 Exit the application 
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Guidelines to GPIB Programming 
The application includes an example file of a GPIB program. Your GPIB 
program should comply with the following guidelines: 

 The application startup must complete before sending additional GPIB 
commands to the application; query the variable application; it will return 
"TDSRT-EYE" when the application startup is complete 

 Recall a setup file from GPIB to select measurements and set up the 
application 

 The measurements cycle must complete before data is queried; query the 
variable SequencerState; it will return "Ready" when sequencing is 
complete 

 The resultFor and resultAcq variables must be set before querying results; 
pause a second after setting each variable 

 The error variable should be checked to ensure that an error has not occurred 
because of a measurement command problem; the measError variable 
returns errors specific to the measurement selected by resultFor 

  



                                                                                              GPIB                   

RT-Eye ® Serial Compliance and Analysis Application  237

Program Example 
The program example shows how to communicate to the RT-Eye application 
using remote GPIB commands. The program includes the following steps:  

 Start up the application 

 Recall a setup 

 Take a measurement 

 Display results or errors 

 Exit the application 

In the example, you will recall a setup file named rt-eyectrl.c (setup). You can 
use the File> Save function in the application to save setup files according to 
your own needs. 
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GPIB Commands 

Introduction to GPIB Command Syntax 

With knowledge of the GPIB command syntax, you can design a GPIB program 
to do the following tasks: 

 Start the RT-Eye application 

 Recognize an active application with GPIB protocol 

 Program and read application setup parameters 

 Sequence measurements 

 Read measurement results 

 Generate reports 
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GPIB Reference Materials 

To use GPIB commands with your oscilloscope, you can refer to the following 
materials: 

 The rt-eyectrl.c file on the oscilloscope hard drive (located in the 
c:\TekApplications\tdsrt-eye\Examples\RemoteCtrl directory) for an 
example of a GPIB program that can execute the application 

 The GPIB Program Example topic for guidelines to use while designing a 
GPIB program 

 The Parameters topics for range of values, minimum units and default 
values of parameters 

 The programmer information in the online help of your oscilloscope 

Starting and Setting Up the Application using GPIB 

To start the RT-Eye application, you must send the oscilloscope the following 
GPIB command: 

application:activate "RT-Eye Serial Compliance and Analysis" 

Note: The name of the application in the previous string is identical to the name 
of the application from the oscilloscope Run Application list. 
 

The application uses the GPIB VARIABLE:VALUE command with arguments 
to execute some features. The set of GPIB commands does not include the 
variable names and variable values necessary to select and configure the 
measurements in the GPIB program. 

You must manually set up the application and oscilloscope, selecting and 
configuring the measurements that you want to use with your GPIB program, and 
save them in a setup file in the default setup folder for that module. To save a 
setup file, refer to Saving a Setup File.  Use the name of the saved setup file as 
the value for the "recallName" variables in your GPIB program. 
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Variable: Value RT-Eye Command 
Description 

This command accepts string arguments for a control or data variable and a value 
to which to set the argument.  

Syntax 

VARIABLE:VALUE "<variable name>","<variable value>" 

Note: The arguments <variable name> and <variable value> are required in the 
order indicated. 
 

VARIABLE:VALUE? <variable name> for query. 

  CAUTION: Commands are case and space sensitive. Your program will not 
operate correctly if you do not follow the capitalization and spacing 
precisely. 
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Variable: Value RT-Eye Command Arguments and Queries (Part 1) 

  Table76. Variable value RT-eye command arguments and queries (part1) 
Group/name Value Function Query returns 
application {exit} Terminates the active 

application 
Returns TDSRT-EYE when 
the application is active 

version Query only  Returns the version number 
of the application 

Sequencer 
sequencerMode {SingleNoAcq, 

FreeRun, Single} 
Sets the sequencer mode Returns the sequencer mode

sequencerState {Stop, Sequencing} Sends the Measurement 
Sequencing command 

Returns {Most recent setting, 
Ready}; Ready indicates that 
the value was processed 
  

reset {Results} Clears the active 
measurement results and 
plots 

Returns {Most recent setting, 
Ready}; Ready indicates that 
the value was processed 

Active module 
module {SerialAnalysis, 

InfiniBand, 
PCIExpress,SATA,SAS
,FB-DIMM} 

Switches to the specified 
module ** 

Returns the active module 

Recall setup 
setup* {Default, Recall} Performs the Recall 

Default setup function 
Returns {Most recent setting, 
Ready}; Most recent setting 
indicates that the value is 
being processed; Ready 
indicates that the value was 
processed 

recallName Any string from 1 to 40 
characters: A to Z, 0 to 
9, or special characters 
like “.” 

Sets the Recall setup file 
name; file name 
extension of .ini is 
optional 

Returns the name of the set 
up file to be recalled (without 
an extension) 

recallDirectory Query only   Returns the current setting 
(determined from module 
command) of recall directory 
default, such as  
InfiniBand\setup  

*Query may return an error code if command fails. 
**Refer to the online help in the SATA and SAS modules for their Variable:Value commands and queries. 
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Variable:Value RT-Eye Command Arguments and Queries (Part 2) 

Table 77. Variable value RT-eye command arguments and queries (part 2) 
Group/name Value Function Query returns 
Source scaling 
sourceAutoset*** {Vert, Horiz, 

vertAndHoriz} 
Starts the automatic scaling if 
the sources are channel 
waveforms 

Returns {Most recent setting, 
Ready}; Ready indicates that 
the value was processed 

Source ref levels 
refLevelAutoset*** {Run} Performs Ref Level Autoset 

for the for all active sources;  
Active sources are Differential 
when Differential is the Probe 
Type or Differential, Dplus 
and Dminus when Single-
Ended is the Probe Type. 

Returns {Most recent setting, 
Ready}; Ready indicates that 
the value was processed 

Report generator setup 
reportGen* {Now} Exports content from current 

measurements into a report 
template/layout where the 
template/layout are default or 
as specified in the recalled 
setup file; concatenates the  
Template name and a 
timestamp for the file name  

{Most recent setting, Ready} 
Ready indicates report has 
been created and saved. 

Compliance module only 
reportDeviceID Any string from 1 to 

40 characters: A to 
Z, 0 to 9, or special 
characters like “.” 

Specifies the device ID field 
for report generation  

Returns the specified 
DeviceID; applies to 
compliance modules only 

Result variables 
resultFor {Measurement 

Name} 
Specifies the measurement 
that is the source for detailed 
results queries; refer to the 
tables between this one and 
the error codes table 

Returns the selected 
measurements for the queries 
associated with the resultFor 
command 

resultAcq {All, Current} Specifies the measurement 
result group as the most 
recent acquired or as an 
accumulation of all the 
measurements in the current 
session 

Returns the current value 

* Query may return an error code if command fails. 
** Serial Analysis module only. 
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Measurements Results Queries 

  CAUTION: Before you query for the measurement results, be sure to insert 
a one second delay after the resultFor and the resultAcq commands to allow 
the statistics variables to refresh. 

You need to use the VARIABLE:VALUE? form to enter measurement results 
queries in your GPIB program. Before you can do this, you must first set the 
measurement with the resultFor command. You can select the current or all 
acquisition statistics with the resultAcq command. 

The next several tables list the measurement results queries for the measurement 
selected in the resultFor variable. 

Measurements Results Queries Variable Names (Part 1) 

Table 78. Measurement results queries variable names (part 1) 
Variable name Query returns for measurement 
Statistics for all measurements selected with resultFor 
max Returns the maximum measurement value. 
mean Returns the mean measurement value. 
min Returns the minimum measurement value. 
pkpk Returns the peak-to-peak measurement value. 
population Returns the number of measurements used to the current 

statistics. 
stdDev Returns the standard deviation measurement set. 
Other for non-statistical information that appears in the Results menus. 
value Returns a generic message for measurements with no 

statistical results, such as for amplitude measurements. 
maskUIControl Returns the number of UIs examined for mask hits. 
maskHits Returns the number of UIs containing one or more mask 

hits. 
Limits 
statusMax Pass or Fail status; Pass when the measurement is below 

the maximum limit or Fail. 
statusMin Pass or Fail status; Pass when the measurement is above 

the minimum limit or Fail. 
status Pass or Fail status; Pass when the measurement passes 

the compliance test or Fail; also applies to the RT-Eye 
analysis with limits defined. 

Misc 
measUnits Returns a units string for the measurement, such as s for 

seconds.  
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Measurements Results Queries Variable Names (Part 2) 

Table 79. Measurement results queries variable names (part 2) 
Variable name Query returns for measurement 
Jitter@BER only 
dataDependent Returns the data dependent jitter component of the TIE 

measurement. 
dutyCycle Returns the duty cycle jitter component of the TIE 

measurement. 
deterministic Returns the deterministic jitter component of the TIE 

measurement. 
periodic Returns the periodic jitter component of the TIE 

measurement. 
random Returns the estimated random jitter component of the TIE 

measurement. 
totalJitter Returns the estimated total jitter component at the BER of 

the TIE measurement. 
eyeOpening Returns the estimated eye opening at the BER of the TIE 

measurement. 
Population Returns the population when resultAcq variable is set to 

"All". 
Messages return strings if there are problems; refer to the Error Codes tables. 
resultForStatus Returns one of the following strings: 

“Active” when the value of resultFor is an active 
measurement. 
“Inactive” when the value of resultFor is a known 
measurement that’s not active. 
“Unknown” when the value of resultFor is an unknown 
measurement. 
Any of the results specified in this table are not valid 
unless this variable is “Active”. 

error Returns a general error. 
warning Returns a warning from the most recent measurement. 
measError Returns a measurement specific error. 
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Serial Analysis Measurement Names for the resultFor Variable 

Table 80. Serial analysis measurement names for the resultFor variable  
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
Eye Width Yes   Yes  
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
Eye Height 
Transition Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Eye Height Non-
Transition Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Rise Time Yes  Yes   
Fall Time Yes  Yes   
Unit Interval Yes  Yes   
Bit Rate Yes  Yes   
Differential Skew* Yes  Yes   
Differential 
Amplitude 

Yes  Yes   

High Amplitude Yes   Yes  
Low Amplitude Yes   Yes  
CM Voltage* Yes   Yes  
AC CM Voltage* Yes   Yes   
De-Emphasis Yes  Yes   
Jitter @ BER  Jitter @ BER 

variables; see 
previous topic 

  Jitter @ BER 
variables; see 
previous topic 

Eye Opening Yes eyeOpening  Yes eyeOpening 
Total Jitter Yes totaljitter  Yes totalJitter 
Deterministic Jitter Yes deterministic  Yes deterministic 
TIE Jitter Yes  Yes   
* Added when the Probe Type option is Single Ended. 
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InfiniBand Driver Measurement Names for the resultFor Variable 

Table 81. Infiniband driver measurement names for the resultFor variable 
 Results when resultAcq= 
Measurement All Current   
Names Stats And … Stats Value And … 
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
Eye Height Transition 
Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Eye Height Non-
Transition Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Rise Time Yes  Yes   
Fall Time Yes  Yes   
Unit Interval Yes  Yes   
Differential Amplitude  Yes  Yes   
CM Voltage* Yes   Yes  
Eye Opening Yes   Yes eyeOpening 
AC CM RMS Voltage* Yes    Yes  
Jitter @ BER  Jitter @ BER 

variables; see 
previous topic 

  Jitter @ BER 
variables; see 
previous topic 

Total Jitter Yes   Yes totalJitter 
Deterministic Jitter Yes   Yes deterministic 
* Added when the Probe Type option is Single Ended. 
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InfiniBand Receiver Measurement Names for the resultFor Variable 

Table 82. Infiniband receiver measurement names for the resultFor variable 
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
Differential 
Amplitude 

Yes  Yes   

CM Voltage* Yes   Yes  
Eye Opening Yes   Yes eyeOpening 
Jitter @ BER  Jitter @ BER 

variables; see 
previous topic 

  Jitter @ BER 
variables; see 
previous topic 

      
Total Jitter Yes   Yes totalJitter 
Deterministic Jitter Yes   Yes deterministic 
* Added when the Probe Type option is Single Ended. 
  

  

InfiniBand Cable Assembly Measurement Names for the resultFor Variable 

Table 83. Infiniband cable assembly measurement names for the resultFor variable 
 Results when resultAcq= 
Measurement All Current   
Names Stats And … Stats Value And … 
Eye Width Yes   Yes  
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
TIE Jitter Yes  Yes   
* Added when the Probe Type option is Single Ended. 
  

  

 



GPIB 

248                RT-Eye ®Serial Compliance and Analysis Application 

PCI Express Measurement Names for the resultFor Variable for any Test point 
except Reference clock 

Table 84. PCI Express measurement names for the resultFor variable for any test point except reference clock 
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
Eye Width Yes   Yes  
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
Eye Height Transition 
Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Eye Height Non-
Transition Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Rise Time* Yes  Yes   
Fall Time** Yes  Yes   
Unit Interval Yes  Yes   
Differential Peak 
Voltage 

Yes   Yes  

Differential Average 
Voltage 

Yes   Yes  

De-Emphasis Yes  Yes   
AC CM RMS 
Voltage† 

Yes    Yes  

TIE Jitter Yes  Yes   
* For Single Ended two measurements: Rise Time D+ and Rise Time D-. 
** For Single Ended two measurements: Fall Time D+ and Fall Time D-. 
† Added when the Probe Type option is Single Ended. 
  

 
  



                                                                                              GPIB                   

RT-Eye ® Serial Compliance and Analysis Application  249

PCI Express Reference Clock Measurement Names for the resultFor Variable 

Table 85. PCI Express measurement names for the resultFor variable  
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
High Voltage Yes   Yes  
Low Voltage Yes   Yes  
Differential Peak 
Voltage 

Yes   Yes  

Rising Edge Yes  Yes   
Falling Edge Yes  Yes   
Period Yes  Yes   
Duty Cycle  Yes  Yes   
Jitter @ 6 BER  Jitter @ BER 

variables† 
  Jitter @ BER 

variables† 
Jitter @ 12 BER  Jitter @ BER 

variables† 
  Jitter @ BER 

variables† 
TIE Jitter  Yes  Yes   
* All measurements are available only for differential probe. 
† Jitter @ BER variables are defined in the topic Measurement Result Queries Variable 
Names Part 2 
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FBDIMM Transmitter Measurement Names for the resultFor Variable 

Table 86. FBDIMM transmitter measurement names for the resultFor variable 
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
Eye Width Yes   Yes  
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
Eye Height Transition 
Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Eye Height Non-
Transition Bits 

Yes maskUICount, 
maskHits 

 Yes maskUICount, 
maskHits 

Bit Rate Yes  Yes   
Rise Time Yes  Yes   
Fall Time Yes  Yes   
Differential Peak 
Voltage 

Yes   Yes  

De-Emphasis Yes  Yes   
AC CM Pk Voltage  Yes   Yes  
CM Voltage  Yes   Yes  
Jitter @ BER   Jitter @ BER 

variables* 
  Jitter @ BER 

variables* 
TIE Jitter Yes  Yes   

 Available only If Probe Type option is Single-Ended. 
 Available only If Probe Type option is Single-Ended and Swing Type selection is 

Large or Small. 
*  Jitter @ BER variables are defined in the topic Measurement Result Queries Variable 
Names Part 2. 
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FBDIMM Receiver Measurement Names for the resultFor Variable 

Table 87. FBDIMM receiver measurement names for the resultFor variable 
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
Eye Width Yes   Yes  
Eye Height Yes maskUICount, 

maskHits 
 Yes maskUICount, 

maskHits 
Bit Rate Yes  Yes   
Rise Time Yes  Yes   
Fall Time Yes  Yes   
Differential Peak 
Voltage 

Yes   Yes  

AC CM Pk Voltage  Yes   Yes  
CM Voltage  Yes   Yes  
Jitter @ BER   Jitter @ BER 

variables** 
  Jitter @ BER 

variables* 
TIE Jitter  Yes  Yes   

 Available only if Probe Type option is Single-Ended. 
** Jitter @ BER variables are defined in the topic Measurement Result Queries Variable 
Names Part 2. 
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FBDIMM Reference Clock Measurement Names for the resultFor Variable 

Note: All measurements are available only for differential probe. 
 

Table 88. FBDIMM reference clock measurement names for the resultFor variable 
 Results when resultAcq= 
Measurement All Current 
Names Stats And … Stats Value And … 
High Voltage Yes   Yes  
Low Voltage Yes   Yes  
Rising Edge Yes  Yes   
Falling Edge Yes  Yes   
Frequency Yes  Yes   
Duty Cycle  Yes  Yes   
Jitter @ BER  Jitter @ BER 

variables† 
  Jitter @ BER 

variables† 
TIE Jitter  Yes  Yes   
  † Jitter @ BER variables are defined in the topic Measurement Result Queries Variable 
Names Part 2. 
  

 

GPIB Commands Error Codes  

Table 89. GPIB commands error codes 
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Code  Description 
E101 No measurements have been selected; select a measurement. 
E103 Record length changed in between. 
E105 Unable to initialize measurement sequence. 
E107 Unable to enable and display requested signal source. 
E108 Reduce record length or number of measurements, sequencing 

stopped. 
E109 Setup file is corrupted or there is another problem with recall. 
E151 Level too high for primary Vref High - Autoset Ref Level. 
E202 Upper range should be more than Lower range. 
E300 Oscilloscope signal acquisition failure due to PC memory limitation. 
E301 Sequencing was stopped; a timeout occurred while acquiring signal 

from the oscilloscope; check the signal or trigger level. 
E302 Waveform Math operation failed. 
E400 Measurement failed to complete successfully. 
E408 Missing data file or crossing times file. 
E410 Number of edges is not sufficient for a measurement. 
E417 Not enough Record Length for required analysis window. 
E420 Could not complete RjDj separation; less than 50 pattern repeats 

detected. 
E424 No edges or UI of required type are found in waveform; check the 

Vref threshold or record length. 
E425 Not enough good bits to perform arbitrary RjDj separation. Increase 

the record length or make more acquisitions. 
E430 Invalid Pattern Length. 
E435 Not enough edges to perform arbitrary RjDj separation. Increase 

record length. 
E440 Signal is unstable. Clock Recovery failed. 
E471 Time constant to remove the data edges is not correct. Adjust time 

constant within the range or acquire more data edges. 
E702 File not found; stopping sequencer. 
E703 I/O Error; stopping sequencer. 
E704 Unable to write worst case file; stopping sequencer. 
E800 File not found. 
E801 File already exists. 
E802 Cannot create the file. 
E803 Illegal character(s) in the file name. 
E804 Cannot create the directory. 
E805 Application .ini file successfully recalled, but the .set file was not 

recalled because it was not found or was corrupted. 
E806 Invalid CSV File/Incompatible CSV Files. 
E807 Invalid wfm File. 
E999 A recognized error has occurred. 
E1001 Process did not complete; no signal. 
E1002 Process did not complete; signal exceeds top of scale. 
E1003 Process did not complete; signal exceeds bottom of scale. 
E1004 Process did not complete; signal removed. 
E1005 Process did not complete; failed to measure rising and falling edge 

speed. 
E1006 Process did not complete; Horizontal resolution at maximum. 
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GPIB Commands Warning Codes 

Table 90. GPIB commands warning codes 
Code  Description 
W999 An unspecified warning has occurred. 
W410 Number of edges is not sufficient for a measurement. 
W402 RjDj separation accuracy not guaranteed; less than 100 pattern 

repeats detected. 
W701 Worst case waveform logging timed out while saving; stopping the 

sequencer. 
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